aboutsummaryrefslogtreecommitdiff
path: root/net/xorp
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-12-28 16:39:51 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-12-28 16:39:51 +0000
commit64d0df4091d788ab6f8715dc820e554e03fa241d (patch)
treee05720f7f9de98a9b50824a2962fb6bcead3ec8f /net/xorp
parent1906c9e8eaef3bfe8cb0bdf38597effcdf02b22a (diff)
downloadports-64d0df4091d788ab6f8715dc820e554e03fa241d.tar.gz
ports-64d0df4091d788ab6f8715dc820e554e03fa241d.zip
- Add patches to allow build with SNMP on.
- Change BUILD_DEPENDS= to BUILD_DEPENDS+= so that different options don't negate each other. - Set maintainer. PR: ports/163584 Submitted by: Anthony Chavez <acc@hexadecagram.org>
Notes
Notes: svn path=/head/; revision=288193
Diffstat (limited to 'net/xorp')
-rw-r--r--net/xorp/Makefile6
-rw-r--r--net/xorp/files/patch-mibs-bgp4_mib_1657_bgp4pathattrtable.cc35
-rw-r--r--net/xorp/files/patch-mibs-bgp4_mib_1657_bgppeertable.cc11
-rw-r--r--net/xorp/files/patch-mibs-xorpevents.cc11
-rw-r--r--net/xorp/pkg-plist1
5 files changed, 60 insertions, 4 deletions
diff --git a/net/xorp/Makefile b/net/xorp/Makefile
index 6425978ba175..d551d5620dea 100644
--- a/net/xorp/Makefile
+++ b/net/xorp/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.xorp.org/releases/${PORTVERSION}/ \
http://www5.xorp.org/releases/${PORTVERSION}/ \
http://www3.xorp.org/releases/${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= acc@hexadecagram.org
COMMENT= The eXtensible Open Router Platform
OPTIONS= \
@@ -52,7 +52,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
.if defined(WITH_SNMP)
-BUILD_DEPENDS= ${LOCALBASE}/sbin/snmpd:${PORTSDIR}/net-mgmt/net-snmp
+BUILD_DEPENDS+= ${LOCALBASE}/sbin/snmpd:${PORTSDIR}/net-mgmt/net-snmp
CONFIGURE_ARGS+= --with-snmp \
--with-path-to-snmpd=${LOCALBASE}/sbin \
--with-path-to-net-snmpd-config=${LOCALBASE}/bin/net-snmp-config \
@@ -69,7 +69,7 @@ CONFIGURE_ARGS+= --enable-optimize --disable-debug
# Bash and Python are only required if running the regression tests.
.if defined(WITH_CHECK)
-BUILD_DEPENDS= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python \
+BUILD_DEPENDS+= ${LOCALBASE}/bin/python:${PORTSDIR}/lang/python \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
.endif
diff --git a/net/xorp/files/patch-mibs-bgp4_mib_1657_bgp4pathattrtable.cc b/net/xorp/files/patch-mibs-bgp4_mib_1657_bgp4pathattrtable.cc
new file mode 100644
index 000000000000..dab5442fd7b3
--- /dev/null
+++ b/net/xorp/files/patch-mibs-bgp4_mib_1657_bgp4pathattrtable.cc
@@ -0,0 +1,35 @@
+--- mibs/bgp4_mib_1657_bgp4pathattrtable.cc.orig 2009-01-05 18:31:00.000000000 +0000
++++ mibs/bgp4_mib_1657_bgp4pathattrtable.cc 2011-12-27 03:17:03.000000000 +0000
+@@ -139,7 +139,7 @@
+ DEBUGMSGTL((BgpMib::the_instance().name(),
+ "updating local bgp4PathAttrTable...\n"));
+ DEBUGMSGTL((BgpMib::the_instance().name(),
+- "local table size: %d\n", CONTAINER_SIZE(cb.container)));
++ "local table size: %zd\n", CONTAINER_SIZE(cb.container)));
+ bgp_mib.send_get_v4_route_list_start("bgp", net, true, false,
+ callback(get_v4_route_list_start_done));
+ break;
+@@ -156,12 +156,12 @@
+ DEBUGMSGTL((BgpMib::the_instance().name(),
+ "removing old routes from bgp4PathAttrTable...\n"));
+ DEBUGMSGTL((BgpMib::the_instance().name(),
+- "local table size: %d old_routes stack: %d\n",
++ "local table size: %zd old_routes stack: %zd\n",
+ CONTAINER_SIZE(cb.container), update.old_routes.size()));
+ CONTAINER_FOR_EACH(cb.container, find_old_routes, NULL);
+ while (update.old_routes.size()) {
+ DEBUGMSGTL((BgpMib::the_instance().name(),
+- "update.old_routes.size() = %d\n",
++ "update.old_routes.size() = %zd\n",
+ update.old_routes.size()));
+ row = (bgp4PathAttrTable_context*)
+ CONTAINER_FIND(cb.container, &update.old_routes.top());
+@@ -745,7 +745,7 @@
+
+ if (row->update_signature != (update.list_token)) {
+ DEBUGMSGTL((BgpMib::the_instance().name(),
+- "removing %#010x from table\n", row->bgp4PathAttrIpAddrPrefix));
++ "removing %#010lx from table\n", row->bgp4PathAttrIpAddrPrefix));
+ update.old_routes.push(row->index);
+ }
+ }
diff --git a/net/xorp/files/patch-mibs-bgp4_mib_1657_bgppeertable.cc b/net/xorp/files/patch-mibs-bgp4_mib_1657_bgppeertable.cc
new file mode 100644
index 000000000000..1a1f1bd17b20
--- /dev/null
+++ b/net/xorp/files/patch-mibs-bgp4_mib_1657_bgppeertable.cc
@@ -0,0 +1,11 @@
+--- mibs/bgp4_mib_1657_bgppeertable.cc-orig 2011-12-27 00:37:40.000000000 +0000
++++ mibs/bgp4_mib_1657_bgppeertable.cc 2011-12-27 00:38:11.000000000 +0000
+@@ -476,7 +476,7 @@
+
+ void free_context(void * context, struct netsnmp_iterator_info_s * /* iinfo */)
+ {
+- DEBUGMSGTL((BgpMib::the_instance().name(),"freeing context %x\n", context));
++ DEBUGMSGTL((BgpMib::the_instance().name(),"freeing context %p\n", context));
+ if (NULL != context) free(context);
+ context = NULL;
+ }
diff --git a/net/xorp/files/patch-mibs-xorpevents.cc b/net/xorp/files/patch-mibs-xorpevents.cc
new file mode 100644
index 000000000000..28298d110291
--- /dev/null
+++ b/net/xorp/files/patch-mibs-xorpevents.cc
@@ -0,0 +1,11 @@
+--- mibs/xorpevents.cc-orig 2011-12-27 00:35:22.000000000 +0000
++++ mibs/xorpevents.cc 2011-12-27 00:36:01.000000000 +0000
+@@ -55,7 +55,7 @@
+ {
+ SnmpEventLoop& e = SnmpEventLoop::the_instance();
+ DEBUGMSGTL((e._log_name, "run all xorp timers\n"));
+- DEBUGMSGTL((e._log_name, "# of timers: %d\n", e.timer_list().size()));
++ DEBUGMSGTL((e._log_name, "# of timers: %zd\n", e.timer_list().size()));
+ e.timer_list().run();
+ SnmpEventLoop::AlarmMap::iterator p;
+ for (p = e._pending_alarms.begin(); p != e._pending_alarms.end(); ++p) {
diff --git a/net/xorp/pkg-plist b/net/xorp/pkg-plist
index b359b02c4836..8ce4aef5e057 100644
--- a/net/xorp/pkg-plist
+++ b/net/xorp/pkg-plist
@@ -111,7 +111,6 @@ xrl/targets/test_xrls.xrls
xrl/targets/vrrp.xrls
xrl/targets/xorp_if_mib.xrls
xrl/targets/xorpsh.xrls
-%%XORP_SNMP%%libdata/ldconfig/xorp
%%XORP_SNMP%%mibs/bgp4_mib_1657.la
%%XORP_SNMP%%mibs/bgp4_mib_1657.so
%%XORP_SNMP%%mibs/libnetsnmpxorp.la