aboutsummaryrefslogtreecommitdiff
path: root/net/xtraceroute
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-07-02 06:26:16 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-07-02 06:26:16 +0000
commit93da14444669d6902d0f1dcaa499661b28e5a21b (patch)
treeaea6381f81765ca1a9c9974c7a3e9ea2096b72f9 /net/xtraceroute
parentefdcddcab5e2eaed17d9cce05972816bafde358c (diff)
downloadports-93da14444669d6902d0f1dcaa499661b28e5a21b.tar.gz
ports-93da14444669d6902d0f1dcaa499661b28e5a21b.zip
- Correct dependencies - we need to use ``host'' command from the ports, not
from the base system; - remove explicit -O6 from the CFLAGS.
Notes
Notes: svn path=/head/; revision=44629
Diffstat (limited to 'net/xtraceroute')
-rw-r--r--net/xtraceroute/Makefile7
-rw-r--r--net/xtraceroute/files/patch-aa11
2 files changed, 14 insertions, 4 deletions
diff --git a/net/xtraceroute/Makefile b/net/xtraceroute/Makefile
index 777f77c1a1e8..c6cab6da2fa2 100644
--- a/net/xtraceroute/Makefile
+++ b/net/xtraceroute/Makefile
@@ -13,17 +13,18 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DATAFILES}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= host:${PORTSDIR}/net/host
+BUILD_DEPENDS= ${LOCALBASE}/bin/host:${PORTSDIR}/net/host
LIB_DEPENDS= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea \
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
-RUN_DEPENDS= host:${PORTSDIR}/net/host
+RUN_DEPENDS= ${LOCALBASE}/bin/host:${PORTSDIR}/net/host
USE_X_PREFIX= yes
USE_MESA= yes
USE_GTK= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-GL-prefix=${X11BASE}/lib \
- --with-lib-GL
+ --with-lib-GL \
+ --with-host=${LOCALBASE}/bin/host
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/net/xtraceroute/files/patch-aa b/net/xtraceroute/files/patch-aa
index 01493bfd1074..4c93a0ee9a1d 100644
--- a/net/xtraceroute/files/patch-aa
+++ b/net/xtraceroute/files/patch-aa
@@ -2,7 +2,7 @@
$FreeBSD$
--- configure.orig Wed Apr 18 17:26:37 2001
-+++ configure Thu Jun 28 23:54:08 2001
++++ configure Mon Jul 2 09:22:57 2001
@@ -2547,7 +2547,7 @@
cat conftest.$ac_ext >&5
rm -rf conftest*
@@ -12,3 +12,12 @@ $FreeBSD$
fi
rm -f conftest*
INSTOBJEXT=.mo
+@@ -3108,7 +3108,7 @@
+ if eval "test x$enable_debug = xyes"; then
+ CFLAGS="-g -Wall -DXT_DEBUG "
+ else
+- CFLAGS="-O6 $CFLAGS"
++# CFLAGS="-O6 $CFLAGS"
+ fi
+
+ xtraceroutedatadir=${datadir}/xtraceroute