aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-05-06 03:30:23 +0000
committerDoug Barton <dougb@FreeBSD.org>2012-05-06 03:30:23 +0000
commitd4deb92b18b7aec00b10096954878e64bc024839 (patch)
tree4febfd8a37f3dac16d0525fe4905bb2add18b447 /net
parent6a9616d188d4922707887b2c7d69f2362ed5c5d7 (diff)
downloadports-d4deb92b18b7aec00b10096954878e64bc024839.tar.gz
ports-d4deb92b18b7aec00b10096954878e64bc024839.zip
Fix use of set_rcvar() in rc.d script
Notes
Notes: svn path=/head/; revision=296071
Diffstat (limited to 'net')
-rw-r--r--net/istgt/Makefile2
-rw-r--r--net/istgt/files/patch-istgt-rc33
-rw-r--r--net/openistgt/Makefile2
-rw-r--r--net/openistgt/files/patch-istgt-rc33
4 files changed, 48 insertions, 22 deletions
diff --git a/net/istgt/Makefile b/net/istgt/Makefile
index 1e76063dbddf..5a3aa1d38187 100644
--- a/net/istgt/Makefile
+++ b/net/istgt/Makefile
@@ -7,7 +7,7 @@
PORTNAME= istgt
PORTVERSION= 20111008
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.peach.ne.jp/archives/istgt/
diff --git a/net/istgt/files/patch-istgt-rc b/net/istgt/files/patch-istgt-rc
index 9aafa4904853..4065054989a3 100644
--- a/net/istgt/files/patch-istgt-rc
+++ b/net/istgt/files/patch-istgt-rc
@@ -1,17 +1,26 @@
--- etc/istgt.sh.in.orig 2011-08-31 11:53:08.000000000 -0700
-+++ etc/istgt.sh.in 2012-03-07 17:12:49.615160257 -0800
-@@ -9,6 +9,7 @@
++++ etc/istgt.sh.in 2012-05-05 20:27:54.000000000 -0700
+@@ -8,19 +8,28 @@
+ . /etc/rc.subr
name="istgt"
- rcvar=`set_rcvar`
-+reload_cmd="istgt_reload"
- extra_commands="reload"
+-rcvar=`set_rcvar`
+-extra_commands="reload"
++rcvar=istgt_enable
load_rc_config $name
-@@ -18,6 +19,14 @@
- : ${istgt_pidfile="/var/run/istgt.pid"}
- : ${istgt_flags=""}
+-: ${istgt_enable="NO"}
++: ${istgt_enable:="NO"}
+ : ${istgt_config="%%CONFIGDIR%%/istgt.conf"}
+-: ${istgt_pidfile="/var/run/istgt.pid"}
+-: ${istgt_flags=""}
++
++pidfile=${istgt_pidfile:-"/var/run/istgt.pid"}
++
++reload_cmd="istgt_reload"
++extra_commands="reload"
++
+#
+# Refresh configuration
+#
@@ -19,7 +28,11 @@
+{
+ %%BINDIR%%/istgtcontrol refresh
+}
-+
+
required_files="${istgt_config}"
- pidfile="${istgt_pidfile}"
+-pidfile="${istgt_pidfile}"
command="%%BINDIR%%/istgt"
+-command_args="-c ${istgt_config} ${istgt_flags}"
++command_args="-c ${istgt_config}"
+
+ run_rc_command "$1"
diff --git a/net/openistgt/Makefile b/net/openistgt/Makefile
index 1e76063dbddf..5a3aa1d38187 100644
--- a/net/openistgt/Makefile
+++ b/net/openistgt/Makefile
@@ -7,7 +7,7 @@
PORTNAME= istgt
PORTVERSION= 20111008
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.peach.ne.jp/archives/istgt/
diff --git a/net/openistgt/files/patch-istgt-rc b/net/openistgt/files/patch-istgt-rc
index 9aafa4904853..4065054989a3 100644
--- a/net/openistgt/files/patch-istgt-rc
+++ b/net/openistgt/files/patch-istgt-rc
@@ -1,17 +1,26 @@
--- etc/istgt.sh.in.orig 2011-08-31 11:53:08.000000000 -0700
-+++ etc/istgt.sh.in 2012-03-07 17:12:49.615160257 -0800
-@@ -9,6 +9,7 @@
++++ etc/istgt.sh.in 2012-05-05 20:27:54.000000000 -0700
+@@ -8,19 +8,28 @@
+ . /etc/rc.subr
name="istgt"
- rcvar=`set_rcvar`
-+reload_cmd="istgt_reload"
- extra_commands="reload"
+-rcvar=`set_rcvar`
+-extra_commands="reload"
++rcvar=istgt_enable
load_rc_config $name
-@@ -18,6 +19,14 @@
- : ${istgt_pidfile="/var/run/istgt.pid"}
- : ${istgt_flags=""}
+-: ${istgt_enable="NO"}
++: ${istgt_enable:="NO"}
+ : ${istgt_config="%%CONFIGDIR%%/istgt.conf"}
+-: ${istgt_pidfile="/var/run/istgt.pid"}
+-: ${istgt_flags=""}
++
++pidfile=${istgt_pidfile:-"/var/run/istgt.pid"}
++
++reload_cmd="istgt_reload"
++extra_commands="reload"
++
+#
+# Refresh configuration
+#
@@ -19,7 +28,11 @@
+{
+ %%BINDIR%%/istgtcontrol refresh
+}
-+
+
required_files="${istgt_config}"
- pidfile="${istgt_pidfile}"
+-pidfile="${istgt_pidfile}"
command="%%BINDIR%%/istgt"
+-command_args="-c ${istgt_config} ${istgt_flags}"
++command_args="-c ${istgt_config}"
+
+ run_rc_command "$1"