aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-28 21:48:17 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-28 21:48:17 +0000
commit6ae29f40bef4389489966a2e20d3418023bac5c4 (patch)
tree7a9e55f8988ce615821d83aaeb455e27b57d3c0c /net
parent2d2fd3c93832399f86d6e9c56649408354854daa (diff)
downloadports-6ae29f40bef4389489966a2e20d3418023bac5c4.tar.gz
ports-6ae29f40bef4389489966a2e20d3418023bac5c4.zip
New port: net/ipa_ip6fw IPA accounting module for FreeBSD IPv6 Firewall
IPA_IP6FW -- IPA accounting module for FreeBSD IPv6 Firewall Main features: - The module is designed for traffic accounting from FreeBSD IPv6 Firewall rules byte counters; - The module understands IPv6 Firewall rules byte counters overflow; - It is possible to summarize and subtract statistics from IPv6 Firewall rules byte counters; - It is possible to distinguish IPv6 Firewall rules with the same numbers; - IPv6 Firewall rules can be dynamically added to and removed from the system, the module correctly works in such situations. WWW: http://ipa-system.sourceforge.net/modules/ipa_ip6fw/ PR: ports/91005 Submitted by: Andrey Simonenko <simon@comsys.ntu-kpi.kiev.ua>
Notes
Notes: svn path=/head/; revision=152304
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ipa_ip6fw/Makefile52
-rw-r--r--net/ipa_ip6fw/distinfo3
-rw-r--r--net/ipa_ip6fw/pkg-descr18
4 files changed, 74 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5c31983e65f6..dbda7cba0088 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -220,6 +220,7 @@
SUBDIR += ifstated
SUBDIR += imapproxy
SUBDIR += ip6_int
+ SUBDIR += ipa_ip6fw
SUBDIR += ipa_ipfw
SUBDIR += ipex
SUBDIR += ipfw-graph
diff --git a/net/ipa_ip6fw/Makefile b/net/ipa_ip6fw/Makefile
new file mode 100644
index 000000000000..a7145852b634
--- /dev/null
+++ b/net/ipa_ip6fw/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: ipa_ip6fw
+# Date created: 27 December 2005
+# Whom: Andrey Simonenko
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipa_ip6fw
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://ipa-system.sourceforge.net/modules/ipa_ip6fw/
+
+MAINTAINER= simon@comsys.ntu-kpi.kiev.ua
+COMMENT= IPA accounting module for FreeBSD IPv6 Firewall
+
+NO_PACKAGE= "Needs to be built uniquely for each host"
+
+USE_BZIP2= yes
+
+OPTIONS= PTHREAD "Build pthread safe module" off \
+ DEBUG_INFO "Produce debugging info" off \
+ MAN_KOI8_R "Install Russian manual pages" off
+
+.include <bsd.port.pre.mk>
+
+.ifdef WITH_PTHREAD
+MAKE_ENV+= WITH_PTHREAD=yes
+CFLAGS+= ${PTHREAD_CFLAGS}
+.endif
+
+.ifdef WITHOUT_DEBUG_INFO
+MAKE_ENV+= DEBUG_FLAGS=""
+.endif
+
+BUILD_DEPENDS= ${PREFIX}/include/ipa_mod.h:${PORTSDIR}/sysutils/ipa
+
+PLIST_FILES= lib/ipa_ip6fw.so
+
+MANCOMPRESSED= yes
+MAN8= ipa_ip6fw.8
+MANLANG= ""
+.ifdef WITH_MAN_KOI8_R
+MANLANG+= ru.KOI8-R
+.endif
+
+do-install:
+ cd ${WRKSRC} && make install
+.ifdef WITH_MAN_KOI8_R
+ cd ${WRKSRC}/man && make LANG_DIR_SRC=ru.KOI8-R clean all install
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/ipa_ip6fw/distinfo b/net/ipa_ip6fw/distinfo
new file mode 100644
index 000000000000..70fab5031f47
--- /dev/null
+++ b/net/ipa_ip6fw/distinfo
@@ -0,0 +1,3 @@
+MD5 (ipa_ip6fw-1.0.tar.bz2) = 77811d19375fbfcd227ede4ca6b07158
+SHA256 (ipa_ip6fw-1.0.tar.bz2) = c6fb47c5818d333f284ce85a971da2dd5b6870a0112f402e9085c5c9f4f233c7
+SIZE (ipa_ip6fw-1.0.tar.bz2) = 16466
diff --git a/net/ipa_ip6fw/pkg-descr b/net/ipa_ip6fw/pkg-descr
new file mode 100644
index 000000000000..16b02d4a04c2
--- /dev/null
+++ b/net/ipa_ip6fw/pkg-descr
@@ -0,0 +1,18 @@
+IPA_IP6FW -- IPA accounting module for FreeBSD IPv6 Firewall
+
+Main features:
+
+- The module is designed for traffic accounting from FreeBSD IPv6
+ Firewall rules byte counters;
+- The module understands IPv6 Firewall rules byte counters overflow;
+- It is possible to summarize and subtract statistics from IPv6
+ Firewall rules byte counters;
+- It is possible to distinguish IPv6 Firewall rules with the same
+ numbers;
+- IPv6 Firewall rules can be dynamically added to and removed from
+ the system, the module correctly works in such situations.
+
+WWW: http://ipa-system.sourceforge.net/modules/ipa_ip6fw/
+
+- Andrey Simonenko
+simon@comsys.ntu-kpi.kiev.ua