aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2009-01-08 17:59:41 +0000
committerErwin Lansing <erwin@FreeBSD.org>2009-01-08 17:59:41 +0000
commitccd4eff1b49405149cc8a1e3c63c91b60f702921 (patch)
treec769ea8a7b1f42825b281acc0901c94362fa2a02 /net
parent5757f03eeed24bdada5085da183cd186c3aa99b1 (diff)
downloadports-ccd4eff1b49405149cc8a1e3c63c91b60f702921.tar.gz
ports-ccd4eff1b49405149cc8a1e3c63c91b60f702921.zip
Mark BROKEN on 8: does not build after the arp-v2 import.
Submitted by: pointyhat
Notes
Notes: svn path=/head/; revision=225509
Diffstat (limited to 'net')
-rw-r--r--net/olsrd/Makefile4
-rw-r--r--net/openbgpd/Makefile8
-rw-r--r--net/openospfd/Makefile8
-rw-r--r--net/p5-Net-ARP/Makefile8
-rw-r--r--net/quagga/Makefile4
-rw-r--r--net/trafshow3/Makefile8
-rw-r--r--net/wackamole/Makefile8
-rw-r--r--net/zebra/Makefile4
8 files changed, 47 insertions, 5 deletions
diff --git a/net/olsrd/Makefile b/net/olsrd/Makefile
index b830a86ead4d..06a7ee618e4d 100644
--- a/net/olsrd/Makefile
+++ b/net/olsrd/Makefile
@@ -41,6 +41,10 @@ MAKE_ARGS+= PREFIX=${PREFIX}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800059
+BROKEN= does not build
+.endif
+
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
CFLAGS+= -fPIC
.endif
diff --git a/net/openbgpd/Makefile b/net/openbgpd/Makefile
index bbb11e8cc529..19f4f80e06f9 100644
--- a/net/openbgpd/Makefile
+++ b/net/openbgpd/Makefile
@@ -86,4 +86,10 @@ post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800059
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/openospfd/Makefile b/net/openospfd/Makefile
index 1d047ed39216..4d6309e10e4b 100644
--- a/net/openospfd/Makefile
+++ b/net/openospfd/Makefile
@@ -73,4 +73,10 @@ do-install:
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800059
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-ARP/Makefile b/net/p5-Net-ARP/Makefile
index 5e5121de019b..eb3712abae28 100644
--- a/net/p5-Net-ARP/Makefile
+++ b/net/p5-Net-ARP/Makefile
@@ -21,4 +21,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAN3= Net::ARP.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800059
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 661639579093..3373fa23126e 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -44,6 +44,10 @@ OPTIONS= ISISD "Enable experimental ISIS daemon" off \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800059
+BROKEN= does not build
+.endif
+
CONFIGURE_ARGS+=--includedir=${PREFIX}/include --enable-exampledir=${PREFIX}/share/examples/quagga --enable-pidfile-mask=0644
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
diff --git a/net/trafshow3/Makefile b/net/trafshow3/Makefile
index 7ea0e8b686d7..6e38956c71f7 100644
--- a/net/trafshow3/Makefile
+++ b/net/trafshow3/Makefile
@@ -43,4 +43,10 @@ do-install:
${CP} ${PREFIX}/etc/trafshow.dist ${PREFIX}/etc/trafshow; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800059
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/wackamole/Makefile b/net/wackamole/Makefile
index 0189aabe512c..01be6470e990 100644
--- a/net/wackamole/Makefile
+++ b/net/wackamole/Makefile
@@ -22,4 +22,10 @@ CONFIGURE_ENV+= YACC=${YACC}
MAN5= wackamole.conf.5
MAN8= wackamole.8 wackatrl.8
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800059
+BROKEN= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/zebra/Makefile b/net/zebra/Makefile
index f282b138bf88..4ebff0671ad1 100644
--- a/net/zebra/Makefile
+++ b/net/zebra/Makefile
@@ -45,6 +45,10 @@ INFO= zebra
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800059
+BROKEN= does not build
+.endif
+
.if defined (WITHOUT_IPV6)
CONFIGURE_ARGS+=--disable-ipv6
WITHOUT_OSPF6D= yes