aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorYi-Jheng Lin <yzlin@FreeBSD.org>2009-08-13 09:05:20 +0000
committerYi-Jheng Lin <yzlin@FreeBSD.org>2009-08-13 09:05:20 +0000
commit89a046b07fa28c64077de9f37ad8425f475bf430 (patch)
treeb4dce83a996678d848a7651c4cfdf199471228e7 /net
parent6c5f7fffe5a76bc7aa10e6a5721f341589b53cc7 (diff)
downloadports-89a046b07fa28c64077de9f37ad8425f475bf430.tar.gz
ports-89a046b07fa28c64077de9f37ad8425f475bf430.zip
- Fix and sort pkg-plist
- Bump PORTREVISION PR: ports/137520 Submitted by: Sofian Brabez <sbrabez AT gmail.com> (maintainer) Approved by: rafan (co-mentor)
Notes
Notes: svn path=/head/; revision=239421
Diffstat (limited to 'net')
-rw-r--r--net/py-libnet/Makefile7
-rw-r--r--net/py-libnet/pkg-plist6
2 files changed, 10 insertions, 3 deletions
diff --git a/net/py-libnet/Makefile b/net/py-libnet/Makefile
index 1c2b76e52890..7f8a3782c004 100644
--- a/net/py-libnet/Makefile
+++ b/net/py-libnet/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libnet
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= SF
MASTER_SITE_SUBDIR= pylibnet
@@ -45,8 +46,12 @@ BROKEN= Does not compile on amd64 (tries to link non-PIC libnet.a into PIC shar
post-patch:
${REINPLACE_CMD} -e 's,^const ,%constant ,' ${WRKSRC}/constants.i
+post-build:
+ ${PYTHON_CMD} -m compileall ${WRKSRC}
+ ${PYTHON_CMD} -O -m compileall ${WRKSRC}
+
do-install:
-.for f in libnet.py _libnet.so
+.for f in libnet.py libnet.pyc libnet.pyo _libnet.so
${INSTALL_DATA} ${WRKSRC}/${f} ${PYTHON_SITELIBDIR}
.endfor
.if !defined(NOPORTEXAMPLES)
diff --git a/net/py-libnet/pkg-plist b/net/py-libnet/pkg-plist
index d9fbad2ef0c0..fbedc9003fb5 100644
--- a/net/py-libnet/pkg-plist
+++ b/net/py-libnet/pkg-plist
@@ -1,7 +1,9 @@
@comment $FreeBSD$
-%%PYTHON_SITELIBDIR%%/libnet.py
%%PYTHON_SITELIBDIR%%/_libnet.so
+%%PYTHON_SITELIBDIR%%/libnet.py
+%%PYTHON_SITELIBDIR%%/libnet.pyc
+%%PYTHON_SITELIBDIR%%/libnet.pyo
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-libnet-arp-req.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-libnet-icmp-echo-req.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-libnet-tcp-syn.py
-@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%