aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-09-21 11:06:03 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-09-21 11:06:03 +0000
commit1e3119b07ebe66367ead55242a47710e556bf383 (patch)
tree2051ba0023bbf060fa37051dc7fc6990710a53b1 /net
parent0dea0192303406b3b949a31479a4264b58bafce6 (diff)
downloadports-1e3119b07ebe66367ead55242a47710e556bf383.tar.gz
ports-1e3119b07ebe66367ead55242a47710e556bf383.zip
- fix misplaced NO_STAGE in slaveports and ifdefs
Notes
Notes: svn path=/head/; revision=327804
Diffstat (limited to 'net')
-rw-r--r--net/freebsd-uucp/Makefile3
-rw-r--r--net/libnet/Makefile2
-rw-r--r--net/libnet10/Makefile3
-rw-r--r--net/miniupnpc/Makefile2
-rw-r--r--net/py-miniupnpc/Makefile1
-rw-r--r--net/radiusd-cistron/Makefile2
-rw-r--r--net/sixxs-aiccu/Makefile3
-rw-r--r--net/tinyldap/Makefile3
-rw-r--r--net/x11vnc/Makefile4
9 files changed, 13 insertions, 10 deletions
diff --git a/net/freebsd-uucp/Makefile b/net/freebsd-uucp/Makefile
index 737bd7ceb8d0..390997d0ec70 100644
--- a/net/freebsd-uucp/Makefile
+++ b/net/freebsd-uucp/Makefile
@@ -12,6 +12,8 @@ PKGNAMESUFFIX?= ${PAM_SUFFIX}${PKGNAMESUFFIX2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= FreeBSD-modified Taylor UUCP (unix-to-unix copy program)
+NO_STAGE= yes
+
USE_BZIP2= yes
MANCOMPRESSED= yes
@@ -29,7 +31,6 @@ BPKGNAME= base-uucp-1.06.1
# fix errros for -std=iso9899:1999 in FreeBSD 5.1
MAKE_ENV+= CSTD=gnu99
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if defined(WITH_PAM)
diff --git a/net/libnet/Makefile b/net/libnet/Makefile
index d51b450074bd..3aa3ba861b7f 100644
--- a/net/libnet/Makefile
+++ b/net/libnet/Makefile
@@ -13,6 +13,7 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= A C library for creating IP packets
LATEST_LINK= ${PORTNAME}${SHORT_VER}
+NO_STAGE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
@@ -38,7 +39,6 @@ OPTIONS_DEFINE= EXAMPLES DOCS BPF
OPTIONS_DEFAULT= BPF
BPF_DESC= link layer bpf
-NO_STAGE= yes
.include <bsd.port.options.mk>
LIBNET_LINK= none
diff --git a/net/libnet10/Makefile b/net/libnet10/Makefile
index 838581ec0a11..7fc023c483e7 100644
--- a/net/libnet10/Makefile
+++ b/net/libnet10/Makefile
@@ -14,6 +14,8 @@ PKGNAMESUFFIX= 10
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A C library for creating IP packets
+NO_STAGE= yes
+
CFLAGS+= -fPIC
USE_AUTOTOOLS= autoconf
@@ -21,7 +23,6 @@ WRKSRC= ${WRKDIR}/Libnet-${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
MAN3= libnet${PKGNAMESUFFIX}.3
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
diff --git a/net/miniupnpc/Makefile b/net/miniupnpc/Makefile
index 5f449b86f38a..012dfd673352 100644
--- a/net/miniupnpc/Makefile
+++ b/net/miniupnpc/Makefile
@@ -11,6 +11,7 @@ COMMENT?= UPnP IGD client lightweight library
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
+NO_STAGE= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
@@ -19,7 +20,6 @@ USE_LDCONFIG= yes
CONFIGURE_SCRIPT= updateminiupnpcstrings.sh
MAKE_ENV+= INSTALLPREFIX=${PREFIX}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
diff --git a/net/py-miniupnpc/Makefile b/net/py-miniupnpc/Makefile
index 98b6519c2425..9f2b837d81a6 100644
--- a/net/py-miniupnpc/Makefile
+++ b/net/py-miniupnpc/Makefile
@@ -16,7 +16,6 @@ WRKDIR= ${WRKDIRPREFIX}${MASTERDIR}/work
PLIST= ${.CURDIR}/pkg-plist
.if exists(${.CURDIR}/Makefile.local)
-NO_STAGE= yes
.include "${.CURDIR}/Makefile.local"
.endif
diff --git a/net/radiusd-cistron/Makefile b/net/radiusd-cistron/Makefile
index 79b4d0b560e9..72894104ff49 100644
--- a/net/radiusd-cistron/Makefile
+++ b/net/radiusd-cistron/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A RADIUS-compliant remote authentication and accounting server
CONFLICTS?= freeradius-0.* gnu-radius-1.* openradius-0.*
+NO_STAGE= yes
MAKEFILE= Makefile.BSD
RADIUS_DIR= ${PREFIX}/etc/raddb
@@ -26,7 +27,6 @@ DOCFILES= COPYRIGHT INSTALL doc/ChangeLog doc/README doc/README.Y2K \
doc/README.cisco doc/README.pam doc/README.proxy \
doc/README.simul doc/README.usersfile
-NO_STAGE= yes
do-build:
cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${MAKE} -f ${MAKEFILE}
diff --git a/net/sixxs-aiccu/Makefile b/net/sixxs-aiccu/Makefile
index 6ce64165cbf3..e07ecc0cc110 100644
--- a/net/sixxs-aiccu/Makefile
+++ b/net/sixxs-aiccu/Makefile
@@ -17,6 +17,8 @@ LIB_DEPENDS= gnutls-openssl:${PORTSDIR}/security/gnutls
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/doc/LICENSE
+NO_STAGE= yes
+
USE_RC_SUBR= sixxs-aiccu
USE_GMAKE= yes
@@ -27,7 +29,6 @@ WRKSRC= ${WRKDIR}/aiccu
BUILD_WRKSRC= ${WRKDIR}/aiccu/unix-console
PORTDOCS= README
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} \
-e 's:verbose true:verbose false:' \
diff --git a/net/tinyldap/Makefile b/net/tinyldap/Makefile
index 4855cfb87b3f..f7cb747871da 100644
--- a/net/tinyldap/Makefile
+++ b/net/tinyldap/Makefile
@@ -14,6 +14,8 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/${LIBOWFAT_PORT}
LICENSE= GPLv2
+NO_STAGE= yes
+
SNAPSHOT= 20091122
USE_BZIP2= yes
USE_GMAKE= yes
@@ -28,7 +30,6 @@ BINFILES= ldapclient ldapclient_str md5password mysql2ldif \
DOCFILES= ACL FORMAT GETTING.STARTED README README.security RFCs \
THANKS TODO
-NO_STAGE= yes
post-patch:
${TOUCH} ${WRKSRC}/alloca.h
${REINPLACE_CMD} -e "s|\"data\"|\"${TINYLDAP_DATA}\"|" \
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index 167941a087da..9d1c6a462a3b 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -16,9 +16,10 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
dbus:${PORTSDIR}/devel/dbus \
pthread-stubs:${PORTSDIR}/devel/libpthread-stubs
+NO_STAGE= yes
+
USE_XORG= x11 xcb xdamage xfixes xrandr xinerama xext xtst xau xrender \
xdmcp recordproto
-
# Sets LDFLAGS and adds to CONFIGURE_ENV, therefore we set LDFLAGS
LDFLAGS+= -L${LOCALBASE}/lib
USE_OPENSSL= yes
@@ -33,7 +34,6 @@ OPTIONS_DEFINE=NLS AVAHI
OPTIONS_DEFAULT=NLS AVAHI
NO_OPTIONS_SORT=yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}