aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-11-09 19:13:27 +0000
committerRene Ladan <rene@FreeBSD.org>2013-11-09 19:13:27 +0000
commitbfc52e710421bd92466b329f6fbb9be930eb4755 (patch)
tree7436338612f22a81def9ee6c2d2e3826c1504ea4 /net
parent16a624cb31062d141fd07c5dc3f7794ed7fe74cd (diff)
downloadports-bfc52e710421bd92466b329f6fbb9be930eb4755.tar.gz
ports-bfc52e710421bd92466b329f6fbb9be930eb4755.zip
Convert to USES=kmod, which removes duplicated code and ensures that all
required steps are followed. There are no user-visible changes. The exception is multimedia/ptx-kmod, which now installs the kernel module into /boot/modules instead of ${PREFIX}/libexec/${PORTNAME}, this was something USES=kmod cannot handle. PR: ports/183625 Submitted by: myself Approved by: portmgr (bdrewery) Exp-run by: bdrewery
Notes
Notes: svn path=/head/; revision=333329
Diffstat (limited to 'net')
-rw-r--r--net/bwi-firmware-kmod/Makefile8
-rw-r--r--net/bwi-firmware-kmod/pkg-plist2
-rw-r--r--net/bwn-firmware-kmod/Makefile8
-rw-r--r--net/bwn-firmware-kmod/pkg-plist2
-rw-r--r--net/stf-6rd-kmod/Makefile11
-rw-r--r--net/stf-6rd-kmod/pkg-plist2
6 files changed, 11 insertions, 22 deletions
diff --git a/net/bwi-firmware-kmod/Makefile b/net/bwi-firmware-kmod/Makefile
index e6ef1324fefa..6903beea7b08 100644
--- a/net/bwi-firmware-kmod/Makefile
+++ b/net/bwi-firmware-kmod/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bwi-firmware
PORTVERSION= ${FWVERSION}
-CATEGORIES= net kld
+CATEGORIES= net
MASTER_SITES= http://downloads.openwrt.org/sources/ \
http://mirror2.openwrt.org/sources/
PKGNAMESUFFIX= -kmod
@@ -25,14 +25,14 @@ WRKSRC= ${WRKDIR}
FWNAME= bwi_v3
FWFILE= wl_apsta-${FWVERSION}.0.o
FWVERSION= 3.130.20
-KMODDIR= /boot/modules
KMODNAME= ${FWNAME}_ucode
-PLIST_SUB= KMODNAME="${KMODNAME}" \
- KMODDIR="${KMODDIR}"
+PLIST_SUB= KMODNAME="${KMODNAME}"
NO_PACKAGE= this is a modified version of a restricted firmware
NO_STAGE= yes
+
+USES= kmod
.include <bsd.port.pre.mk>
do-build:
diff --git a/net/bwi-firmware-kmod/pkg-plist b/net/bwi-firmware-kmod/pkg-plist
index 330be96cdcd5..9a46a1f98369 100644
--- a/net/bwi-firmware-kmod/pkg-plist
+++ b/net/bwi-firmware-kmod/pkg-plist
@@ -1,4 +1,2 @@
@cwd %%KMODDIR%%
%%KMODNAME%%.ko
-@exec kldxref %%KMODDIR%%
-@unexec kldxref %%KMODDIR%%
diff --git a/net/bwn-firmware-kmod/Makefile b/net/bwn-firmware-kmod/Makefile
index 218fc86c3c9f..297e0eaf290d 100644
--- a/net/bwn-firmware-kmod/Makefile
+++ b/net/bwn-firmware-kmod/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bwn-firmware
PORTVERSION= 0.1.0
-CATEGORIES= net kld
+CATEGORIES= net
MASTER_SITES= http://downloads.openwrt.org/sources/ \
http://mirror2.openwrt.org/sources/
PKGNAMESUFFIX= -kmod
@@ -42,14 +42,14 @@ FWNAME_LP= bwn_v4_lp
FWFILE_LP= broadcom-wl-${FWVERSION_LP}.tar.bz2
FWVERSION_LP= 4.178.10.4
KMODNAME_LP= ${FWNAME_LP}_ucode
-KMODDIR= /boot/modules
PLIST_SUB= KMODNAME="${KMODNAME}" \
- KMODNAME_LP="${KMODNAME_LP}" \
- KMODDIR="${KMODDIR}"
+ KMODNAME_LP="${KMODNAME_LP}"
NO_PACKAGE= this is a modified version of a restricted firmware
NO_STAGE= yes
+
+USES= kmod
.include <bsd.port.pre.mk>
do-build:
diff --git a/net/bwn-firmware-kmod/pkg-plist b/net/bwn-firmware-kmod/pkg-plist
index 4135df6d6174..db363bbe39ec 100644
--- a/net/bwn-firmware-kmod/pkg-plist
+++ b/net/bwn-firmware-kmod/pkg-plist
@@ -1,5 +1,3 @@
@cwd %%KMODDIR%%
%%KMODNAME%%.ko
%%KMODNAME_LP%%.ko
-@exec kldxref %%KMODDIR%%
-@unexec kldxref %%KMODDIR%%
diff --git a/net/stf-6rd-kmod/Makefile b/net/stf-6rd-kmod/Makefile
index 6d6492dbb5c0..ea5c6ac8a7e0 100644
--- a/net/stf-6rd-kmod/Makefile
+++ b/net/stf-6rd-kmod/Makefile
@@ -2,7 +2,7 @@
PORTNAME= stf
PORTVERSION= 0.${SVN_REV}
-CATEGORIES= net ipv6 kld
+CATEGORIES= net ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= kuriyama
PKGNAMESUFFIX= -6rd-kmod
@@ -15,14 +15,10 @@ ONLY_FOR_ARCHS= amd64 i386
WRKSRC= ${WRKDIR}
SVN_REV= 239080 # 8.1=r209773, 8.2=r216741, 8.3=r232314
-KMODDIR?= /boot/modules
-PLIST_SUB= KMODDIR=${KMODDIR:C,^/,,}
-
-.if !exists(${SRC_BASE}/sys/Makefile)
-IGNORE= requires kernel source to be installed
-.endif
NO_STAGE= yes
+
+USES= kmod
.include <bsd.port.pre.mk>
.if ${OSREL} != "8.1" && ${OSREL} != "8.2" && ${OSREL} != "8.3" && ${OSREL} != "8.4" && ${OSREL} != "9.1"
@@ -47,7 +43,6 @@ do-install:
${INSTALL_KLD} ${WRKSRC}/sys/modules/if_stf/${f}.ko ${KMODDIR}
${INSTALL_KLD} ${WRKSRC}/sys/modules/if_stf/${f}.ko.symbols ${KMODDIR}
.endfor
- /usr/sbin/kldxref ${KMODDIR}
post-install:
${CAT} ${PKGMESSAGE}
diff --git a/net/stf-6rd-kmod/pkg-plist b/net/stf-6rd-kmod/pkg-plist
index e9ef29e780d0..9cc78435e819 100644
--- a/net/stf-6rd-kmod/pkg-plist
+++ b/net/stf-6rd-kmod/pkg-plist
@@ -1,5 +1,3 @@
@cwd /
%%KMODDIR%%/if_stf.ko
%%KMODDIR%%/if_stf.ko.symbols
-@exec /usr/sbin/kldxref /%%KMODDIR%%
-@unexec /usr/sbin/kldxref /%%KMODDIR%%