aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
commitf899c758a653ca8ff2f8a63aafcb2519a0b524ed (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /net
parent74d26774f830684ae21247061aa4bd7dabbe6527 (diff)
downloadports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.tar.gz
ports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.zip
When there is a do-install target, do not use a post-install target, do
everything at once. Sometime, rename post-install into a options helper target. I did not fix ports that were such a mess that I could not figure out what they really wanted to do. I also did not change ports that had some version of an auto-plist code in post-install, for the same reason. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=418767
Diffstat (limited to 'net')
-rw-r--r--net/delegate/Makefile2
-rw-r--r--net/dgd-kernel/Makefile2
-rw-r--r--net/dgd-lpmud/Makefile10
-rw-r--r--net/drawterm/Makefile2
-rw-r--r--net/gogoc/Makefile2
-rw-r--r--net/isc-dhcp43-server/Makefile2
-rw-r--r--net/java-beepcore/Makefile2
-rw-r--r--net/pipsecd/Makefile3
-rw-r--r--net/pwhois/Makefile6
-rw-r--r--net/remotebox/Makefile2
-rw-r--r--net/tn5250j/Makefile2
-rw-r--r--net/unison-devel/Makefile1
-rw-r--r--net/unison/Makefile1
-rw-r--r--net/unison232/Makefile1
-rw-r--r--net/unison240/Makefile1
-rw-r--r--net/vnstat/Makefile4
16 files changed, 11 insertions, 32 deletions
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index 05136147a688..64404be9ee68 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -37,8 +37,6 @@ do-install:
${STAGEDIR}${PREFIX}/etc/rc.d/delegated.sh-dist
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}
-
-post-install:
# Re-sign the executable
@${MKDIR} ${WRKDIR}/tmp
@${CP} ${STAGEDIR}${PREFIX}/sbin/delegated ${WRKDIR}/tmp/dg
diff --git a/net/dgd-kernel/Makefile b/net/dgd-kernel/Makefile
index c9fb593baefc..0c45a24611e3 100644
--- a/net/dgd-kernel/Makefile
+++ b/net/dgd-kernel/Makefile
@@ -43,8 +43,6 @@ do-install:
@${CHMOD} a+x ${STAGEDIR}${PREFIX}/etc/rc.d/dgd-kernel.sh.sample
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@cd ${WRKSRC}/kernellib && ${COPYTREE_SHARE} doc ${STAGEDIR}${DOCSDIR}
-
-post-install:
@# Need a temporary directory for certain files
@${MKDIR} ${STAGEDIR}${DATADIR}/tmp
diff --git a/net/dgd-lpmud/Makefile b/net/dgd-lpmud/Makefile
index 6e9b34b425dc..3b98d5533598 100644
--- a/net/dgd-lpmud/Makefile
+++ b/net/dgd-lpmud/Makefile
@@ -50,15 +50,13 @@ do-install:
${STAGEDIR}${DATADIR}/lpmud/ACCESS.ALLOW.example
${MV} ${STAGEDIR}${DATADIR}/lpmud/ACCESS.DENY \
${STAGEDIR}${DATADIR}/lpmud/ACCESS.DENY.example
-
-do-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-
-post-install:
# Need a temporary directory for certain files
${MKDIR} ${STAGEDIR}${DATADIR}/tmp
# Link in the dgd docs
${LN} -sf ${PREFIX}/share/doc/dgd/kfun ${STAGEDIR}${DATADIR}/lpmud/doc
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/net/drawterm/Makefile b/net/drawterm/Makefile
index 94d057e901aa..44fbdd86130c 100644
--- a/net/drawterm/Makefile
+++ b/net/drawterm/Makefile
@@ -27,7 +27,7 @@ OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/drawterm ${STAGEDIR}${PREFIX}/bin
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/README ${WRKSRC}/LICENSE ${STAGEDIR}${DOCSDIR}
diff --git a/net/gogoc/Makefile b/net/gogoc/Makefile
index 032e6f12fc28..66b94799efbf 100644
--- a/net/gogoc/Makefile
+++ b/net/gogoc/Makefile
@@ -30,8 +30,6 @@ do-install:
cd ${WRKSRC}/gogoc-tsp/ && ${SETENV} ${MAKE_ENV} DESTDIR=${STAGEDIR} \
${MAKE_CMD} platform=freebsd installdir=${STAGEDIR}${PREFIX} install
${RM} ${STAGEDIR}${PREFIX}/bin/gogoc.conf*
-
-post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/gogoc
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/gogoc-tsp/bin/gogoc.conf.sample ${STAGEDIR}${EXAMPLESDIR}
diff --git a/net/isc-dhcp43-server/Makefile b/net/isc-dhcp43-server/Makefile
index 07fa00e63b5c..02b4e833db82 100644
--- a/net/isc-dhcp43-server/Makefile
+++ b/net/isc-dhcp43-server/Makefile
@@ -167,8 +167,6 @@ do-install:
${INSTALL_MAN} ${LDAP_README} ${STAGEDIR}${DOCSDIR}
.endif
.endif
-
-post-install:
.if ${SUBSYS} == client
${INSTALL_SCRIPT} ${WRKSRC}/client/scripts/freebsd ${STAGEDIR}${PREFIX}/sbin/dhclient-script
.elif ${SUBSYS} == server
diff --git a/net/java-beepcore/Makefile b/net/java-beepcore/Makefile
index 5ecfc758f01c..7659760caadf 100644
--- a/net/java-beepcore/Makefile
+++ b/net/java-beepcore/Makefile
@@ -27,7 +27,7 @@ do-install:
&& ${FIND} -s . -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR}/{} \;)
${INSTALL_DATA} ${WRKSRC}/lib/example.jar ${STAGEDIR}${EXAMPLESDIR}
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${WRKSRC}/*.htm ${STAGEDIR}${DOCSDIR}
diff --git a/net/pipsecd/Makefile b/net/pipsecd/Makefile
index 53123435c2a0..d77ccbd4a645 100644
--- a/net/pipsecd/Makefile
+++ b/net/pipsecd/Makefile
@@ -29,7 +29,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/COPYRIGHT ${STAGEDIR}${PREFIX}/share/doc/pipsecd
${INSTALL_MAN} ${WRKSRC}/README.port ${STAGEDIR}${PREFIX}/share/doc/pipsecd
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/pipsecd
-
.include <bsd.port.mk>
diff --git a/net/pwhois/Makefile b/net/pwhois/Makefile
index c4daf669bbb7..289a44e289d9 100644
--- a/net/pwhois/Makefile
+++ b/net/pwhois/Makefile
@@ -56,9 +56,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/pwhoisd.conf \
${STAGEDIR}${ETCDIR}/pwhoisd.conf.sample
@${INSTALL_DATA} ${WRKSRC}/mysql/createdb.sql ${STAGEDIR}${DATADIR}/
-
-post-install:
- @${INSTALL} -d -o 512 -g 512 ${STAGEDIR}/var/db/pwhois
- @${INSTALL} -d -o 512 -g 512 ${STAGEDIR}/var/log/pwhois
+ @${INSTALL} -d ${STAGEDIR}/var/db/pwhois
+ @${INSTALL} -d ${STAGEDIR}/var/log/pwhois
.include <bsd.port.mk>
diff --git a/net/remotebox/Makefile b/net/remotebox/Makefile
index 67ac06c5ae47..92b9082216db 100644
--- a/net/remotebox/Makefile
+++ b/net/remotebox/Makefile
@@ -47,7 +47,7 @@ do-install:
${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop \
${STAGEDIR}${PREFIX}/share/applications
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/docs/remotebox.pdf ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/docs/changelog.txt ${STAGEDIR}${DOCSDIR}
diff --git a/net/tn5250j/Makefile b/net/tn5250j/Makefile
index f824aad81bbc..225c4d521701 100644
--- a/net/tn5250j/Makefile
+++ b/net/tn5250j/Makefile
@@ -53,7 +53,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/tn5250j ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/build/tn5250j.jar ${STAGEDIR}${JAVAJARDIR}
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for d in ${DOC_FILES}
${INSTALL_MAN} ${WRKSRC}/src/${d} ${STAGEDIR}${DOCSDIR}
diff --git a/net/unison-devel/Makefile b/net/unison-devel/Makefile
index 22bc5b2ab504..66d2e71c7182 100644
--- a/net/unison-devel/Makefile
+++ b/net/unison-devel/Makefile
@@ -66,7 +66,6 @@ post-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/unison ${STAGEDIR}${PREFIX}/bin
-post-install:
.if ${PORT_OPTIONS:MX11}
${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${STAGEDIR}${PREFIX}/bin
.endif
diff --git a/net/unison/Makefile b/net/unison/Makefile
index a6ba7ddce419..475024717373 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -64,7 +64,6 @@ post-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/net/unison232/Makefile b/net/unison232/Makefile
index a0df64ea14ce..f12b5207a49c 100644
--- a/net/unison232/Makefile
+++ b/net/unison232/Makefile
@@ -63,7 +63,6 @@ post-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
-post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/net/unison240/Makefile b/net/unison240/Makefile
index 96f41a6dcb9a..3769e71186f0 100644
--- a/net/unison240/Makefile
+++ b/net/unison240/Makefile
@@ -64,7 +64,6 @@ post-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
-post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/net/vnstat/Makefile b/net/vnstat/Makefile
index c68b4d401d92..95e37f2a0c70 100644
--- a/net/vnstat/Makefile
+++ b/net/vnstat/Makefile
@@ -64,11 +64,9 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/man/vnstati.1 ${STAGEDIR}/${MANPREFIX}/man/man1/vnstati.1
.endif
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
@${MKDIR} ${STAGEDIR}/${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}/${DOCSDIR}
-.endif
.include <bsd.port.mk>