aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
commit64cf27c85d89298041b8c8dc2fd090181e6d10d8 (patch)
tree11668b893f94453b0262a155d53e6eac8dd4a6f5 /net
parent440d8863c8d496b982754e2a71867892213a902b (diff)
downloadports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.tar.gz
ports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.zip
Say hello to the linux mega patch, it consolidates our linux bits a
little bit and allows to proceed to a more recent linux_base from a stable (read as: the major bugs should be ironed out or identified and most linux ports build just fine) source. It also allows to ship 4.11 with a working linuxolator (the EOLed linux_base is marked forbidden because of a security hole). This is a major update, please read UPDATING (and CHANGES if you develop linux ports). Changes: - change the default linux_base from v7 to v8 - add a newer freetype to linux_base-8 for nicer fonts display [1] - don't let cpio use hardlinks in the linux_base-8 port to quiet some warnings in some cases [2] - fix a cut&past error in the linux_base-8 pkg-install script [3] - convert the binary knob "USE_LINUX" to a version specifier, e.g. USE_LINUX=<value> specifies a dependency upon emulators/linux_base-<value>, exceptions are a value of "7" (which does what you want and adds a dependency to linux_base) and any value without a corresponding port in PORTSDIR/emulators/linux_base-<value> (which adds a dependency to the default linux_base) - don't implicitly add USE_LINUX with the USE_LINUX_PREFIX knob, this allows us to use the USE_LINUX_PREFIX knob for linux_base and paves the way for splitting up future linux base ports into individual pieces - remove RESTRICTED from some GPL licensed ports, even when we only distribute binaries, we get them from official linux sites, so anyone can grab them there if he needs to - add a dependency upon the linux X11 bits where necessary (based upon guesswork) - don't use USE_X_PREFIX in some linux ports since it adds a dependency to the FreeBSD X11 libs, as a workaround use PREFIX?= (the clean solution would be to remove the implicit USE_XLIB from USE_X_PREFIX) - bump the portrevision of the linux ports ("better safe than sorry" algorithm) - pass maintainership of the important linux infrastructure to a mailinglist, hijack freebsd-emulation@ for this purpose (if somebody doesn't like this: tell us your bikeshed color at freebsd-emulation@, my color would be "linuxolator@" in case someone cares...) - add a pkg-install script for linux-fontconfig, but don't use it; everything should work without it (the FreeBSD fc-cache program should do all the work), but in case we need it we just need to decomment the pkg-install part in the Makefile - fix some dependencies - fix some bugs - add some static plists - unbreak the ports with dependecies to more than one linux_base This also fixes some ports which are marked BROKEN because of dependencies to v7 and v8 of linux_base at the same time. Known bugs: - the linux-mesa and linux-devtools ports install libGL*.so symlinks - some "minor" plist bugs (e.g. ld.so.{conf,cache} are modified by the linux X11 port, so linx_Base-8 moans at deinstall time) Future work (interested souls should coordinate with freebsd-emulation@): - add some kind of USE_LINUX_X11 knob to streamline the X11 dependencies, or modify the behavior of USE_XLIB in the USE_LINUX case AFAIK trevor has some patches. - make USE_XLIB and USE_X_PREFIX orthogonal to be able to get rid of the PREFIX?= workaround in some linux ports Should be discussed/coordinated on/with x11@. - move the RPM bits from x11-toolkits/linux-gtk/Makefile to PORTSDIR/Mk/ - update to a more recent linux base PR: 69997, 70539 (and maybe others) Discussed with/on: java@, x11@, trevor, portmgr Tested by: mezz, portmgr, pointyhat RPM hunted down by: Joseph Gelinas <scirocco@tasam.com> [1] Requested by: portmgr [2] Submitted by: kris [3] Approved by: portmgr
Notes
Notes: svn path=/head/; revision=125613
Diffstat (limited to 'net')
-rw-r--r--net/aim/Makefile7
-rw-r--r--net/citrix_ica/Makefile5
-rw-r--r--net/citrix_xenapp/Makefile5
-rw-r--r--net/linux-agsatellite/Makefile4
-rw-r--r--net/linux-edonkey-core/Makefile1
-rw-r--r--net/linux-edonkey-gui-gtk/Makefile3
-rw-r--r--net/linux-edonkey-server/Makefile1
-rw-r--r--net/peercast/Makefile2
-rw-r--r--net/skype-devel/Makefile8
-rw-r--r--net/skype/Makefile8
10 files changed, 23 insertions, 21 deletions
diff --git a/net/aim/Makefile b/net/aim/Makefile
index 9e79e727ab1a..c4ef5a7d5bc3 100644
--- a/net/aim/Makefile
+++ b/net/aim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aim
PORTVERSION= 1.5.286
+PORTREVISION= 1
CATEGORIES= net linux
MASTER_SITES= ftp://ftp.newaol.com/aimgen/380469/
DISTNAME= aim-${PORTVERSION}
@@ -15,13 +16,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= AOL's Instant Messenger (AIM) client
-RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base \
- /compat/linux/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
ONLY_FOR_ARCHS= i386
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_XLIB= yes
+USE_LINUX= yes
+PREFIX?= ${X11BASE}
INSTALLS_SHLIB= yes
# must not strip
STRIP=
diff --git a/net/citrix_ica/Makefile b/net/citrix_ica/Makefile
index 17bbacfe3f92..984293afe8e4 100644
--- a/net/citrix_ica/Makefile
+++ b/net/citrix_ica/Makefile
@@ -7,7 +7,7 @@
PORTNAME= citrix_ica
PORTVERSION= 8.00
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net comms linux
MASTER_SITES=
DISTNAME= ${PORTNAME}-linuxx86-${PORTVERSION}
@@ -15,14 +15,13 @@ DISTNAME= ${PORTNAME}-linuxx86-${PORTVERSION}
MAINTAINER= mbr@FreeBSD.org
COMMENT= Citrix(R) client for the Microsoft Windows Terminal Server
-RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
-
ONLY_FOR_ARCHS= i386
RESTRICTED= "License prohibits redistribution"
IS_INTERACTIVE= "Noisy license agreement ignores stdin"
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_LINUX= yes
CDIR= ${PREFIX}/ICAClient
BINDIR= ${PREFIX}/bin
diff --git a/net/citrix_xenapp/Makefile b/net/citrix_xenapp/Makefile
index 17bbacfe3f92..984293afe8e4 100644
--- a/net/citrix_xenapp/Makefile
+++ b/net/citrix_xenapp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= citrix_ica
PORTVERSION= 8.00
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net comms linux
MASTER_SITES=
DISTNAME= ${PORTNAME}-linuxx86-${PORTVERSION}
@@ -15,14 +15,13 @@ DISTNAME= ${PORTNAME}-linuxx86-${PORTVERSION}
MAINTAINER= mbr@FreeBSD.org
COMMENT= Citrix(R) client for the Microsoft Windows Terminal Server
-RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
-
ONLY_FOR_ARCHS= i386
RESTRICTED= "License prohibits redistribution"
IS_INTERACTIVE= "Noisy license agreement ignores stdin"
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_LINUX= yes
CDIR= ${PREFIX}/ICAClient
BINDIR= ${PREFIX}/bin
diff --git a/net/linux-agsatellite/Makefile b/net/linux-agsatellite/Makefile
index 9f3a4592a707..a2df25e0e13d 100644
--- a/net/linux-agsatellite/Makefile
+++ b/net/linux-agsatellite/Makefile
@@ -7,7 +7,7 @@
PORTNAME= agsatellite
PORTVERSION= 0.520
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net audio linux
MASTER_SITES= http://www.audiogalaxy.com/downloads/
PKGNAMEPREFIX= linux-
@@ -16,6 +16,8 @@ DISTNAME= AGSatellite${PORTVERSION:S/.//}-glibc21
MAINTAINER= lioux@FreeBSD.org
COMMENT= Client that allows you to share your music on Audiogalaxy(TM)
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+
WRKSRC= ${WRKDIR}/${DISTNAME:C/-.*//}
USE_LINUX= yes
diff --git a/net/linux-edonkey-core/Makefile b/net/linux-edonkey-core/Makefile
index 65537dc8f6a8..6fda23a509c9 100644
--- a/net/linux-edonkey-core/Makefile
+++ b/net/linux-edonkey-core/Makefile
@@ -7,6 +7,7 @@
PORTNAME= edonkey
PORTVERSION= 0.50.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net linux
MASTER_SITES= http://www.overnet.com/files/
diff --git a/net/linux-edonkey-gui-gtk/Makefile b/net/linux-edonkey-gui-gtk/Makefile
index 3ee8bd87393c..85dd0cbecf06 100644
--- a/net/linux-edonkey-gui-gtk/Makefile
+++ b/net/linux-edonkey-gui-gtk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= edonkey
PORTVERSION= 0.2.0.a.${SNAPSHOT_DATE:S/-/./g}
+PORTREVISION= 1
CATEGORIES= net linux
MASTER_SITES= http://users.aber.ac.uk/tpm01/
PKGNAMEPREFIX= linux-
@@ -21,7 +22,7 @@ RUN_DEPENDS= donkey:${PORTSDIR}/net/linux-edonkey-core \
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
-USE_X_PREFIX= yes
+PREFIX?= ${X11BASE}
NO_WRKSUBDIR= yes
NO_BUILD= yes
STRIP=
diff --git a/net/linux-edonkey-server/Makefile b/net/linux-edonkey-server/Makefile
index 13d661d11ef2..fffd87c540d3 100644
--- a/net/linux-edonkey-server/Makefile
+++ b/net/linux-edonkey-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME= edonkey
PORTVERSION= 16.39
+PORTREVISION= 1
CATEGORIES= net linux
MASTER_SITES= http://www.edonkey2000.com/files/
PKGNAMEPREFIX= linux-
diff --git a/net/peercast/Makefile b/net/peercast/Makefile
index 03d32427194c..7e2c7ef0cb94 100644
--- a/net/peercast/Makefile
+++ b/net/peercast/Makefile
@@ -15,8 +15,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= jylefort@brutele.be
COMMENT= A peer-to-peer network for broadcasting and listening to streams
-RUN_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base-8
-
USE_LINUX= yes
NO_WRKSUBDIR= yes
diff --git a/net/skype-devel/Makefile b/net/skype-devel/Makefile
index 759dc976345a..c6b47e298ebb 100644
--- a/net/skype-devel/Makefile
+++ b/net/skype-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= skype
PORTVERSION= 0.92.0.12
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://download.skype.com/linux/
DISTNAME= skype_staticQT-${PORTVERSION}
@@ -14,14 +15,13 @@ DISTNAME= skype_staticQT-${PORTVERSION}
MAINTAINER= netchild@FreeBSD.org
COMMENT= P2P VoIP software
-RUN_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8 \
- ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
USE_BZIP2= yes
-USE_X_PREFIX= yes
-#USE_LINUX= yes
+PREFIX?= ${X11BASE}
+USE_LINUX= yes
WANT_GNOME= yes
ONLY_FOR_ARCHS= i386
diff --git a/net/skype/Makefile b/net/skype/Makefile
index 759dc976345a..c6b47e298ebb 100644
--- a/net/skype/Makefile
+++ b/net/skype/Makefile
@@ -7,6 +7,7 @@
PORTNAME= skype
PORTVERSION= 0.92.0.12
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://download.skype.com/linux/
DISTNAME= skype_staticQT-${PORTVERSION}
@@ -14,14 +15,13 @@ DISTNAME= skype_staticQT-${PORTVERSION}
MAINTAINER= netchild@FreeBSD.org
COMMENT= P2P VoIP software
-RUN_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8 \
- ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
USE_BZIP2= yes
-USE_X_PREFIX= yes
-#USE_LINUX= yes
+PREFIX?= ${X11BASE}
+USE_LINUX= yes
WANT_GNOME= yes
ONLY_FOR_ARCHS= i386