aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-11-19 15:17:56 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-11-19 15:17:56 +0000
commitdf09a873dcc6e94956b508a1e94f3c4af2e3457f (patch)
tree411b649778ae82f407822cf7b760419ea024734f /net
parent58b7e23de7c85a7596fe77d3a0a28c3cd9af38fb (diff)
downloadports-df09a873dcc6e94956b508a1e94f3c4af2e3457f.tar.gz
ports-df09a873dcc6e94956b508a1e94f3c4af2e3457f.zip
Convert to new options.
While here, drop the old libnet10 option. Feature safe: yes
Notes
Notes: svn path=/head/; revision=307564
Diffstat (limited to 'net')
-rw-r--r--net/libnids/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index fd76e1b3503f..43740a95dcb2 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -15,30 +15,32 @@ COMMENT= Network monitoring library with TCP/IP reassembly
LICENSE= GPLv2
-OPTIONS= LIBNET "Include code requiring libnet" ON \
- LIBNET10 "Use the old libnet-1.0.x version" ON \
- GLIB2 "Use GLIB2 for multiprocessing support" ON
+OPTIONS_DEFINE= LIBNET GLIB2
+LIBNET_DESC= "Use libnet 1.1.x"
+GLIB2_DESC= "Use GLIB2 for multiprocessing support"
+OPTIONS_DEFAULT= LIBNET GLIB2
WANT_GNOME= yes
GNU_CONFIGURE= yes
MAN3= libnids.3
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_LIBNET)
-.if !defined(WITHOUT_LIBNET10)
-BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+.if ${PORT_OPTIONS:MDOCS}
+PLIST_SUB+= PORTDOCS=""
.else
+PLIST_SUB+= PORTDOCS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MLIBNET}
BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-.endif
.else
CONFIGURE_ARGS+= --disable-libnet
.endif
-.if !defined(WITHOUT_GLIB2)
+.if ${PORT_OPTIONS:MGLIB2}
USE_GNOME+= glib20
.else
CONFIGURE_ARGS+= --disable-libglib
@@ -56,11 +58,11 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/src/libnids.3 ${PREFIX}/man/man3
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in README doc/*
${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}/
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>