aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-04-06 17:59:34 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-04-06 17:59:34 +0000
commit07a71ce2018d3e2b0638bdda47ab1ce1d529fa84 (patch)
tree1f41b90534fbac699d4f60f14333a8b10ce48325 /net
parent497725e65991c80cf0a4e761ba9bcadfcb1979ca (diff)
downloadports-07a71ce2018d3e2b0638bdda47ab1ce1d529fa84.tar.gz
ports-07a71ce2018d3e2b0638bdda47ab1ce1d529fa84.zip
New port: net/sngrep
sngrep - SIP Messages flow viewer sngrep is a terminal tool that groups SIP (Session Initiation Protocol) Messages by Call-Id, and displays them in arrow flows similar to the used in SIP RFCs. The aim of this tool is to make easier the process of learnig or debugging SIP. It recognizes UDP, TCP and partially TLS SIP packets and understands bpf filter logic in the same way ngrep and tcpdump does. WWW: https://github.com/irontec/sngrep PR: 208572 Submitted by: Talal Al Dik <tad@vif.com>
Notes
Notes: svn path=/head/; revision=412635
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/sngrep/Makefile57
-rw-r--r--net/sngrep/distinfo2
-rw-r--r--net/sngrep/pkg-descr9
-rw-r--r--net/sngrep/pkg-plist3
5 files changed, 72 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a86e326ffb89..83707ac65bd5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1211,6 +1211,7 @@
SUBDIR += smbldap-tools
SUBDIR += smcroute
SUBDIR += smm++
+ SUBDIR += sngrep
SUBDIR += sniffit
SUBDIR += sntop
SUBDIR += sobby
diff --git a/net/sngrep/Makefile b/net/sngrep/Makefile
new file mode 100644
index 000000000000..02eaabf1e377
--- /dev/null
+++ b/net/sngrep/Makefile
@@ -0,0 +1,57 @@
+# Created by: Talal Al Dik (tad@vif.com)
+# $FreeBSD$
+
+PORTNAME= sngrep
+PORTVERSION= 1.3.0
+CATEGORIES= net
+
+MAINTAINER= tad@vif.com
+COMMENT= SIP Packet display and capture
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libncurses.so:${PORTSDIR}/devel/ncurses \
+ libpcap.so:${PORTSDIR}/net/libpcap
+
+#CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+USE_GITHUB= yes
+GH_ACCOUNT= irontec
+GH_TAGNAME= v${PORTVERSION}
+
+OPTIONS_DEFINE= OPENSSL PCRE UNICODE IPV6 EEP
+
+OPENSSL_DESC= Adds OpenSSL support to parse TLS captured messages
+OPENSSL_CONFIGURE_ON= --with-openssl
+OPENSSL_USE= OPENSSL=yes
+
+PCRE_DESC= Adds Perl Compatible regex support
+PCRE_CONFIGURE_ON= --with-pcre
+PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+
+UNICODE_DESC= Adds Ncurses UTF-8/Unicode support
+UNICODE_CONFIGURE_ON= --enable-unicode
+UNICODE_LIB_DEPENDS= libncursesw.so:${PORTSDIR}/devel/ncurses
+
+IPV6_DESC= Enable IPv6 packet capture support
+IPV6_CONFIGURE_ON= --enable-ipv6
+
+EEP_DESC= Enable EEP packet send/receive support
+EEP_CONFIGURE_ON= --enable-eep
+
+GNU_CONFIGURE= yes
+USES=autoreconf
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|ncursesw/ncurses.h|ncurses.h|g' \
+ ${WRKSRC}/configure.ac \
+ ${WRKSRC}/src/curses/scrollbar.h \
+ ${WRKSRC}/src/curses/ui_panel.h
+
+.include <bsd.port.options.mk>
+
+.include <bsd.port.mk>
diff --git a/net/sngrep/distinfo b/net/sngrep/distinfo
new file mode 100644
index 000000000000..eca43a6e78d7
--- /dev/null
+++ b/net/sngrep/distinfo
@@ -0,0 +1,2 @@
+SHA256 (irontec-sngrep-1.3.0-v1.3.0_GH0.tar.gz) = bf77ae470ee4282130aea3f689db82d0335c673a50e55d82308616bd07e42b77
+SIZE (irontec-sngrep-1.3.0-v1.3.0_GH0.tar.gz) = 213228
diff --git a/net/sngrep/pkg-descr b/net/sngrep/pkg-descr
new file mode 100644
index 000000000000..abf974ba2a05
--- /dev/null
+++ b/net/sngrep/pkg-descr
@@ -0,0 +1,9 @@
+sngrep - SIP Messages flow viewer
+
+sngrep is a terminal tool that groups SIP (Session Initiation Protocol)
+Messages by Call-Id, and displays them in arrow flows similar to the used in
+SIP RFCs. The aim of this tool is to make easier the process of learnig or
+debugging SIP. It recognizes UDP, TCP and partially TLS SIP packets and
+understands bpf filter logic in the same way ngrep and tcpdump does.
+
+WWW: https://github.com/irontec/sngrep
diff --git a/net/sngrep/pkg-plist b/net/sngrep/pkg-plist
new file mode 100644
index 000000000000..b6cfd8f91a28
--- /dev/null
+++ b/net/sngrep/pkg-plist
@@ -0,0 +1,3 @@
+bin/sngrep
+@sample %%ETCDIR%%rc %%ETCDIR%%rc.sample
+man/man8/sngrep.8.gz