aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-11-22 21:55:30 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-11-22 21:55:30 +0000
commit0f96567711d4eee0954db0538c92a7b04005492b (patch)
treee73969424c51d7ab58202de8bdd46d3e5dcfe54c /net
parent12e9ea7565599bce5b2d464c0badf0ca4660fe4d (diff)
downloadports-0f96567711d4eee0954db0538c92a7b04005492b.tar.gz
ports-0f96567711d4eee0954db0538c92a7b04005492b.zip
Build libdnet' Python module in a slave port.
(needed for a to-be-released soon port) Since I'm there, add SHA256. Approved by: Jonatan B <onatan (at) gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=149108
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/libdnet/Makefile28
-rw-r--r--net/libdnet/distinfo1
-rw-r--r--net/libdnet/pkg-plist44
-rw-r--r--net/py-libdnet/Makefile14
5 files changed, 59 insertions, 29 deletions
diff --git a/net/Makefile b/net/Makefile
index 02b3c4b30191..f8057e3f6f82 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -597,6 +597,7 @@
SUBDIR += py-kenosis
SUBDIR += py-kenosis-bittorrent
SUBDIR += py-ldap2
+ SUBDIR += py-libdnet
SUBDIR += py-libnet
SUBDIR += py-medusa
SUBDIR += py-mp-random
diff --git a/net/libdnet/Makefile b/net/libdnet/Makefile
index 4ba9177d92ed..07e82e9bdf91 100644
--- a/net/libdnet/Makefile
+++ b/net/libdnet/Makefile
@@ -10,32 +10,46 @@ PORTVERSION= 1.10
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+.if defined(BUILD_PYTHON_MODULE)
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+.endif
MAINTAINER= onatan@gmail.com
-COMMENT= A simple interface to low level networking routines
+COMMENT?= A simple interface to low level networking routines
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
USE_AUTOTOOLS= libtool:15
-.if defined(WITH_PYTHON)
+SLAVE_DIRS= net/py-libdnet
+
+.if defined(BUILD_PYTHON_MODULE)
USE_PYTHON= yes
CONFIGURE_ARGS+= --with-python
-PLIST_FILES+= lib/${PYTHON_VERSION}/site-packages/dnet.so
+INSTALL_WRKSRC= ${BUILD_WRKSRC}/python
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/dnet.so
+PLIST_SUB+= MASTER="@comment "
.else
CONFIGURE_ARGS+= --without-python
-.endif
+INSTALLS_SHLIB= yes
+PLIST_SUB+= MASTER=""
MAN3= dnet.3
MAN8= dnet.8
+.endif
pre-everything::
-.if !defined(WITH_PYTHON)
+.if !defined(BUILD_PYTHON_MODULE)
@${ECHO_MSG} "===>"
- @${ECHO_MSG} "===> You can add python support using WITH_PYTHON,"
+ @${ECHO_MSG} "===> You can add python support with the port ${SLAVE_DIRS}."
@${ECHO_MSG} "===>"
@sleep 2
.endif
+.if defined(BUILD_PYTHON_MODULE) && defined(MAINTAINER_MODE)
+test: install
+ ${PYTHON_CMD} ${INSTALL_WRKSRC}/test.py
+.endif
+
.include <bsd.port.mk>
diff --git a/net/libdnet/distinfo b/net/libdnet/distinfo
index 734780d1a1d3..e8d0cfb0e3ea 100644
--- a/net/libdnet/distinfo
+++ b/net/libdnet/distinfo
@@ -1,2 +1,3 @@
MD5 (libdnet-1.10.tar.gz) = 416b765e9d9961501ac85e9a366fd219
+SHA256 (libdnet-1.10.tar.gz) = c6e2329df7556cc5004113b65d2d68740e87bbd15c5b2ef6c3fb7cde191cfe67
SIZE (libdnet-1.10.tar.gz) = 419752
diff --git a/net/libdnet/pkg-plist b/net/libdnet/pkg-plist
index e55bb79ea92a..5c984f48aa05 100644
--- a/net/libdnet/pkg-plist
+++ b/net/libdnet/pkg-plist
@@ -1,22 +1,22 @@
-bin/dnet-config
-sbin/dnet
-lib/libdnet.a
-lib/libdnet.so
-lib/libdnet.so.1
-include/dnet/addr.h
-include/dnet/arp.h
-include/dnet/blob.h
-include/dnet/eth.h
-include/dnet/fw.h
-include/dnet/icmp.h
-include/dnet/intf.h
-include/dnet/ip.h
-include/dnet/ip6.h
-include/dnet/os.h
-include/dnet/rand.h
-include/dnet/route.h
-include/dnet/tcp.h
-include/dnet/tun.h
-include/dnet/udp.h
-include/dnet.h
-@dirrm include/dnet
+%%MASTER%%bin/dnet-config
+%%MASTER%%sbin/dnet
+%%MASTER%%lib/libdnet.a
+%%MASTER%%lib/libdnet.so
+%%MASTER%%lib/libdnet.so.1
+%%MASTER%%include/dnet/addr.h
+%%MASTER%%include/dnet/arp.h
+%%MASTER%%include/dnet/blob.h
+%%MASTER%%include/dnet/eth.h
+%%MASTER%%include/dnet/fw.h
+%%MASTER%%include/dnet/icmp.h
+%%MASTER%%include/dnet/intf.h
+%%MASTER%%include/dnet/ip.h
+%%MASTER%%include/dnet/ip6.h
+%%MASTER%%include/dnet/os.h
+%%MASTER%%include/dnet/rand.h
+%%MASTER%%include/dnet/route.h
+%%MASTER%%include/dnet/tcp.h
+%%MASTER%%include/dnet/tun.h
+%%MASTER%%include/dnet/udp.h
+%%MASTER%%include/dnet.h
+%%MASTER%%@dirrm include/dnet
diff --git a/net/py-libdnet/Makefile b/net/py-libdnet/Makefile
new file mode 100644
index 000000000000..ba0b1af82ba7
--- /dev/null
+++ b/net/py-libdnet/Makefile
@@ -0,0 +1,14 @@
+# Ports collection makefile for: py-libdnet
+# Date created: Nov 2, 2005
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+COMMENT= Python module for libdnet
+
+MASTERDIR= ${.CURDIR}/../libdnet
+
+BUILD_PYTHON_MODULE= yes
+
+.include "${MASTERDIR}/Makefile"