aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-04-16 08:58:17 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-04-16 08:58:17 +0000
commita377a1e0ce4d2abc866d5b97108ceeaee4023103 (patch)
tree47340171c8386478354cede25c639cb8ae05a7c1 /net
parent97467cb771ce4c4d4e218b75f666b0b5cc401d21 (diff)
downloadports-a377a1e0ce4d2abc866d5b97108ceeaee4023103.tar.gz
ports-a377a1e0ce4d2abc866d5b97108ceeaee4023103.zip
- Remove INSTALLS_ICONS knob (not to be used for Qt-based programs)
- Do not attempt to create ${STAGEDIR}${DESKTOPDIR}: `share/applications' was added to mtree (Templates/BSD.local.dist) in r331266 2.5 years ago - Stop cd'ing when operating on a single argument for better readability and not having to request a sub-shell for every install recipe command
Notes
Notes: svn path=/head/; revision=413420
Diffstat (limited to 'net')
-rw-r--r--net/x2goclient/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/net/x2goclient/Makefile b/net/x2goclient/Makefile
index 0cb7df2b31b4..4bd02af8ad51 100644
--- a/net/x2goclient/Makefile
+++ b/net/x2goclient/Makefile
@@ -24,7 +24,6 @@ USE_XORG= xpm
USE_QT4= gui network svg \
linguisttools_build moc_build rcc_build uic_build
QMAKE_ARGS= QMAKE_LRELEASE="${LRELEASE}"
-INSTALLS_ICONS= yes
OPTIONS_DEFINE= DOCS LDAP
OPTIONS_DEFAULT= LDAP
@@ -46,28 +45,26 @@ pre-build:
@(cd ${WRKSRC} && ${DO_MAKE_BUILD} compiler_TSQM_make_all)
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} x2goclient \
- ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} x2goclient.1 \
- ${STAGEDIR}${MANPREFIX}/man/man1)
- @${MKDIR} ${STAGEDIR}${DESKTOPDIR}
- (cd ${WRKSRC}/desktop && ${INSTALL_DATA} x2goclient.desktop \
- ${STAGEDIR}${DESKTOPDIR})
+ ${INSTALL_PROGRAM} ${WRKSRC}/x2goclient ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/x2goclient.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/desktop/x2goclient.desktop \
+ ${STAGEDIR}${DESKTOPDIR}
.for i in 16x16 32x32 48x48 64x64 128x128
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}/apps
- (cd ${WRKSRC}/res/img/icons/${i} && ${INSTALL_DATA} x2goclient.png \
- ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}/apps)
+ ${INSTALL_DATA} ${WRKSRC}/res/img/icons/${i}/x2goclient.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}/apps
.endfor
@${MKDIR} ${STAGEDIR}${DATADIR}/icons
- (cd ${WRKSRC}/res/img/icons && ${INSTALL_DATA} x2goclient.xpm \
- ${STAGEDIR}${DATADIR}/icons)
+ ${INSTALL_DATA} ${WRKSRC}/res/img/icons/x2goclient.xpm \
+ ${STAGEDIR}${DATADIR}/icons
.for i in x2goclient.png x2gosession.png
- (cd ${WRKSRC}/res/img/icons/128x128 && ${INSTALL_DATA} ${i} \
- ${STAGEDIR}${DATADIR}/icons)
+ ${INSTALL_DATA} ${WRKSRC}/res/img/icons/128x128/${i} \
+ ${STAGEDIR}${DATADIR}/icons
.endfor
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} HOWTO.GPGCARD ${STAGEDIR}${DOCSDIR})
+ ${INSTALL_DATA} ${WRKSRC}/HOWTO.GPGCARD ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>