aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-05-24 10:16:58 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-05-24 10:16:58 +0000
commitffdd97b0e6a8904e5fb9a9ff1cc7a239069d3c85 (patch)
treef28ef23bb6a2826ce5adfd4c7183fb51f8520ed1 /net
parent30588c5645755db3fee0ff1cc95410ee3a4c366a (diff)
downloadports-ffdd97b0e6a8904e5fb9a9ff1cc7a239069d3c85.tar.gz
ports-ffdd97b0e6a8904e5fb9a9ff1cc7a239069d3c85.zip
Grive is an independent implementation of Google Drive client. It uses
the Google Document List API to talk to the servers in Google. WWW: http://www.lbreda.com/grive/ PR: ports/178025 Submitted by: Key-Teck SIN <ktsin@acm.org> Approved by: culot (mentor)
Notes
Notes: svn path=/head/; revision=318949
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/grive/Makefile61
-rw-r--r--net/grive/distinfo2
-rw-r--r--net/grive/files/patch-grive_CMakeLists.txt8
-rw-r--r--net/grive/files/patch-st_ctimespec13
-rw-r--r--net/grive/pkg-descr4
6 files changed, 89 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f19c58a55302..41f5deb27a01 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -191,6 +191,7 @@
SUBDIR += gpxe
SUBDIR += gq
SUBDIR += grdesktop
+ SUBDIR += grive
SUBDIR += grsync
SUBDIR += gsk
SUBDIR += gspoof
diff --git a/net/grive/Makefile b/net/grive/Makefile
new file mode 100644
index 000000000000..ac5b11af2e73
--- /dev/null
+++ b/net/grive/Makefile
@@ -0,0 +1,61 @@
+# Created by: ktsin@acm.org
+# $FreeBSD$
+
+PORTNAME= grive
+PORTVERSION= 0.2.0
+CATEGORIES= net
+MASTER_SITES= GH
+
+MAINTAINER= ktsin@acm.org
+COMMENT= Open source client for Google Drive
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libiberty.a:${PORTSDIR}/devel/binutils
+LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs \
+ curl:${PORTSDIR}/ftp/curl \
+ expat:${PORTSDIR}/textproc/expat2 \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
+ json:${PORTSDIR}/devel/json-c
+
+USE_GITHUB= yes
+GH_ACCOUNT= Grive
+GH_PROJECT= ${PORTNAME}
+GH_COMMIT= 93d696a
+GH_TAGNAME= v${PORTVERSION}
+
+USES= cmake
+CXXFLAGS+= -I${LOCALBASE}/include
+
+MAKE_JOBS_UNSAFE= yes
+
+FETCH_ARGS= -pRr
+
+PLIST_FILES= bin/grive
+MAN1= grive.1
+
+.include <bsd.port.pre.mk>
+
+# We need clang or GCC 4.6+ to build
+# Piece of code copied from bsd.gecko.mk
+.if ${CC} == "cc" && (exists(/usr/bin/clang) && ${OSVERSION} >= 900014)
+CC= /usr/bin/clang
+.endif
+.if ${CXX} == "c++" && (exists(/usr/bin/clang++) && ${OSVERSION} >= 900014)
+CXX= /usr/bin/clang++
+.endif
+.if ${CPP} == "cpp" && (exists(/usr/bin/clang-cpp) && ${OSVERSION} >= 900045)
+CPP= /usr/bin/clang-cpp
+.endif
+.if ${CC} != "cc" && ${CPP} == "cpp"
+CPP= ${CC} -E
+.endif
+# fallback to gcc otherwise
+.if ${CC} == "cc" || ${CXX} == "c++"
+USE_GCC= 4.6+
+.endif
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/grive
+
+.include <bsd.port.post.mk>
diff --git a/net/grive/distinfo b/net/grive/distinfo
new file mode 100644
index 000000000000..bafac1634e5b
--- /dev/null
+++ b/net/grive/distinfo
@@ -0,0 +1,2 @@
+SHA256 (grive-0.2.0.tar.gz) = f9b32eb9da9f2d47b6642248e1e25606e9ab2cd5b3e94730b23399250ec7f2ec
+SIZE (grive-0.2.0.tar.gz) = 144474
diff --git a/net/grive/files/patch-grive_CMakeLists.txt b/net/grive/files/patch-grive_CMakeLists.txt
new file mode 100644
index 000000000000..43ff928f2ca6
--- /dev/null
+++ b/net/grive/files/patch-grive_CMakeLists.txt
@@ -0,0 +1,8 @@
+--- grive/CMakeLists.txt.orig 2012-07-07 23:43:18.000000000 +0800
++++ grive/CMakeLists.txt 2013-04-21 23:34:38.000000000 +0800
+@@ -27,4 +27,4 @@
+ )
+
+ install(TARGETS grive_executable RUNTIME DESTINATION bin)
+-install(FILES doc/grive.1 DESTINATION share/man/man1 )
++install(FILES doc/grive.1 DESTINATION man/man1 )
diff --git a/net/grive/files/patch-st_ctimespec b/net/grive/files/patch-st_ctimespec
new file mode 100644
index 000000000000..99c6c86927f2
--- /dev/null
+++ b/net/grive/files/patch-st_ctimespec
@@ -0,0 +1,13 @@
+diff --git libgrive/src/util/OS.cc libgrive/src/util/OS.cc
+index 0d51136..469e373 100644
+--- libgrive/src/util/OS.cc
++++ libgrive/src/util/OS.cc
+@@ -57,7 +57,7 @@ DateTime FileCTime( const std::string& filename )
+ ) ;
+ }
+
+-#if defined __APPLE__ && defined __DARWIN_64_BIT_INO_T
++#if defined(__FreeBSD__) && __FreeBSD_version < 900000
+ return DateTime( s.st_ctimespec.tv_sec, s.st_ctimespec.tv_nsec ) ;
+ #else
+ return DateTime( s.st_ctim.tv_sec, s.st_ctim.tv_nsec);
diff --git a/net/grive/pkg-descr b/net/grive/pkg-descr
new file mode 100644
index 000000000000..1068c66e9b9a
--- /dev/null
+++ b/net/grive/pkg-descr
@@ -0,0 +1,4 @@
+Grive is an independent implementation of Google Drive client. It uses
+the Google Document List API to talk to the servers in Google.
+
+WWW: http://www.lbreda.com/grive/