aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2006-09-28 21:29:10 +0000
committerBruce M Simpson <bms@FreeBSD.org>2006-09-28 21:29:10 +0000
commit51a04cbd4c5ca6dc3d46e787406c076ac671ff67 (patch)
tree4105192f5ff7380f4e849cf97330664c6fa9d21c /net
parent7cf3d9082da0ecf9dc89a98fd65a7f036224b1bb (diff)
downloadports-51a04cbd4c5ca6dc3d46e787406c076ac671ff67.tar.gz
ports-51a04cbd4c5ca6dc3d46e787406c076ac671ff67.zip
Add new port of mrouted, IPv4 DVMRP multicast routing daemon.
Notes
Notes: svn path=/head/; revision=174057
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/mrouted/Makefile35
-rw-r--r--net/mrouted/distinfo3
-rw-r--r--net/mrouted/files/mrouted.in21
-rw-r--r--net/mrouted/files/patch-Makefile19
-rw-r--r--net/mrouted/files/patch-main.c38
-rw-r--r--net/mrouted/pkg-descr3
7 files changed, 120 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3c0659f3d300..32577c07f6a4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -304,6 +304,7 @@
SUBDIR += mpich
SUBDIR += mpich2
SUBDIR += mping
+ SUBDIR += mrouted
SUBDIR += mrt
SUBDIR += mrtg-ping-probe
SUBDIR += msend
diff --git a/net/mrouted/Makefile b/net/mrouted/Makefile
new file mode 100644
index 000000000000..96f684e0ae2a
--- /dev/null
+++ b/net/mrouted/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mrouted
+# Date created: 28 September 2006
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mrouted
+PORTVERSION= 3.9
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.research.att.com/pub/fenner/mrouted/ \
+ http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION}beta3+IOS12
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Multicast routing daemon providing DVMRP for IPv4
+
+USE_RC_SUBR= mrouted
+BUILD_ENV+= CFLAGS="-O2 -fno-strict-aliasing -DRSRR -Dlog=logit"
+
+MAN8= map-mbone.8 mrouted.8 mrinfo.8
+
+MROUTED_BINARIES= map-mbone mrouted mrinfo
+
+PLIST_FILES= sbin/map-mbone sbin/mrouted sbin/mrinfo
+
+do-install:
+.for i in ${MROUTED_BINARIES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/sbin/${i}
+.endfor
+.for i in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${PREFIX}/man/man8
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net/mrouted/distinfo b/net/mrouted/distinfo
new file mode 100644
index 000000000000..90b276745f78
--- /dev/null
+++ b/net/mrouted/distinfo
@@ -0,0 +1,3 @@
+MD5 (mrouted-3.9beta3+IOS12.tar.gz) = 15bb287b5af0cef4ec8e4ad3bd56740c
+SHA256 (mrouted-3.9beta3+IOS12.tar.gz) = fa9ad8150ca11044288162cf3056cca94ad737ee822b710994aa178eb0100908
+SIZE (mrouted-3.9beta3+IOS12.tar.gz) = 110167
diff --git a/net/mrouted/files/mrouted.in b/net/mrouted/files/mrouted.in
new file mode 100644
index 000000000000..7bdc073aecda
--- /dev/null
+++ b/net/mrouted/files/mrouted.in
@@ -0,0 +1,21 @@
+#!/bin/sh
+#
+# $NetBSD: mrouted,v 1.6 2002/03/22 04:33:59 thorpej Exp $
+# $FreeBSD$
+#
+
+# PROVIDE: mrouted
+# REQUIRE: netif routing cleanvar
+# KEYWORD: nojail
+
+. %%RC_SUBR%%
+
+name="mrouted"
+rcvar=`set_rcvar`
+command=%%PREFIX%%/sbin/${name}
+pidfile="/var/run/${name}.pid"
+required_files=%%PREFIX%%/etc/${name}.conf
+extra_commands="reload"
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net/mrouted/files/patch-Makefile b/net/mrouted/files/patch-Makefile
new file mode 100644
index 000000000000..1a2bce163acd
--- /dev/null
+++ b/net/mrouted/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig Sun Mar 1 03:09:11 1998
++++ Makefile Thu Sep 28 22:11:44 2006
+@@ -24,12 +24,13 @@
+ #
+ # Uncomment the following three lines if you want to use RSRR (Routing
+ # Support for Resource Reservations), currently used by RSVP.
+-#RSRRDEF= -DRSRR
+-#RSRRC= rsrr.c
+-#RSRRO= rsrr.o
++RSRRDEF= -DRSRR
++RSRRC= rsrr.c
++RSRRO= rsrr.o
+ #
+ LDFLAGS=
+ CFLAGS= -O ${MCAST_INCLUDE} ${SNMPDEF} ${RSRRDEF} ## SunOS, OSF1, FreeBSD, IRIX
++CFLAGS+= -O2 -fno-strict-aliasing -pipe -Dlog=logit
+ #CFLAGS= -O ${MCAST_INCLUDE} ${SNMPDEF} ${RSRRDEF} -DSYSV -DSUNOS5 ## Solaris 2.x
+ #LIB2=-lsocket -lnsl ## Solaris 2.x
+ #CFLAGS= -O ${MCAST_INCLUDE} ${SNMPDEF} ${RSRRDEF} -D__BSD_SOURCE -DRAW_INPUT_IS_RAW -DRAW_OUTPUT_IS_RAW -DIOCTL_OK_ON_RAW_SOCKET ## Linux
diff --git a/net/mrouted/files/patch-main.c b/net/mrouted/files/patch-main.c
new file mode 100644
index 000000000000..a45a764cb388
--- /dev/null
+++ b/net/mrouted/files/patch-main.c
@@ -0,0 +1,38 @@
+--- main.c.orig Sun Mar 1 01:49:00 1998
++++ main.c Thu Sep 28 21:44:08 2006
+@@ -934,6 +934,7 @@
+ static char fmt[211] = "warning - ";
+ char *msg;
+ struct timeval now;
++ time_t now_sec;
+ struct tm *thyme;
+ #ifdef RINGBUFFER
+ static int ringbufinit = 0;
+@@ -953,6 +954,7 @@
+ char *msg;
+ char tbuf[20];
+ struct timeval now;
++ time_t now_sec;
+ struct tm *thyme;
+ #ifdef RINGBUFFER
+ static int ringbufinit = 0;
+@@ -979,7 +981,8 @@
+ ringbufinit = 1;
+ }
+ gettimeofday(&now,NULL);
+- thyme = localtime(&now.tv_sec);
++ now_sec = now.tv_sec;
++ thyme = localtime(&now_sec);
+ sprintf(logmsg[logmsgno++], "%02d:%02d:%02d.%03ld %s err %d",
+ thyme->tm_hour, thyme->tm_min, thyme->tm_sec,
+ now.tv_usec / 1000, msg, syserr);
+@@ -992,7 +995,8 @@
+ */
+ if (haveterminal && (debug || severity <= LOG_WARNING)) {
+ gettimeofday(&now,NULL);
+- thyme = localtime(&now.tv_sec);
++ now_sec = now.tv_sec;
++ thyme = localtime(&now_sec);
+ if (!debug)
+ fprintf(stderr, "%s: ", progname);
+ fprintf(stderr, "%02d:%02d:%02d.%03ld %s", thyme->tm_hour,
diff --git a/net/mrouted/pkg-descr b/net/mrouted/pkg-descr
new file mode 100644
index 000000000000..b51e70a9af3c
--- /dev/null
+++ b/net/mrouted/pkg-descr
@@ -0,0 +1,3 @@
+mrouted is an implementation of the DVMRP multicast routing protocol.
+It turns a UNIX workstation into a DVMRP multicast router with tunnel
+support, in order to cross non-multicast-aware routers.