aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlfred Perlstein <alfred@FreeBSD.org>2004-04-16 02:15:01 +0000
committerAlfred Perlstein <alfred@FreeBSD.org>2004-04-16 02:15:01 +0000
commit3c1269109edb1d332b75261150f41173e8fc7513 (patch)
tree35eae67299088197d70a5bb51ae19eb6e6566cd1 /net
parentcdd7b7cf620f65219f646f9b1aceedffed32f0bf (diff)
downloadports-3c1269109edb1d332b75261150f41173e8fc7513.tar.gz
ports-3c1269109edb1d332b75261150f41173e8fc7513.zip
Install binaries needed by some mDNS consumers.
Notes
Notes: svn path=/head/; revision=107187
Diffstat (limited to 'net')
-rw-r--r--net/mDNSResponder/Makefile11
-rw-r--r--net/mDNSResponder/pkg-plist5
2 files changed, 15 insertions, 1 deletions
diff --git a/net/mDNSResponder/Makefile b/net/mDNSResponder/Makefile
index 4120dc4ab6c0..88497cf038e5 100644
--- a/net/mDNSResponder/Makefile
+++ b/net/mDNSResponder/Makefile
@@ -8,7 +8,7 @@
PORTNAME= mDNSResponder
PORTVERSION= 62
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://darwinsource.opendarwin.org/tarballs/apsl/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -22,5 +22,14 @@ USE_GMAKE= YES
MAKE_ARGS+= os=freebsd
BUILD_WRKSRC= ${WRKSRC}/mDNSPosix
INSTALL_WRKSRC= ${WRKSRC}/mDNSPosix
+EXTRA_PROGS= mDNSClientPosix \
+ mDNSIdentify \
+ mDNSNetMonitor \
+ mDNSProxyResponderPosix \
+ mDNSResponderPosix
+
+post-install:
+ cd ${INSTALL_WRKSRC}/build/prod && \
+ ${INSTALL_PROGRAM} ${EXTRA_PROGS} ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/net/mDNSResponder/pkg-plist b/net/mDNSResponder/pkg-plist
index 67c2c512f764..562a17b10777 100644
--- a/net/mDNSResponder/pkg-plist
+++ b/net/mDNSResponder/pkg-plist
@@ -1,3 +1,8 @@
+bin/mDNSClientPosix
+bin/mDNSIdentify
+bin/mDNSNetMonitor
+bin/mDNSProxyResponderPosix
+bin/mDNSResponderPosix
etc/rc.d/mdns.sh
lib/libmdns.so
lib/libmdns.so.1