aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-12-01 08:23:30 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-12-01 08:23:30 +0000
commit6b3ced65a9deb69397f933bdf210de26f4fa05d8 (patch)
tree2c439fcb8c2ce5afc32bce959a86197ed1c59730 /net
parente4297fced6e8efa89fac78561f6d1936428dcfb0 (diff)
downloadports-6b3ced65a9deb69397f933bdf210de26f4fa05d8.tar.gz
ports-6b3ced65a9deb69397f933bdf210de26f4fa05d8.zip
Move Makefile.inc to ${FILESDIR}, copy it to ${WRKSRC} during extract
and include it explicitly. The previous method of relying in the implicit inclusion of "../Makefile.inc" broke when WRKDIRPREFIX is set.
Notes
Notes: svn path=/head/; revision=14983
Diffstat (limited to 'net')
-rw-r--r--net/pcnfsd/Makefile5
-rw-r--r--net/pcnfsd/files/Makefile.inc7
-rw-r--r--net/pcnfsd/files/patch-ab5
3 files changed, 14 insertions, 3 deletions
diff --git a/net/pcnfsd/Makefile b/net/pcnfsd/Makefile
index 1699e73d09d7..6f41986302eb 100644
--- a/net/pcnfsd/Makefile
+++ b/net/pcnfsd/Makefile
@@ -3,7 +3,7 @@
# Date created: Oct 6, 1994
# Whom: pst
#
-# $Id: Makefile,v 1.8 1997/07/10 15:50:52 pst Exp $
+# $Id: Makefile,v 1.9 1998/08/24 08:41:36 hoek Exp $
#
DISTNAME= pcnfsd.93.02.16
@@ -19,4 +19,7 @@ MANCOMPRESSED= maybe
NO_WRKSUBDIR=
+post-extract:
+ ${CP} ${FILESDIR}/Makefile.inc ${WRKSRC}
+
.include <bsd.port.mk>
diff --git a/net/pcnfsd/files/Makefile.inc b/net/pcnfsd/files/Makefile.inc
new file mode 100644
index 000000000000..d91164de241f
--- /dev/null
+++ b/net/pcnfsd/files/Makefile.inc
@@ -0,0 +1,7 @@
+#
+# Directories for pcnfsd(8)
+# $Id: Makefile.inc,v 1.2 1995/05/12 12:23:06 asami Exp $
+#
+BINDIR= ${DESTDIR}/usr/local/libexec
+MANDIR= ${DESTDIR}/usr/local/man/man
+PRDIR= ${DESTDIR}/var/spool/pcnfs
diff --git a/net/pcnfsd/files/patch-ab b/net/pcnfsd/files/patch-ab
index 95538572a242..2832f585e01b 100644
--- a/net/pcnfsd/files/patch-ab
+++ b/net/pcnfsd/files/patch-ab
@@ -2,13 +2,14 @@
--- Makefile.44bsd Thu Oct 6 17:18:19 1994
***************
*** 0 ****
---- 1,21 ----
+--- 1,22 ----
+ #
+ # @(#)Makefile
+ # Makefile for rpc.pcnfsd for BSD/386 or similar
-+ # $Id: patch-ab,v 1.1.1.1 1994/10/07 00:23:56 pst Exp $
++ # $Id: patch-ab,v 1.2 1995/03/19 10:12:39 joerg Exp $
+ #
+
++ .include "Makefile.inc"
+ PROG= rpc.pcnfsd
+ SRCS= pcnfsd_svc.c pcnfsd_xdr.c pcnfsd_v1.c pcnfsd_v2.c pcnfsd_misc.c \
+ pcnfsd_cache.c pcnfsd_print.c