aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-24 19:40:38 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-24 19:40:38 +0000
commita10318dfa488cedfb4ee20682dc7cb11f6a3914b (patch)
tree6122ad643f783757da95e5a132693c3f918979ba /net
parent0187e86785f52db7a61db937e2426edebdfade73 (diff)
downloadports-a10318dfa488cedfb4ee20682dc7cb11f6a3914b.tar.gz
ports-a10318dfa488cedfb4ee20682dc7cb11f6a3914b.zip
Add ruby-ldap, Ruby interface to LDAP API based on RFC1823.
Notes
Notes: svn path=/head/; revision=33070
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ruby-ldap/Makefile54
-rw-r--r--net/ruby-ldap/distinfo1
-rw-r--r--net/ruby-ldap/pkg-comment1
-rw-r--r--net/ruby-ldap/pkg-descr7
-rw-r--r--net/ruby-ldap/pkg-plist11
6 files changed, 75 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b49bed7d4183..d92f326caca1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -220,6 +220,7 @@
SUBDIR += rsync
SUBDIR += rtsp_proxy
SUBDIR += ruby-drb
+ SUBDIR += ruby-ldap
SUBDIR += ruby-snmp
SUBDIR += ruby-uri
SUBDIR += rwhois
diff --git a/net/ruby-ldap/Makefile b/net/ruby-ldap/Makefile
new file mode 100644
index 000000000000..b48e4918befa
--- /dev/null
+++ b/net/ruby-ldap/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: Ruby/LDAP
+# Date created: 25 Sep 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ldap
+PORTVERSION= 0.1
+CATEGORIES= net ruby
+MASTER_SITES= http://kt-www.jaist.ac.jp:8000/~ttate/ftp/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+.if !defined(WITHOUT_OPENLDAP1)
+LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
+.endif
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
+
+# Configure options:
+# --with-ldap specify the ldap directory
+# --with-ldap-incdir specify the directory which contains ldap.h and lber.h
+# --with-ldap-libdir specify the directory which contains ldap libraries
+# --with-netscape specify this to use Netscape SDK
+# --with-openldap1 specify this to use OpenLDAP-1.x
+# --with-openldap2 specify this to use OpenLDAP-2.x
+CONFIGURE_ARGS?= --with-openldap1 --with-ldap="${LOCALBASE}"
+
+INSTALL_TARGET= site-install
+
+DOCS_EN= README README.html
+EXAMPLES_EN= test1.rb test2.rb test3.rb test4.rb \
+ test5.rb test6.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/ldap
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/test/${f} ${RUBY_EXAMPLESDIR}/ldap/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/ldap
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/ldap/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ruby-ldap/distinfo b/net/ruby-ldap/distinfo
new file mode 100644
index 000000000000..0260509f0ded
--- /dev/null
+++ b/net/ruby-ldap/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-ldap-0.1.tar.gz) = a3d7435e747fd952e3fc6a29fb3b0e5d
diff --git a/net/ruby-ldap/pkg-comment b/net/ruby-ldap/pkg-comment
new file mode 100644
index 000000000000..837d3986da97
--- /dev/null
+++ b/net/ruby-ldap/pkg-comment
@@ -0,0 +1 @@
+Ruby interface to LDAP API based on RFC1823
diff --git a/net/ruby-ldap/pkg-descr b/net/ruby-ldap/pkg-descr
new file mode 100644
index 000000000000..58de7d61ab36
--- /dev/null
+++ b/net/ruby-ldap/pkg-descr
@@ -0,0 +1,7 @@
+Ruby/LDAP is a Ruby extension library which provides LDAP interface
+based on RFC1823.
+
+Supported LDAP libraries are OpenLDAP, Michigan LDAP, and NetscapeSDK.
+
+Author: Takaaki Tateishi <ttate@jaist.ac.jp>
+WWW: http://kt-www.jaist.ac.jp:8000/~ttate/lang/ruby/
diff --git a/net/ruby-ldap/pkg-plist b/net/ruby-ldap/pkg-plist
new file mode 100644
index 000000000000..dc3b73041a2d
--- /dev/null
+++ b/net/ruby-ldap/pkg-plist
@@ -0,0 +1,11 @@
+%%RUBY_SITEARCHLIBDIR%%/ldap.so
+%%RUBY_EXAMPLESDIR%%/ldap/test1.rb
+%%RUBY_EXAMPLESDIR%%/ldap/test2.rb
+%%RUBY_EXAMPLESDIR%%/ldap/test3.rb
+%%RUBY_EXAMPLESDIR%%/ldap/test4.rb
+%%RUBY_EXAMPLESDIR%%/ldap/test5.rb
+%%RUBY_EXAMPLESDIR%%/ldap/test6.rb
+@dirrm %%RUBY_EXAMPLESDIR%%/ldap
+%%RUBY_DOCDIR%%/ldap/README
+%%RUBY_DOCDIR%%/ldap/README.html
+@dirrm %%RUBY_DOCDIR%%/ldap