aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-18 20:01:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-18 20:01:27 +0000
commitad501b97d6a94c08d159fb08ac76da0cfb60ed23 (patch)
tree270836d64b7c7e4a7263a696725ec77df7249bd0 /net
parent72e8003e70440c1eda7ffbc27bdb8b234ddfcfc2 (diff)
downloadports-ad501b97d6a94c08d159fb08ac76da0cfb60ed23.tar.gz
ports-ad501b97d6a94c08d159fb08ac76da0cfb60ed23.zip
This PEAR class provides to access and query CDDB audio-CD servers.
WWW: http://pear.php.net/package/Net_CDDB PR: ports/101993 Submitted by: chinsan <chinsan.tw(at)gmail.com> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=170957
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pear-Net_CDDB/Makefile37
-rw-r--r--net/pear-Net_CDDB/distinfo3
-rw-r--r--net/pear-Net_CDDB/pkg-descr3
4 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a18d0dd3ea98..1409584dbe2e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -531,6 +531,7 @@
SUBDIR += pcnfsd
SUBDIR += pcs
SUBDIR += pear-Auth_RADIUS
+ SUBDIR += pear-Net_CDDB
SUBDIR += pear-Net_CheckIP
SUBDIR += pear-Net_DIME
SUBDIR += pear-Net_DNSBL
diff --git a/net/pear-Net_CDDB/Makefile b/net/pear-Net_CDDB/Makefile
new file mode 100644
index 000000000000..5de9bfe916d5
--- /dev/null
+++ b/net/pear-Net_CDDB/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: pear-Net_CDDB
+# Date created: 2006/08/14
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_CDDB
+PORTVERSION= 0.2.0
+CATEGORIES= net audio www pear
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= PEAR class that access and query CDDB audio-CD servers
+
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
+ ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_DOS2UNIX= yes
+
+CATEGORY= Net
+FILES= CDDB.php CDDB/Disc.php CDDB/Track.php CDDB/Utilities.php \
+ CDDB/Protocol.php CDDB/Request.php CDDB/Client.php \
+ CDDB/Server.php CDDB/Reader/test.php CDDB/Reader/cddiscid.php \
+ CDDB/Reader/cdparanoia.php CDDB/Protocol/Http.php \
+ CDDB/Protocol/Cddbp.php CDDB/Protocol/Filesystem.php \
+ CDDB/Request/Http.php
+DOCS= CDDB_example_output.txt CDDB_fileformat.txt CDDB_notes.txt \
+ CDDB_protocol.txt CDDB_record.txt
+TESTS= CDDBTest.php CDDBTest_HTTP.php CDDBTest_CDDBP.php \
+ CDDBTest_Filesystem.php
+EXAMPLES= CDDB_client_example.php CDDB_server_example.php CDDB_misc_example.php
+_EXAMPLESDIR= docs/examples
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_CDDB/distinfo b/net/pear-Net_CDDB/distinfo
new file mode 100644
index 000000000000..980cb06eacd6
--- /dev/null
+++ b/net/pear-Net_CDDB/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Net_CDDB-0.2.0.tgz) = 7ce657b4cb9d847000566e5c76634eb1
+SHA256 (PEAR/Net_CDDB-0.2.0.tgz) = 1a56e12b0690a38ec053dbbb4d8cb9f78d3f35bafa2d981d0f2345e72a997c2b
+SIZE (PEAR/Net_CDDB-0.2.0.tgz) = 47269
diff --git a/net/pear-Net_CDDB/pkg-descr b/net/pear-Net_CDDB/pkg-descr
new file mode 100644
index 000000000000..164f686557c5
--- /dev/null
+++ b/net/pear-Net_CDDB/pkg-descr
@@ -0,0 +1,3 @@
+This PEAR class provides to access and query CDDB audio-CD servers.
+
+WWW: http://pear.php.net/package/Net_CDDB