aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-06-11 16:13:12 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-06-11 16:13:12 +0000
commit54a1630d6e44ec2ef8cb3c4a00d6f4e0503f3b4f (patch)
tree75f8d629d0ebf0e58a1b981a5cffc533b15375cf /net
parent60cdc5877ab9a2546477d5d754adaa936030b51e (diff)
downloadports-54a1630d6e44ec2ef8cb3c4a00d6f4e0503f3b4f.tar.gz
ports-54a1630d6e44ec2ef8cb3c4a00d6f4e0503f3b4f.zip
* reflect renaming on CPAN File-Spec to PathTools
+ add devel/p5-PathTools, remove devel/p5-File-Spec + update dependencies for all affected ports (make them unconditional), bump PORTREVISION for these ports module was renamed * reflect renaming on CPAN PodParser to Pod-Parser + add textproc/p5-Pod-Parser, remove textproc/p5-PodParser + update dependencies for all affected ports (make them unconditional), bump PORTREVISION for these ports * for all changed ports make dependencies on File::Temp, Digest::MD5, Storable unconditional * remove 'CONFIGURE_ARGS= INSTALLDIRS=site' from Makefile's (this variable is forced by bsd.port.mk now) * update Class-Autouse to 1.17 * update POE-API-Hooks to 1.05 * make portlint happy (clean IGNORE, convert spaces to tabs and so on)
Notes
Notes: svn path=/head/; revision=137264
Diffstat (limited to 'net')
-rw-r--r--net/ldapsh/Makefile3
-rw-r--r--net/p5-Net/Makefile2
-rw-r--r--net/p5-RPC-XML/Makefile10
-rw-r--r--net/smokeping/Makefile3
4 files changed, 8 insertions, 10 deletions
diff --git a/net/ldapsh/Makefile b/net/ldapsh/Makefile
index 6580cf0fe111..6dbce55798c8 100644
--- a/net/ldapsh/Makefile
+++ b/net/ldapsh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ldapsh
PORTVERSION= 2.00
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
@@ -37,7 +38,7 @@ PERL_CONFIGURE= yes
.if ${PERL_LEVEL} > 500600
MAN3+= Net::LDAP::Config.3
.else
-BUILD_DEPENDS+= ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
+BUILD_DEPENDS+= ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-Pod-Parser
.endif
post-patch:
diff --git a/net/p5-Net/Makefile b/net/p5-Net/Makefile
index 7c12f69244c0..37981b63e196 100644
--- a/net/p5-Net/Makefile
+++ b/net/p5-Net/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
PERL_CONFIGURE= yes
-CONFIGURE_ARGS= INSTALLDIRS=site < /dev/null
+CONFIGURE_ARGS= < /dev/null
MAN3= Net::Cmd.3 \
Net::Config.3 \
diff --git a/net/p5-RPC-XML/Makefile b/net/p5-RPC-XML/Makefile
index 2ec83a721517..45665481394a 100644
--- a/net/p5-RPC-XML/Makefile
+++ b/net/p5-RPC-XML/Makefile
@@ -7,6 +7,7 @@
PORTNAME= RPC-XML
PORTVERSION= 0.57
+PORTREVISION= 1
CATEGORIES= net www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= RPC
@@ -16,6 +17,7 @@ MAINTAINER= martin@matuska.org
COMMENT= XML-RPC client and server library for Perl
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -33,10 +35,4 @@ MAN3= Apache::RPC::Server.3 \
RPC::XML::Procedure.3 \
RPC::XML::Server.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif # ${PERL_LEVEL} < 500601
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/smokeping/Makefile b/net/smokeping/Makefile
index 169f92ecdf4b..612d062fb21e 100644
--- a/net/smokeping/Makefile
+++ b/net/smokeping/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smokeping
PORTVERSION= 1.40
+PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= http://people.ee.ethz.ch/~oetiker/webtools/smokeping/pub/
@@ -18,7 +19,7 @@ RUN_DEPENDS= rrdtool:${PORTSDIR}/net/rrdtool \
${SITE_PERL}/BER.pm:${PORTSDIR}/net-mgmt/p5-SNMP_Session \
${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser \
+ ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-Pod-Parser \
${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
IGNORE= only works with old versions (1.0.x) of net/rrdtool