aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-03-25 14:50:30 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-03-25 14:50:30 +0000
commit766a3300c971fe7c1e1174633da32689eecffda8 (patch)
treec3aa6fb81cf18d2a4496fe8b293ca64b6b982ddf /net
parent031ab0cecfc896725521f7aa602743d325fdea75 (diff)
downloadports-766a3300c971fe7c1e1174633da32689eecffda8.tar.gz
ports-766a3300c971fe7c1e1174633da32689eecffda8.zip
- add OPTIONS
Submitted by: Warren Block Feature safe: yes
Notes
Notes: svn path=/head/; revision=293803
Diffstat (limited to 'net')
-rw-r--r--net/x11vnc/Makefile28
1 files changed, 20 insertions, 8 deletions
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index 2cd3d991d1ca..1fa30b926d86 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -7,19 +7,19 @@
PORTNAME= x11vnc
PORTVERSION= 0.9.13
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/libvncserver/${PORTNAME}/${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= VNC server for use with real X displays
+LICENSE= GPLv2
+
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
dbus:${PORTSDIR}/devel/dbus \
xcb:${PORTSDIR}/x11/libxcb \
- pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- avahi-common:${PORTSDIR}/net/avahi-app
-
-LICENSE= GPLv2
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs
USE_XORG= x11 xdamage xfixes xrandr xinerama xext xtst xau xrender xdmcp recordproto
@@ -27,15 +27,27 @@ USE_XORG= x11 xdamage xfixes xrandr xinerama xext xtst xau xrender xdmcp recordp
LDFLAGS+= -L${LOCALBASE}/lib
USE_OPENSSL= yes
USE_ICONV= yes
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-.endif
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
MAN1= x11vnc.1
PORTDOCS= AUTHORS COPYING ChangeLog NEWS README README.LibVNCServer TODO
+OPTIONS= NLS "Build with gettext support" on \
+ AVAHI "Enable AVAHI (ZeroConf)" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+.endif
+
+.if !defined(WITHOUT_AVAHI)
+LIB_DEPENDS+= avahi-common:${PORTSDIR}/net/avahi-app
+.else
+CONFIGURE_ARGS+= --without-avahi
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
@@ -49,4 +61,4 @@ post-install:
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>