aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-03-21 13:38:41 +0000
committerSteve Wills <swills@FreeBSD.org>2012-03-21 13:38:41 +0000
commitc1148b51d256666695ab891fb077cb056856b129 (patch)
tree08eff4059749a733335ada4597863bd6a38505be /net
parentd32f9be758c6258e98f6511e1212a505308419a3 (diff)
downloadports-c1148b51d256666695ab891fb077cb056856b129.tar.gz
ports-c1148b51d256666695ab891fb077cb056856b129.zip
Perl module to test Net::LDAP code
Notes
Notes: svn path=/head/; revision=293629
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-LDAP-Server-Test/Makefile26
-rw-r--r--net/p5-Net-LDAP-Server-Test/pkg-descr3
-rw-r--r--net/p5-Net-LDAP-Server-Test/pkg-plist4
4 files changed, 34 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ab895a8fcf22..863613bc1359 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -589,6 +589,7 @@
SUBDIR += p5-Net-LDAP-LDAPhash
SUBDIR += p5-Net-LDAP-Makepath
SUBDIR += p5-Net-LDAP-Server
+ SUBDIR += p5-Net-LDAP-Server-Test
SUBDIR += p5-Net-LDAP-posixAccount
SUBDIR += p5-Net-LDAP-posixGroup
SUBDIR += p5-Net-Libdnet
diff --git a/net/p5-Net-LDAP-Server-Test/Makefile b/net/p5-Net-LDAP-Server-Test/Makefile
new file mode 100644
index 000000000000..51a39254040f
--- /dev/null
+++ b/net/p5-Net-LDAP-Server-Test/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-LDAP-Server-Test
+# Date created: 2012-03-21
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-LDAP-Server-Test
+PORTVERSION= 0.12
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+#MASTER_SITE_SUBDIR= CPAN:KARMAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl module to test Net::LDAP code
+
+BUILD_DEPENDS= p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap \
+ p5-Net-LDAP-Server>=0.3:${PORTSDIR}/net/p5-Net-LDAP-Server
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::LDAP::Server::Test.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-LDAP-Server-Test/pkg-descr b/net/p5-Net-LDAP-Server-Test/pkg-descr
new file mode 100644
index 000000000000..ee2de73d81bd
--- /dev/null
+++ b/net/p5-Net-LDAP-Server-Test/pkg-descr
@@ -0,0 +1,3 @@
+Perl module to test Net::LDAP code
+
+WWW: http://search.cpan.org/dist/Net-LDAP-Server-Test/
diff --git a/net/p5-Net-LDAP-Server-Test/pkg-plist b/net/p5-Net-LDAP-Server-Test/pkg-plist
new file mode 100644
index 000000000000..b1cf881dac7f
--- /dev/null
+++ b/net/p5-Net-LDAP-Server-Test/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Net/LDAP/Server/Test.pm
+%%SITE_PERL%%/mach/auto/Net/LDAP/Server/Test/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Net/LDAP/Server/Test
+@dirrmtry %%SITE_PERL%%/Net/LDAP/Server