aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-12 16:28:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-12 16:28:14 +0000
commitfb50d122cee02ffec3a5079f3ad775e85ab40832 (patch)
tree90bfa1aa7e22660a55efe045368069aababea7c2 /net
parent095a642be25cd37f70edfa851c758f5a2e4d02b4 (diff)
downloadports-fb50d122cee02ffec3a5079f3ad775e85ab40832.tar.gz
ports-fb50d122cee02ffec3a5079f3ad775e85ab40832.zip
A Net::Proxy object represents a proxy that accepts connections and then
relays the data transfered between the source and the destination. The goal of this module is to abstract the different methods used to connect from the proxy to the destination. A proxy is a program that transfer data across a network boundary between a client and a server. Net::Proxy introduces the concept of "connectors" (implemented as Net::Proxy::Connector subclasses), which abstract the server part (connected to the client) and the client part (connected to the server) of the proxy. This architecture makes it easy to implement specific techniques to cross a given network boundary, possibly by using a proxy on one side of the network fence, and a reverse-proxy on the other side of the fence. WWW: http://search.cpan.org/dist/Net-Proxy PR: ports/119301 Submitted by: Philippe Audeoud <jadawin at tuxaco.net>
Notes
Notes: svn path=/head/; revision=205538
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Proxy/Makefile33
-rw-r--r--net/p5-Net-Proxy/distinfo3
-rw-r--r--net/p5-Net-Proxy/pkg-descr14
-rw-r--r--net/p5-Net-Proxy/pkg-plist17
5 files changed, 68 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f56306428dbe..92e3f87ae9b1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -513,6 +513,7 @@
SUBDIR += p5-Net-PcapUtils
SUBDIR += p5-Net-Ping
SUBDIR += p5-Net-Ping-External
+ SUBDIR += p5-Net-Proxy
SUBDIR += p5-Net-RTP
SUBDIR += p5-Net-Radius
SUBDIR += p5-Net-Random
diff --git a/net/p5-Net-Proxy/Makefile b/net/p5-Net-Proxy/Makefile
new file mode 100644
index 000000000000..ccf515c14ea4
--- /dev/null
+++ b/net/p5-Net-Proxy/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Net-Proxy
+# Date created: 2008-01-03
+# Whom: Philippe Audeoud <jadawin@tuxaco.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Proxy
+PORTVERSION= 0.12
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jadawin@tuxaco.net
+COMMENT= Framework for proxying network connections in many ways
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= Net::Proxy.3 \
+ Net::Proxy::Connector.3 \
+ Net::Proxy::Connector::connect.3 \
+ Net::Proxy::Connector::connect_ssl.3 \
+ Net::Proxy::Connector::dual.3 \
+ Net::Proxy::Connector::dummy.3 \
+ Net::Proxy::Connector::ssl.3 \
+ Net::Proxy::Connector::tcp.3 \
+ Net::Proxy::Tutorial.3
+
+MAN1= connect-tunnel.1 \
+ sslh.1
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Proxy/distinfo b/net/p5-Net-Proxy/distinfo
new file mode 100644
index 000000000000..39ed961cb581
--- /dev/null
+++ b/net/p5-Net-Proxy/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Proxy-0.12.tar.gz) = 84975f4d832fdccd1d3be2e49a783cde
+SHA256 (Net-Proxy-0.12.tar.gz) = 453682e462998d2140374952303ac5f11d508182cb68ac1d471623b45a41116c
+SIZE (Net-Proxy-0.12.tar.gz) = 39027
diff --git a/net/p5-Net-Proxy/pkg-descr b/net/p5-Net-Proxy/pkg-descr
new file mode 100644
index 000000000000..98436f73299d
--- /dev/null
+++ b/net/p5-Net-Proxy/pkg-descr
@@ -0,0 +1,14 @@
+A Net::Proxy object represents a proxy that accepts connections and then
+relays the data transfered between the source and the destination.
+The goal of this module is to abstract the different methods used to
+connect from the proxy to the destination.
+A proxy is a program that transfer data across a network boundary
+between a client and a server. Net::Proxy introduces the concept of
+"connectors" (implemented as Net::Proxy::Connector subclasses), which
+abstract the server part (connected to the client) and the client part
+(connected to the server) of the proxy.
+This architecture makes it easy to implement specific techniques to
+cross a given network boundary, possibly by using a proxy on one side of
+the network fence, and a reverse-proxy on the other side of the fence.
+
+WWW: http://search.cpan.org/dist/Net-Proxy
diff --git a/net/p5-Net-Proxy/pkg-plist b/net/p5-Net-Proxy/pkg-plist
new file mode 100644
index 000000000000..28209c4f46f5
--- /dev/null
+++ b/net/p5-Net-Proxy/pkg-plist
@@ -0,0 +1,17 @@
+bin/connect-tunnel
+bin/sslh
+%%SITE_PERL%%/Net/Proxy.pm
+%%SITE_PERL%%/Net/Proxy/Connector.pm
+%%SITE_PERL%%/Net/Proxy/Connector/connect.pm
+%%SITE_PERL%%/Net/Proxy/Connector/connect_ssl.pm
+%%SITE_PERL%%/Net/Proxy/Connector/dual.pm
+%%SITE_PERL%%/Net/Proxy/Connector/dummy.pm
+%%SITE_PERL%%/Net/Proxy/Connector/ssl.pm
+%%SITE_PERL%%/Net/Proxy/Connector/tcp.pm
+%%SITE_PERL%%/Net/Proxy/Tutorial.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Proxy/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Proxy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/Proxy/Connector
+@dirrm %%SITE_PERL%%/Net/Proxy
+@dirrmtry %%SITE_PERL%%/Net