aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /net
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Notes
Notes: svn path=/head/; revision=137660
Diffstat (limited to 'net')
-rw-r--r--net/aim/Makefile11
-rw-r--r--net/citrix_ica/Makefile7
-rw-r--r--net/citrix_xenapp/Makefile7
-rw-r--r--net/linux-agsatellite/Makefile9
-rw-r--r--net/linux-edonkey-core/Makefile2
-rw-r--r--net/linux-edonkey-server/Makefile13
-rw-r--r--net/linux-jigdo/Makefile5
-rw-r--r--net/linux-nx-client/Makefile10
-rw-r--r--net/linux-overnet-core/Makefile3
-rw-r--r--net/peercast/Makefile1
-rw-r--r--net/skype-devel/Makefile6
-rw-r--r--net/skype/Makefile6
12 files changed, 32 insertions, 48 deletions
diff --git a/net/aim/Makefile b/net/aim/Makefile
index f4c3788f8cbf..8c4452148451 100644
--- a/net/aim/Makefile
+++ b/net/aim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= aim
PORTVERSION= 1.5.286
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net linux
MASTER_SITES= ftp://ftp.newaol.com/aimgen/380469/
DISTNAME= aim-${PORTVERSION}
@@ -19,15 +19,14 @@ COMMENT= AOL's Instant Messenger (AIM) client
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
-PREFIX?= ${X11BASE}
-INSTALLS_SHLIB= yes
-# must not strip
-STRIP=
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/usr/bin/aim ${PREFIX}/libexec
+ ${BRANDELF} -t Linux ${PREFIX}/libexec/aim
(cd ${WRKSRC}/usr/lib;exec ${TAR} --exclude aim/source -cf - *)|(cd ${PREFIX}/lib;exec ${TAR} -xpf -)
@${ECHO_CMD} "#!/bin/sh" >${PREFIX}/bin/aim
@${ECHO_CMD} "ulimit -Sc 0" >>${PREFIX}/bin/aim
@@ -36,7 +35,7 @@ do-install:
${CHMOD} ${BINMODE} ${PREFIX}/bin/aim
post-install:
-.if !exists(/compat/linux/usr/bin/esdplay) && !exists(${PREFIX}/bin/esdplay)
+.if !exists(${LINUXBASE}/usr/bin/esdplay) && !exists(${PREFIX}/bin/esdplay)
@${ECHO_MSG} "-----------------------------------------------------------------"
@${ECHO_MSG} "Install audio/linux-esound or disable Sounds in aim's Preferences"
@${ECHO_MSG} "-----------------------------------------------------------------"
diff --git a/net/citrix_ica/Makefile b/net/citrix_ica/Makefile
index 6528556ea0bc..d8e16dc85412 100644
--- a/net/citrix_ica/Makefile
+++ b/net/citrix_ica/Makefile
@@ -7,6 +7,7 @@
PORTNAME= citrix_ica
PORTVERSION= 9.00
+PORTREVISION= 1
CATEGORIES= net comms linux
MASTER_SITES=
DISTNAME= ${PORTNAME}-linuxx86-${PORTVERSION}
@@ -14,10 +15,11 @@ DISTNAME= ${PORTNAME}-linuxx86-${PORTVERSION}
MAINTAINER= mbr@FreeBSD.org
COMMENT= Citrix(R) client for the Microsoft Windows Terminal Server
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXaw.so.6:${PORTSDIR}/x11/linux-XFree86-libs \
- ${LINUXBASE}/usr/X11R6/lib/libXm.so.3:${PORTSDIR}/x11-toolkits/linux-openmotif
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXm.so.3:${PORTSDIR}/x11-toolkits/linux-openmotif
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
RESTRICTED= "License prohibits redistribution"
IS_INTERACTIVE= "Noisy license agreement ignores stdin"
@@ -79,5 +81,6 @@ do-install:
cd ${WRKSRC} && /bin/sh -c './setupwfc'
${INSTALL_SCRIPT} ${WRKSRC}/wfcmgr.x ${PREFIX}/bin/wfcmgr
${INSTALL_SCRIPT} ${WRKSRC}/wfica.x ${PREFIX}/bin/wfica
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
.include <bsd.port.post.mk>
diff --git a/net/citrix_xenapp/Makefile b/net/citrix_xenapp/Makefile
index 6528556ea0bc..d8e16dc85412 100644
--- a/net/citrix_xenapp/Makefile
+++ b/net/citrix_xenapp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= citrix_ica
PORTVERSION= 9.00
+PORTREVISION= 1
CATEGORIES= net comms linux
MASTER_SITES=
DISTNAME= ${PORTNAME}-linuxx86-${PORTVERSION}
@@ -14,10 +15,11 @@ DISTNAME= ${PORTNAME}-linuxx86-${PORTVERSION}
MAINTAINER= mbr@FreeBSD.org
COMMENT= Citrix(R) client for the Microsoft Windows Terminal Server
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXaw.so.6:${PORTSDIR}/x11/linux-XFree86-libs \
- ${LINUXBASE}/usr/X11R6/lib/libXm.so.3:${PORTSDIR}/x11-toolkits/linux-openmotif
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXm.so.3:${PORTSDIR}/x11-toolkits/linux-openmotif
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
RESTRICTED= "License prohibits redistribution"
IS_INTERACTIVE= "Noisy license agreement ignores stdin"
@@ -79,5 +81,6 @@ do-install:
cd ${WRKSRC} && /bin/sh -c './setupwfc'
${INSTALL_SCRIPT} ${WRKSRC}/wfcmgr.x ${PREFIX}/bin/wfcmgr
${INSTALL_SCRIPT} ${WRKSRC}/wfica.x ${PREFIX}/bin/wfica
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
.include <bsd.port.post.mk>
diff --git a/net/linux-agsatellite/Makefile b/net/linux-agsatellite/Makefile
index caeb58f690ae..d0831a85a470 100644
--- a/net/linux-agsatellite/Makefile
+++ b/net/linux-agsatellite/Makefile
@@ -7,7 +7,7 @@
PORTNAME= agsatellite
PORTVERSION= 0.520
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net audio linux
MASTER_SITES= http://www.audiogalaxy.com/downloads/
PKGNAMEPREFIX= linux-
@@ -16,19 +16,16 @@ DISTNAME= AGSatellite${PORTVERSION:S/.//}-glibc21
MAINTAINER= ports@FreeBSD.org
COMMENT= Client that allows you to share your music on Audiogalaxy(TM)
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
WRKSRC= ${WRKDIR}/${DISTNAME:C/-.*//}
NO_BUILD= yes
USE_REINPLACE= yes
-STRIP=
+USE_LINUX= yes
+USE_X_PREFIX= yes
RESTRICTED= no response from developer on licensing issues
DOCS= german_readme.txt license.txt readme.txt
-BRANDELF= /usr/bin/brandelf
-
post-patch:
@${REINPLACE_CMD} -e "s| ||;s|email|username|" ${WRKSRC}/*.txt
@${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${FILESDIR}/wrapper.sh > \
diff --git a/net/linux-edonkey-core/Makefile b/net/linux-edonkey-core/Makefile
index d05dda04e973..f6a53b4c3e60 100644
--- a/net/linux-edonkey-core/Makefile
+++ b/net/linux-edonkey-core/Makefile
@@ -22,7 +22,6 @@ ONLY_FOR_ARCHS= i386
USE_LINUX= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-STRIP=
BINARY_NAME_OLD?= ${PORTNAME}clc
BINARY_NAME= donkey
@@ -30,7 +29,6 @@ BINARY_NAME= donkey
DOC_FILES= ChangeLog LISEZMOI README changelog.Debian.gz
pre-install:
-
@${BRANDELF} -t Linux ${WRKSRC}/usr/bin/${BINARY_NAME_OLD}
do-install:
diff --git a/net/linux-edonkey-server/Makefile b/net/linux-edonkey-server/Makefile
index 56ebe7e9fc78..d6128236f5a1 100644
--- a/net/linux-edonkey-server/Makefile
+++ b/net/linux-edonkey-server/Makefile
@@ -20,21 +20,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A decentralized peer-to-peer file-sharing server (eDonkey2000 server)
ONLY_FOR_ARCHS= i386
-USE_LINUX?= yes
+USE_LINUX= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
-STRIP=
#
PKGDEINSTALL= ${PKGINSTALL}
-STRIP_CMD= ${LINUXBASE}/usr/bin/strip
-
-.if exists(/usr/bin/brandelf)
-BRANDELF?= /usr/bin/brandelf
-.else
-BRANDELF?= brandelf
-.endif
-
BINARY_NAME= dserver
RC_SAMPLE= edonkey2000-server.sh.sample
@@ -57,9 +48,7 @@ do-install:
.include <bsd.port.pre.mk>
pre-install:
-.if exists(${STRIP_CMD})
@${STRIP_CMD} ${WRKSRC}/${BINARY_NAME}
-.endif
@${BRANDELF} -t Linux ${WRKSRC}/${BINARY_NAME}
.include <bsd.port.post.mk>
diff --git a/net/linux-jigdo/Makefile b/net/linux-jigdo/Makefile
index ca49a96551eb..75b3b712141b 100644
--- a/net/linux-jigdo/Makefile
+++ b/net/linux-jigdo/Makefile
@@ -21,9 +21,8 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
ONLY_FOR_ARCHS= i386
USE_BZIP2= YES
-USE_LINUX?= yes
+USE_LINUX= yes
NO_BUILD= yes
-STRIP=
PROGRAMS= jigdo-file
SCRIPTS= jigdo-lite jigdo-mirror
@@ -31,7 +30,7 @@ SCRIPTS= jigdo-lite jigdo-mirror
MAN1= jigdo-file.1 jigdo-lite.1 jigdo-mirror.1
pre-install:
- @brandelf -t Linux ${WRKSRC}/jigdo-file
+ @${BRANDELF} -t Linux ${WRKSRC}/jigdo-file
do-install:
.for i in ${PROGRAMS}
diff --git a/net/linux-nx-client/Makefile b/net/linux-nx-client/Makefile
index 65dfec9b1d07..a3a608392d28 100644
--- a/net/linux-nx-client/Makefile
+++ b/net/linux-nx-client/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linux-nx-client
PORTVERSION= 1.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.nomachine.com/download/nxclient/${PORTVERSION}/Linux-Static-Tar/
DISTNAME= nxclient-${PORTVERSION}-91.i386
@@ -18,17 +18,14 @@ COMMENT= The NoMachine NX client
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
NO_WRKSUBDIR= yes
-USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
NO_BUILD= yes
NXSRC= ${WRKSRC}/NX
NXDST= ${PREFIX}/lib/linux-nx-client
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
-
PLIST_SUB+= PORTVERSION=${PORTVERSION}
post-extract:
@@ -64,6 +61,7 @@ do-install:
${ECHO_CMD} "export NXDIR=${NXDST}" >> ${WRKSRC}/${f}
${ECHO_CMD} "exec \$$NXDIR/bin/${f} \"\$$@\"" >> ${WRKSRC}/${f}
${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
+ ${BRANDELF} -t Linux ${NXDST}/bin/${f}
.endfor
.include <bsd.port.mk>
diff --git a/net/linux-overnet-core/Makefile b/net/linux-overnet-core/Makefile
index 512dd38ea104..6ee5d30d3cfe 100644
--- a/net/linux-overnet-core/Makefile
+++ b/net/linux-overnet-core/Makefile
@@ -18,10 +18,9 @@ MAINTAINER= arundel@h3c.de
COMMENT= Overnet 'core' command line client
ONLY_FOR_ARCHS= i386
-USE_LINUX?= yes
+USE_LINUX= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-STRIP=
BINARY_NAME_OLD?= ${PORTNAME}clc
TARGET_DIR= ${PORTNAME}
diff --git a/net/peercast/Makefile b/net/peercast/Makefile
index 2886103c43d5..d48dbd357d3c 100644
--- a/net/peercast/Makefile
+++ b/net/peercast/Makefile
@@ -18,7 +18,6 @@ COMMENT= A peer-to-peer network for broadcasting and listening to streams
USE_LINUX= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
-STRIP= # empty: do not strip linux binaries
SUB_FILES= peercast.sh
diff --git a/net/skype-devel/Makefile b/net/skype-devel/Makefile
index 965e7e9852a7..a98ea5d42956 100644
--- a/net/skype-devel/Makefile
+++ b/net/skype-devel/Makefile
@@ -15,11 +15,11 @@ MAINTAINER= netchild@FreeBSD.org
COMMENT= P2P VoIP software
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
- ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
USE_BZIP2= yes
-PREFIX?= ${X11BASE}
+USE_LINUX= yes
+USE_X_PREFIX= yes
WANT_GNOME= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/net/skype/Makefile b/net/skype/Makefile
index 965e7e9852a7..a98ea5d42956 100644
--- a/net/skype/Makefile
+++ b/net/skype/Makefile
@@ -15,11 +15,11 @@ MAINTAINER= netchild@FreeBSD.org
COMMENT= P2P VoIP software
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat \
- ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
USE_BZIP2= yes
-PREFIX?= ${X11BASE}
+USE_LINUX= yes
+USE_X_PREFIX= yes
WANT_GNOME= yes
ONLY_FOR_ARCHS= i386 amd64