aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-24 05:19:50 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-24 05:19:50 +0000
commitd0cf7356bf4e787a326f3a6a48fee95b2ce8dff6 (patch)
tree81ae771bda91fb4b82dc5f403680b6bebe9b118d /net
parentb39cf9835ef445cec208ccd5866f766efff07387 (diff)
downloadports-d0cf7356bf4e787a326f3a6a48fee95b2ce8dff6.tar.gz
ports-d0cf7356bf4e787a326f3a6a48fee95b2ce8dff6.zip
Interface to Riak.
WWW: http://search.cpan.org/dist/Net-Riak/ PR: ports/152277 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=265051
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Riak/Makefile39
-rw-r--r--net/p5-Net-Riak/distinfo2
-rw-r--r--net/p5-Net-Riak/pkg-descr3
-rw-r--r--net/p5-Net-Riak/pkg-plist21
5 files changed, 66 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e612dd3376bc..3387116e4342 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -626,6 +626,7 @@
SUBDIR += p5-Net-RawSock
SUBDIR += p5-Net-Rendezvous
SUBDIR += p5-Net-Rendezvous-Publish
+ SUBDIR += p5-Net-Riak
SUBDIR += p5-Net-Rsh
SUBDIR += p5-Net-SAP
SUBDIR += p5-Net-SCP
diff --git a/net/p5-Net-Riak/Makefile b/net/p5-Net-Riak/Makefile
new file mode 100644
index 000000000000..0e39711f59a9
--- /dev/null
+++ b/net/p5-Net-Riak/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Net-Riak
+# Date created: 2010-11-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Riak
+PORTVERSION= 0.11
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Interface to Riak
+
+RUN_DEPENDS= p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
+ p5-Moose>0:${PORTSDIR}/devel/p5-Moose \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Riak.3 \
+ Net::Riak::Bucket.3 \
+ Net::Riak::Client.3 \
+ Net::Riak::Link.3 \
+ Net::Riak::LinkPhase.3 \
+ Net::Riak::MapReduce.3 \
+ Net::Riak::MapReducePhase.3 \
+ Net::Riak::Object.3 \
+ Net::Riak::Role::Base.3 \
+ Net::Riak::Role::Hosts.3 \
+ Net::Riak::Role::MapReduce.3 \
+ Net::Riak::Role::REST.3 \
+ Net::Riak::Role::Replica.3 \
+ Net::Riak::Role::UserAgent.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Riak/distinfo b/net/p5-Net-Riak/distinfo
new file mode 100644
index 000000000000..fc3de947f1a0
--- /dev/null
+++ b/net/p5-Net-Riak/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Riak-0.11.tar.gz) = 93c2ab6e9d25663dff507dda4b2398fea4990f10a6037cadf92c358c390a90f1
+SIZE (Net-Riak-0.11.tar.gz) = 24571
diff --git a/net/p5-Net-Riak/pkg-descr b/net/p5-Net-Riak/pkg-descr
new file mode 100644
index 000000000000..7cea4bf7f35b
--- /dev/null
+++ b/net/p5-Net-Riak/pkg-descr
@@ -0,0 +1,3 @@
+Interface to Riak.
+
+WWW: http://search.cpan.org/dist/Net-Riak/
diff --git a/net/p5-Net-Riak/pkg-plist b/net/p5-Net-Riak/pkg-plist
new file mode 100644
index 000000000000..a8de4cabebe9
--- /dev/null
+++ b/net/p5-Net-Riak/pkg-plist
@@ -0,0 +1,21 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Riak/.packlist
+%%SITE_PERL%%/Net/Riak.pm
+%%SITE_PERL%%/Net/Riak/Bucket.pm
+%%SITE_PERL%%/Net/Riak/Client.pm
+%%SITE_PERL%%/Net/Riak/Link.pm
+%%SITE_PERL%%/Net/Riak/LinkPhase.pm
+%%SITE_PERL%%/Net/Riak/MapReduce.pm
+%%SITE_PERL%%/Net/Riak/MapReducePhase.pm
+%%SITE_PERL%%/Net/Riak/Object.pm
+%%SITE_PERL%%/Net/Riak/Role/Base.pm
+%%SITE_PERL%%/Net/Riak/Role/Hosts.pm
+%%SITE_PERL%%/Net/Riak/Role/MapReduce.pm
+%%SITE_PERL%%/Net/Riak/Role/REST.pm
+%%SITE_PERL%%/Net/Riak/Role/Replica.pm
+%%SITE_PERL%%/Net/Riak/Role/UserAgent.pm
+@dirrmtry %%SITE_PERL%%/Net/Riak/Role
+@dirrmtry %%SITE_PERL%%/Net/Riak
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Riak
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net