aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-11-16 16:34:57 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-11-16 16:34:57 +0000
commitb73497debe35cb2bc9a576365ea33950fe0b54ff (patch)
treebb3a1dfa816a8fd6daa6ac7d82ff4fe1efb424d7 /net
parentf02fd0fdf05b886ad5f0f969923bea2efc919e23 (diff)
downloadports-b73497debe35cb2bc9a576365ea33950fe0b54ff.tar.gz
ports-b73497debe35cb2bc9a576365ea33950fe0b54ff.zip
- Fix build on 4.x (stdint.h -> inttypes.h)
Submitted by: mnag
Notes
Notes: svn path=/head/; revision=148491
Diffstat (limited to 'net')
-rw-r--r--net/libnet-devel/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/net/libnet-devel/Makefile b/net/libnet-devel/Makefile
index 99282bfaad90..c9e690d1b2ad 100644
--- a/net/libnet-devel/Makefile
+++ b/net/libnet-devel/Makefile
@@ -17,6 +17,7 @@ COMMENT= A C library for creating IP packets (development version)
CONFLICTS= libnet*-1.*
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -27,6 +28,16 @@ DOCS= README doc/BUGS doc/CHANGELOG doc/CONTRIB doc/COPYING \
doc/RAWSOCKET_NON_SEQUITUR doc/TODO
EXAMPLES= sample/*.c
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 500000
+ ${REINPLACE_CMD} -e "s|stdint.h|inttypes.h|g" \
+ ${WRKSRC}/include/libnet/libnet-types.h
+.else
+ ${DO_NADA}
+.endif
+
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/libnet-config ${PREFIX}/bin
@${MKDIR} ${EXAMPLESDIR}
@@ -36,4 +47,4 @@ post-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>