aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-09 12:26:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-09 12:26:54 +0000
commit38d3364d0da1368ce3bfeb15465bff143ebd8fbc (patch)
tree43e563a2082e5ca71645aca1e0ee003473ffb60c /net
parentc2afcffae17cc62e9cb2dc114b6d313f572e1751 (diff)
downloadports-38d3364d0da1368ce3bfeb15465bff143ebd8fbc.tar.gz
ports-38d3364d0da1368ce3bfeb15465bff143ebd8fbc.zip
New ports: coda6_server and coda6_client
I've just added the kernel support for Coda 6.x. It would be great to have the server and client in the ports collection to make it easier for people to experiment with. PR: ports/56623 Submitted by: Tim Robbins <tim@robbins.dropbear.id.au>
Notes
Notes: svn path=/head/; revision=88851
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/coda6_server/Makefile43
-rw-r--r--net/coda6_server/distinfo1
-rw-r--r--net/coda6_server/pkg-descr11
-rw-r--r--net/coda6_server/pkg-plist43
5 files changed, 99 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e550843d7d49..83ba2738a8f3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -67,6 +67,7 @@
SUBDIR += coda5_client
SUBDIR += coda5_doc
SUBDIR += coda5_server
+ SUBDIR += coda6_server
SUBDIR += coda_doc
SUBDIR += coda_intro
SUBDIR += confregdecode
diff --git a/net/coda6_server/Makefile b/net/coda6_server/Makefile
new file mode 100644
index 000000000000..ced80dbfff27
--- /dev/null
+++ b/net/coda6_server/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: coda-server-6
+# Date created: 9 september 2003
+# Whom: Tim Robbins
+
+# $FreeBSD$
+
+PORTNAME= coda
+PORTVERSION= ${CODA_VERSION}
+PORTREVISION= 1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.coda.cs.cmu.edu/pub/coda/src/
+PKGNAMESUFFIX= -${CODA_SUITE}
+DISTNAME= coda-${PORTVERSION}
+
+MAINTAINER?= tim@robbins.dropbear.id.au
+COMMENT= Server programs for a replicated high-performance network file system
+
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
+ lwp.2:${PORTSDIR}/devel/lwp \
+ rpc2.4:${PORTSDIR}/devel/rpc2 \
+ rvm.2:${PORTSDIR}/devel/rvm
+
+CONFLICTS= coda-server-5.*
+
+ALL_TARGET= coda
+INSTALL_TARGET= ${CODA_SUITE}-install
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS?= --sysconfdir=${PREFIX}/etc/rc.d
+
+CODA_SUITE?= server
+CODA_VERSION?= 6.0.2
+
+.include <bsd.port.pre.mk>
+
+.if ${CODA_SUITE} == client
+.if ${OSVERSION} < 501106
+IGNORE= "This version of FreeBSD lacks Coda 6.x kernel support"
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/coda6_server/distinfo b/net/coda6_server/distinfo
new file mode 100644
index 000000000000..a3ba26e041f7
--- /dev/null
+++ b/net/coda6_server/distinfo
@@ -0,0 +1 @@
+MD5 (coda-6.0.2.tar.gz) = bb3b98c3302e0d5a2a9d16e88055838c
diff --git a/net/coda6_server/pkg-descr b/net/coda6_server/pkg-descr
new file mode 100644
index 000000000000..67606731d270
--- /dev/null
+++ b/net/coda6_server/pkg-descr
@@ -0,0 +1,11 @@
+Coda is a distributed file system. Among its features are disconnected
+operation, good security model, server replication and persistent
+client side caching.
+
+This package builds the entire source tree but only installs(/packages)
+the server side programs.
+
+For more info, contact information available below.
+
+EMAIL: coda@cs.cmu.edu
+WWW: http://www.coda.cs.cmu.edu/
diff --git a/net/coda6_server/pkg-plist b/net/coda6_server/pkg-plist
new file mode 100644
index 000000000000..e7866bdd655c
--- /dev/null
+++ b/net/coda6_server/pkg-plist
@@ -0,0 +1,43 @@
+bin/norton
+bin/norton-reinit
+bin/reinit
+bin/getvolinfo
+bin/rpc2ping
+bin/smon2
+etc/coda/server.conf.ex
+@dirrm etc/coda
+sbin/au
+sbin/auth2
+sbin/backup
+sbin/backup.sh
+sbin/bldvldb.sh
+sbin/codaconfedit
+sbin/coda-server-logrotate
+sbin/coda-setup-ports
+sbin/codasrv
+sbin/codastart
+sbin/createvol_rep
+sbin/initpw
+sbin/inoder
+sbin/merge
+sbin/parserecdump
+sbin/partial-reinit.sh
+sbin/pdbtool
+sbin/printvrdb
+sbin/purgevol
+sbin/purgevol_rep
+sbin/readdump
+sbin/rpc2portmap
+sbin/startserver
+sbin/tape.pl
+sbin/updateclnt
+sbin/updatefetch
+sbin/updatesrv
+sbin/vice-killvolumes
+sbin/vice-setup
+sbin/vice-setup-rvm
+sbin/vice-setup-scm
+sbin/vice-setup-srvdir
+sbin/vice-setup-user
+sbin/volutil
+etc/rc.d/rc.vice