aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-03-15 20:08:43 +0000
committerSteve Price <steve@FreeBSD.org>1998-03-15 20:08:43 +0000
commita771efb1f51bfa0fe056a8d54acd1c0bad624776 (patch)
treea66994ea9502494398cd76084aa8390bfccf7649 /net
parente2922bf70763a0b288ea5adce3cf7cecfcb6efc3 (diff)
downloadports-a771efb1f51bfa0fe056a8d54acd1c0bad624776.tar.gz
ports-a771efb1f51bfa0fe056a8d54acd1c0bad624776.zip
Initial import of p5-Net-Telnet.
perl5 module to access and use telnet protocol. PR: 5903 Submitted by: Jun Kuriyama <kuriyama@opt.phys.waseda.ac.jp>
Notes
Notes: svn path=/head/; revision=10152
Diffstat (limited to 'net')
-rw-r--r--net/p5-Net-Telnet/Makefile24
-rw-r--r--net/p5-Net-Telnet/distinfo1
-rw-r--r--net/p5-Net-Telnet/pkg-comment1
-rw-r--r--net/p5-Net-Telnet/pkg-descr12
-rw-r--r--net/p5-Net-Telnet/pkg-plist4
5 files changed, 42 insertions, 0 deletions
diff --git a/net/p5-Net-Telnet/Makefile b/net/p5-Net-Telnet/Makefile
new file mode 100644
index 000000000000..259566681ae9
--- /dev/null
+++ b/net/p5-Net-Telnet/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Net-Telnet
+# Version required: 3.01
+# Date created: March 3 1998
+# Whom: Jun Kuriyama <kuriyama@opt.phys.waseda.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= Net-Telnet-3.01
+PKGNAME= p5-Net-Telnet-3.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+
+MAINTAINER= kuriyama@opt.phys.waseda.ac.jp
+
+USE_PERL5= YES
+
+MAN3= Net::Telnet.3
+MANPREFIX= ${PREFIX}/lib/perl5
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Telnet/distinfo b/net/p5-Net-Telnet/distinfo
new file mode 100644
index 000000000000..5f4235e03fc2
--- /dev/null
+++ b/net/p5-Net-Telnet/distinfo
@@ -0,0 +1 @@
+MD5 (Net-Telnet-3.01.tar.gz) = 60168f232b8da397ff16f3cfe820510a
diff --git a/net/p5-Net-Telnet/pkg-comment b/net/p5-Net-Telnet/pkg-comment
new file mode 100644
index 000000000000..a6299f3f4d90
--- /dev/null
+++ b/net/p5-Net-Telnet/pkg-comment
@@ -0,0 +1 @@
+perl5 module to access and use telnet protocol.
diff --git a/net/p5-Net-Telnet/pkg-descr b/net/p5-Net-Telnet/pkg-descr
new file mode 100644
index 000000000000..91df34f597a0
--- /dev/null
+++ b/net/p5-Net-Telnet/pkg-descr
@@ -0,0 +1,12 @@
+ Description
+ -----------
+
+ Net::Telnet allows you to make client connections to a TCP port
+ and do network I/O, especially with a port using the TELNET
+ protocol. Simple I/O methods such as print, get, and getline are
+ provided. More sophisticated interactive features are provided
+ because connecting to a TELNET port ultimately means communicating
+ with a program designed for human interaction. Some interactive
+ features include the ability to specify a timeout and to wait for
+ patterns to appear in the input stream, such as the prompt from a
+ command interpreter.
diff --git a/net/p5-Net-Telnet/pkg-plist b/net/p5-Net-Telnet/pkg-plist
new file mode 100644
index 000000000000..c6e4fe5efc21
--- /dev/null
+++ b/net/p5-Net-Telnet/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/man/man3/Net::Telnet.3.gz
+lib/perl5/site_perl/Net/Telnet.pm
+lib/perl5/site_perl/i386-freebsd/auto/Net/Telnet/.packlist
+@dirrm lib/perl5/site_perl/i386-freebsd/auto/Net/Telnet