aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-05-23 22:22:19 +0000
committerPatrick Li <pat@FreeBSD.org>2002-05-23 22:22:19 +0000
commit03f189ed5b5a5559e1a2ac5154ffbb0d247b086e (patch)
treea7d8311612999f81e004ab9fe53399cfe729f724 /net
parent52cc034e89ec1c9bb688c6b17513311efae31bb2 (diff)
downloadports-03f189ed5b5a5559e1a2ac5154ffbb0d247b086e.tar.gz
ports-03f189ed5b5a5559e1a2ac5154ffbb0d247b086e.zip
back out commit made comparing OSVERSION and use sed(1) to workaround perl
on current issue. gotta back it out sooner or later. /me puts on pointy hat Requested by: many
Notes
Notes: svn path=/head/; revision=59826
Diffstat (limited to 'net')
-rw-r--r--net/py-adns/Makefile10
-rw-r--r--net/py-google/Makefile13
2 files changed, 3 insertions, 20 deletions
diff --git a/net/py-adns/Makefile b/net/py-adns/Makefile
index 83e40776422b..b741415a3123 100644
--- a/net/py-adns/Makefile
+++ b/net/py-adns/Makefile
@@ -20,17 +20,9 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
-.include <bsd.port.pre.mk>
-
post-patch:
-.if ${OSVERSION} < 500036
@${PERL} -pi -e 's|^(include_dirs = ).*$$|\1\["${LOCALBASE}/include"\]|g; \
s|^(library_dirs = ).*$$|\1\["${LOCALBASE}/lib"\]|g' \
${WRKSRC}/setup.py
-.else
- @${SED} -i.orig -e 's|^\(include_dirs = \).*$$|\1\["${LOCALBASE}/include"\]|g' \
- -e 's|^\(library_dirs = \).*$$|\1\["${LOCALBASE}/lib"\]|g' \
- ${WRKSRC}/setup.py
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/py-google/Makefile b/net/py-google/Makefile
index cf9e7a7be960..5c2116e04df9 100644
--- a/net/py-google/Makefile
+++ b/net/py-google/Makefile
@@ -24,24 +24,15 @@ EXTRACT_BEFORE_ARGS= -q -aa
WRKSRC= ${WRKDIR}/pygoogle
EXAMPLESDIR= ${PREFIX}/share/examples/py-google
-.include <bsd.port.pre.mk>
-
post-patch:
# www/py-websvcs has an incompatible version of SOAP.py
@${MV} ${WRKSRC}/SOAP.py ${WRKSRC}/SOAPgoogle.py
-.if ${OSVERSION} < 500036
@cd ${WRKSRC}; for f in *.py; do \
${PERL} -pi -e 's,import SOAP,import SOAPgoogle as SOAP,g' $$f; \
done
- @${PERL} -pi -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
-.else
- @cd ${WRKSRC}; for f in *.py; do \
- ${SED} -i "" -e 's,import SOAP,import SOAPgoogle as SOAP,g' $$f; \
- done
- @${SED} -i.orig -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
-.endif
@${MKDIR} ${WRKSRC}/tests
@${MV} ${WRKSRC}/*test*.py ${WRKSRC}/tests
+ @${PERL} -pi -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
post-install:
.if !defined(NOPORTDOCS)
@@ -50,4 +41,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>