aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-27 13:14:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-27 13:14:56 +0000
commit4f97a36abf6be4b08a29f0b740dce1c4bb89e0c6 (patch)
tree7dbc1e6df0778747939ba0b2cc76bd9dc1256d4e /net
parent22fe192f88d66e4ac80f19709e1664c5ce46ac11 (diff)
downloadports-4f97a36abf6be4b08a29f0b740dce1c4bb89e0c6.tar.gz
ports-4f97a36abf6be4b08a29f0b740dce1c4bb89e0c6.zip
WebService::Dropbox is Perl interface to Dropbox API
WWW: http://search.cpan.org/dist/WebService-Dropbox/ PR: ports/162898 Submitted by: Lung-Pin Chang <changlp@cs.nctu.edu.tw> Feature safe: yes
Notes
Notes: svn path=/head/; revision=286504
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-WebService-Dropbox/Makefile24
-rw-r--r--net/p5-WebService-Dropbox/distinfo2
-rw-r--r--net/p5-WebService-Dropbox/pkg-descr3
-rw-r--r--net/p5-WebService-Dropbox/pkg-plist4
5 files changed, 34 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a5a7fa0884e7..95cd758974d9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -729,6 +729,7 @@
SUBDIR += p5-URI-Template
SUBDIR += p5-URI-Template-Restrict
SUBDIR += p5-Validate-Net
+ SUBDIR += p5-WebService-Dropbox
SUBDIR += p5-What
SUBDIR += p5-X500-DN
SUBDIR += p5-XML-Compile-SOAP
diff --git a/net/p5-WebService-Dropbox/Makefile b/net/p5-WebService-Dropbox/Makefile
new file mode 100644
index 000000000000..33a6e87db581
--- /dev/null
+++ b/net/p5-WebService-Dropbox/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-WebService-Dropbox
+# Date created: 2011-11-25
+# Whom: Lung-Pin Chang <changlp@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebService-Dropbox
+PORTVERSION= 0.03
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= changlp@cs.nctu.edu.tw
+COMMENT= Perl interface to Dropbox API
+
+RUN_DEPENDS= p5-Net-OAuth>=0:${PORTSDIR}/net/p5-Net-OAuth \
+ p5-String-Random>=0:${PORTSDIR}/devel/p5-String-Random
+
+PERL_CONFIGURE= yes
+
+MAN3= WebService::Dropbox.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-WebService-Dropbox/distinfo b/net/p5-WebService-Dropbox/distinfo
new file mode 100644
index 000000000000..a53e8f2ac0fd
--- /dev/null
+++ b/net/p5-WebService-Dropbox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (WebService-Dropbox-0.03.tar.gz) = 756b281d797b4503aba5f4ea6ef9a66c3dc276e32d4b0a264195a20da912c257
+SIZE (WebService-Dropbox-0.03.tar.gz) = 67936
diff --git a/net/p5-WebService-Dropbox/pkg-descr b/net/p5-WebService-Dropbox/pkg-descr
new file mode 100644
index 000000000000..5b366a0efeab
--- /dev/null
+++ b/net/p5-WebService-Dropbox/pkg-descr
@@ -0,0 +1,3 @@
+WebService::Dropbox is Perl interface to Dropbox API
+
+WWW: http://search.cpan.org/dist/WebService-Dropbox/
diff --git a/net/p5-WebService-Dropbox/pkg-plist b/net/p5-WebService-Dropbox/pkg-plist
new file mode 100644
index 000000000000..0a55af49a2fa
--- /dev/null
+++ b/net/p5-WebService-Dropbox/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/WebService/Dropbox.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService-Dropbox/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService-Dropbox
+@dirrmtry %%SITE_PERL%%/WebService