aboutsummaryrefslogtreecommitdiff
path: root/news/PicMonger
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-02 13:05:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-12-02 13:05:53 +0000
commita3cd942cb82d1eb1b3b971fae8c376ce13f82673 (patch)
treed3b706e0d6df57f2548f4b3db989b38b57ef8681 /news/PicMonger
parent6f9251c42ec7993c37549794b0adcfe30c387246 (diff)
downloadports-a3cd942cb82d1eb1b3b971fae8c376ce13f82673.tar.gz
ports-a3cd942cb82d1eb1b3b971fae8c376ce13f82673.zip
- Unbreak: fix build on 5.X and above
PR: ports/106201 Submitted by: Peter Johnson <johnson.peter@gmail.com>
Notes
Notes: svn path=/head/; revision=178584
Diffstat (limited to 'news/PicMonger')
-rw-r--r--news/PicMonger/Makefile10
-rw-r--r--news/PicMonger/files/patch-ErrorLogger.cpp11
-rw-r--r--news/PicMonger/files/patch-Exceptions.cpp53
-rw-r--r--news/PicMonger/files/patch-FileTypeState.cpp14
-rw-r--r--news/PicMonger/files/patch-FilenameCleaner.cpp14
-rw-r--r--news/PicMonger/files/patch-GroupState.cpp12
-rw-r--r--news/PicMonger/files/patch-GroupState.h10
-rw-r--r--news/PicMonger/files/patch-HtmlPage.cpp11
-rw-r--r--news/PicMonger/files/patch-HtmlPage.h10
-rw-r--r--news/PicMonger/files/patch-InetSocket.cpp20
-rw-r--r--news/PicMonger/files/patch-NewsScanner.cpp11
-rw-r--r--news/PicMonger/files/patch-OptionsTab.cpp11
-rw-r--r--news/PicMonger/files/patch-ad12
-rw-r--r--news/PicMonger/files/patch-imlib.h11
14 files changed, 199 insertions, 11 deletions
diff --git a/news/PicMonger/Makefile b/news/PicMonger/Makefile
index 3c31561222cc..e4f11cec5efa 100644
--- a/news/PicMonger/Makefile
+++ b/news/PicMonger/Makefile
@@ -7,7 +7,7 @@
PORTNAME= PicMonger
PORTVERSION= 0.9.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= news graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=picmonger
@@ -23,10 +23,4 @@ USE_GMAKE= yes
USE_GNOME= imlib
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/news/PicMonger/files/patch-ErrorLogger.cpp b/news/PicMonger/files/patch-ErrorLogger.cpp
new file mode 100644
index 000000000000..aa4f74e9ecdf
--- /dev/null
+++ b/news/PicMonger/files/patch-ErrorLogger.cpp
@@ -0,0 +1,11 @@
+--- ErrorLogger.cpp.orig Tue Mar 14 23:43:02 2000
++++ ErrorLogger.cpp Fri Dec 1 22:27:20 2006
+@@ -28,6 +28,8 @@
+ using std::ofstream;
+ using std::string;
+ using std::list;
++using std::ios;
++using std::endl;
+
+ ErrorLogger* ErrorLogger::instance = 0;
+
diff --git a/news/PicMonger/files/patch-Exceptions.cpp b/news/PicMonger/files/patch-Exceptions.cpp
new file mode 100644
index 000000000000..d50037cba082
--- /dev/null
+++ b/news/PicMonger/files/patch-Exceptions.cpp
@@ -0,0 +1,53 @@
+--- Exceptions.cpp.orig Tue Mar 28 02:00:12 2000
++++ Exceptions.cpp Fri Dec 1 22:24:08 2006
+@@ -29,8 +29,8 @@
+
+ ///////////////////////////////////////////////////////////////////////////////////
+
+-Basic::Basic( const string& location = "Unknown",
+- const string& condition = "Unknown" )
++Basic::Basic( const string& location,
++ const string& condition )
+ : abort(false), loc( location ), cond( condition )
+ {
+ }
+@@ -65,8 +65,8 @@
+
+ ////////////////////////////////////////////////////////////////////////////////////
+
+-Fatal::Fatal( const string& location = "Unknown",
+- const string& condition = "Fatal Error" )
++Fatal::Fatal( const string& location,
++ const string& condition )
+ : Basic( location, condition )
+ {
+ }
+@@ -81,7 +81,7 @@
+
+ ////////////////////////////////////////////////////////////////////////////////////
+
+-NullPointer::NullPointer( const string& location = "Unknown" )
++NullPointer::NullPointer( const string& location )
+ : Fatal( location, "Attempted to dereference or access a null pointer." )
+ {}
+
+@@ -94,8 +94,8 @@
+ }
+
+ ////////////////////////////////////////////////////////////////////////////////////
+-FileAccess::FileAccess( const string& location = "Unknown",
+- const string& filename = "Filename Not Specified" )
++FileAccess::FileAccess( const string& location,
++ const string& filename )
+ : Basic( location, "File Not Found or Access Denied" ), fname( filename )
+ {}
+
+@@ -160,7 +160,7 @@
+ ////////////////////////////////////////////////////////////////////////////////////
+
+ TimeOut::TimeOut( const string& location, HtmlGenerator *htmlgen,
+- const string& pending_io = "(Err During Read)" )
++ const string& pending_io )
+ : Basic( location, "Socket I/O Timed Out" ), pend_io( pending_io ),
+ p_htgen( htmlgen )
+ {}
diff --git a/news/PicMonger/files/patch-FileTypeState.cpp b/news/PicMonger/files/patch-FileTypeState.cpp
new file mode 100644
index 000000000000..1b39e8d6c9ca
--- /dev/null
+++ b/news/PicMonger/files/patch-FileTypeState.cpp
@@ -0,0 +1,14 @@
+--- FileTypeState.cpp.orig Tue Apr 18 21:22:46 2000
++++ FileTypeState.cpp Fri Dec 1 22:45:01 2006
+@@ -21,6 +21,11 @@
+ #include <fstream>
+ #include <stdlib.h> // need getenv()
+
++using std::ofstream;
++using std::ifstream;
++using std::ios;
++using std::flush;
++
+ // Implemented as a Singleton to simplify access from both filetype dialog and
+ // newsscanner without having to maintain references to each other
+
diff --git a/news/PicMonger/files/patch-FilenameCleaner.cpp b/news/PicMonger/files/patch-FilenameCleaner.cpp
new file mode 100644
index 000000000000..f489c1e4a840
--- /dev/null
+++ b/news/PicMonger/files/patch-FilenameCleaner.cpp
@@ -0,0 +1,14 @@
+--- FilenameCleaner.cpp.orig Tue Apr 11 12:01:47 2000
++++ FilenameCleaner.cpp Fri Dec 1 22:46:08 2006
+@@ -5,8 +5,11 @@
+ #include "FileTypeState.h" // need enum FileTypes
+ #include <ctype.h> // need tolower()
+ #include <strstream>
++#include <iostream>
+
+ using std::strstream;
++using std::cerr;
++using std::endl;
+
+ FilenameCleaner::FilenameCleaner()
+ {
diff --git a/news/PicMonger/files/patch-GroupState.cpp b/news/PicMonger/files/patch-GroupState.cpp
new file mode 100644
index 000000000000..a52901538a40
--- /dev/null
+++ b/news/PicMonger/files/patch-GroupState.cpp
@@ -0,0 +1,12 @@
+--- GroupState.cpp.orig Tue Mar 14 23:43:08 2000
++++ GroupState.cpp Fri Dec 1 22:47:05 2006
+@@ -24,6 +24,9 @@
+ #include <stdlib.h> // need getenv
+
+ using std::string;
++using std::ifstream;
++using std::ofstream;
++using std::ios;
+
+ GroupState::GroupState(const string& groupname, const string& max_msg_id)
+ : group(groupname)
diff --git a/news/PicMonger/files/patch-GroupState.h b/news/PicMonger/files/patch-GroupState.h
new file mode 100644
index 000000000000..ccba1d1e0dd1
--- /dev/null
+++ b/news/PicMonger/files/patch-GroupState.h
@@ -0,0 +1,10 @@
+--- GroupState.h.orig Tue Mar 14 23:43:08 2000
++++ GroupState.h Fri Dec 1 22:47:53 2006
+@@ -26,6 +26,7 @@
+
+ using std::string;
+ using std::map;
++using std::less;
+
+ typedef map< string, string, less<string> > GroupStateData;
+ typedef GroupStateData::value_type StatePair;
diff --git a/news/PicMonger/files/patch-HtmlPage.cpp b/news/PicMonger/files/patch-HtmlPage.cpp
new file mode 100644
index 000000000000..318c46ee8785
--- /dev/null
+++ b/news/PicMonger/files/patch-HtmlPage.cpp
@@ -0,0 +1,11 @@
+--- HtmlPage.cpp.orig Tue Apr 4 01:59:24 2000
++++ HtmlPage.cpp Fri Dec 1 22:34:09 2006
+@@ -26,6 +26,8 @@
+ #endif
+
+ using std::string;
++using std::ios;
++using std::endl;
+
+ HtmlPage::HtmlPage( const string& path,
+ const string& _filename,
diff --git a/news/PicMonger/files/patch-HtmlPage.h b/news/PicMonger/files/patch-HtmlPage.h
new file mode 100644
index 000000000000..1709af85b89b
--- /dev/null
+++ b/news/PicMonger/files/patch-HtmlPage.h
@@ -0,0 +1,10 @@
+--- HtmlPage.h.orig Wed Mar 22 01:20:48 2000
++++ HtmlPage.h Fri Dec 1 22:33:36 2006
+@@ -27,6 +27,7 @@
+ #include "Exceptions.h"
+
+ using std::string;
++using std::ofstream;
+
+ class HtmlPage {
+
diff --git a/news/PicMonger/files/patch-InetSocket.cpp b/news/PicMonger/files/patch-InetSocket.cpp
new file mode 100644
index 000000000000..296f3cd0c4b4
--- /dev/null
+++ b/news/PicMonger/files/patch-InetSocket.cpp
@@ -0,0 +1,20 @@
+--- InetSocket.cpp.orig Tue Mar 14 23:43:09 2000
++++ InetSocket.cpp Fri Dec 1 22:20:58 2006
+@@ -31,7 +31,7 @@
+ #include <errno.h>
+ #include <unistd.h>
+
+-InetSocket::InetSocket(int type=SOCK_STREAM, int protocol=0)
++InetSocket::InetSocket(int type, int protocol)
+ : type_(type), protocol_(protocol)
+ {
+ local_fd = socket( PF_INET, type_, protocol_ );
+@@ -58,7 +58,7 @@
+ return result;
+ }
+
+-int InetSocket::s_bind( int port, const char *dotquad = (const char *)0)
++int InetSocket::s_bind( int port, const char *dotquad)
+ {
+ // construct local address to which we want our unnamed socket bound
+ if (!dotquad)
diff --git a/news/PicMonger/files/patch-NewsScanner.cpp b/news/PicMonger/files/patch-NewsScanner.cpp
new file mode 100644
index 000000000000..9d1e4daf9d55
--- /dev/null
+++ b/news/PicMonger/files/patch-NewsScanner.cpp
@@ -0,0 +1,11 @@
+--- NewsScanner.cpp.orig Fri Jul 14 12:58:22 2000
++++ NewsScanner.cpp Fri Dec 1 22:19:44 2006
+@@ -58,7 +58,7 @@
+
+
+ NewsScanner::NewsScanner(NewsScannerView *nsv, const char* saddr,
+- const char* ng, ScanOrder so=NS_FORWARD)
++ const char* ng, ScanOrder so)
+
+ : p_NSV(nsv), so_(so), htmlgen("."), p_htgen( 0 ),
+ serv_addr( saddr ), serv_port( 119 ), group( ng ),
diff --git a/news/PicMonger/files/patch-OptionsTab.cpp b/news/PicMonger/files/patch-OptionsTab.cpp
new file mode 100644
index 000000000000..308ef54fc0b8
--- /dev/null
+++ b/news/PicMonger/files/patch-OptionsTab.cpp
@@ -0,0 +1,11 @@
+--- OptionsTab.cpp.orig Tue Apr 11 20:40:30 2000
++++ OptionsTab.cpp Fri Dec 1 22:35:20 2006
+@@ -8,6 +8,8 @@
+ #include <iostream>
+
+ using std::cerr;
++using std::string;
++using std::endl;
+
+ OptionsTab::OptionsTab()
+ : Gtk::Table( 4, 1, true )
diff --git a/news/PicMonger/files/patch-ad b/news/PicMonger/files/patch-ad
index 2fece371fe56..3dc0f0590712 100644
--- a/news/PicMonger/files/patch-ad
+++ b/news/PicMonger/files/patch-ad
@@ -1,6 +1,6 @@
---- HtmlOptionState.cpp.old Sun Jul 23 01:47:29 2000
-+++ HtmlOptionState.cpp Sun Jul 23 01:47:43 2000
-@@ -17,6 +17,9 @@
+--- HtmlOptionState.cpp.orig Fri Jul 14 12:58:22 2000
++++ HtmlOptionState.cpp Fri Dec 1 22:39:45 2006
+@@ -17,11 +17,15 @@
// along with this program; if not, write to the Free Software
// Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
@@ -10,3 +10,9 @@
#include "HtmlOptionState.h"
#include <fstream>
+ using std::ifstream;
+ using std::ofstream;
++using std::ios;
+
+ HtmlOptionState* HtmlOptionState::instance = 0;
+ HtmlOptionState* HtmlOptionState::Instance()
diff --git a/news/PicMonger/files/patch-imlib.h b/news/PicMonger/files/patch-imlib.h
new file mode 100644
index 000000000000..43ff347f8ee8
--- /dev/null
+++ b/news/PicMonger/files/patch-imlib.h
@@ -0,0 +1,11 @@
+--- imlib.h.orig Sun Apr 23 00:11:09 2000
++++ imlib.h Fri Dec 1 22:18:13 2006
+@@ -29,7 +29,7 @@
+
+ #include <gdk--.h>
+ #include <gdk_imlib.h>
+-
++using std::string;
+ class Gdk_Imlib
+ {
+ public: