aboutsummaryrefslogtreecommitdiff
path: root/news/aub
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-10-13 07:02:39 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-10-13 07:02:39 +0000
commited0554a9fa337e6fb84ffcebfc05861b112bc638 (patch)
tree502473778f29d53340e83b99df56cfc09765d4fb /news/aub
parent413ea0e8ba47daab76c8a96b6a0ce8483b9b6022 (diff)
downloadports-ed0554a9fa337e6fb84ffcebfc05861b112bc638.tar.gz
ports-ed0554a9fa337e6fb84ffcebfc05861b112bc638.zip
Automatic assembly of usenet binaries.
Keeps track of what you've gotten already, what has parts missing, etc.
Notes
Notes: svn path=/head/; revision=8232
Diffstat (limited to 'news/aub')
-rw-r--r--news/aub/Makefile43
-rw-r--r--news/aub/distinfo3
-rw-r--r--news/aub/pkg-comment1
-rw-r--r--news/aub/pkg-descr23
-rw-r--r--news/aub/pkg-plist3
5 files changed, 73 insertions, 0 deletions
diff --git a/news/aub/Makefile b/news/aub/Makefile
new file mode 100644
index 000000000000..540c6d4a94f6
--- /dev/null
+++ b/news/aub/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=8
+# Ports collection makefile for: aub
+# Version required: v2.0.5
+# Date created: Sun Oct 12, 1997
+# Whom: David O'Brien (obrien@cs.ucdavis.edu)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= aub
+PKGNAME= aub-2.0.5
+CATEGORIES= news
+MASTER_SITES= ftp://ftp.cdrom.com/pub/perl/CPAN/scripts/news/nntpstuff/aub/ \
+ ftp://ftp.digital.com/pub/plan/perl/CPAN/scripts/news/nntpstuff/aub/ \
+ ftp://ftp.perl.org/pub/CPAN/scripts/news/nntpstuff/aub/
+DISTFILES= aub aub.1 BUG_FIXES
+
+MAINTAINER= obrien@FreeBSD.ORG
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+MAN1= aub.1
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+
+pre-configure:
+ @${SED} -e '1,1s:/usr/local/bin/perl:!/usr/bin/perl:' \
+ -e 's:$SUM = "/bin/sum":$SUM = "/usr/bin/sum":' \
+ ${DISTDIR}/aub > ${WRKDIR}/aub
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/aub ${PREFIX}/bin
+ ${INSTALL_MAN} ${DISTDIR}/aub.1 ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/doc/aub
+ ${INSTALL_MAN} ${DISTDIR}/BUG_FIXES ${PREFIX}/share/doc/aub
+
+#
+# There is a patch to aub to run with perl5.
+# You may find it in the files/ dir.
+#
+
+.include <bsd.port.mk>
diff --git a/news/aub/distinfo b/news/aub/distinfo
new file mode 100644
index 000000000000..703395c8d5a6
--- /dev/null
+++ b/news/aub/distinfo
@@ -0,0 +1,3 @@
+MD5 (aub) = 74892a6ae002937d011d3e1102269b7f
+MD5 (aub.1) = 813f6c5782f6cce0412e462ab41e7f03
+MD5 (BUG_FIXES) = 394a97815510cef50655646f54932915
diff --git a/news/aub/pkg-comment b/news/aub/pkg-comment
new file mode 100644
index 000000000000..ec6c4417fe07
--- /dev/null
+++ b/news/aub/pkg-comment
@@ -0,0 +1 @@
+assemble usenet binaries
diff --git a/news/aub/pkg-descr b/news/aub/pkg-descr
new file mode 100644
index 000000000000..dabb314b7aeb
--- /dev/null
+++ b/news/aub/pkg-descr
@@ -0,0 +1,23 @@
+More and more people are posting binary files to usenet these days.
+Because of limitations in the type data that usenet can accommodate,
+binaries must be encoded into text, and because binary files are
+commonly very large relative to text files usenet was designed to
+handle, they frequently must be broken up into pieces.
+
+aub, which stands for "assemble usenet binaries", automates the
+reassembly process for you. aub determines whether or not any new
+binaries have appeared in selected newsgroups since the last time it was
+run, and if so, retrieves, organizes and decodes them, depositing them
+in a configurable location. This process requires no human intervention
+once aub has been configured. aub also keeps track of binaries which it
+has seen some, but not all, of the pieces of. It remembers how to find
+these old pieces, so that when new, previously missing pieces arrive at
+your site, it will build the entire binary the next time it is run. It
+also remembers which binaries it has already seen all of the pieces of
+already, so that it does not waste time rebuilding the same binaries
+over and over again.
+
+run: ``aub -M | more'' for the long form documentation, or
+ ``aub -m | more'' for the short form.
+
+-- David (obrien@NUXI.com)
diff --git a/news/aub/pkg-plist b/news/aub/pkg-plist
new file mode 100644
index 000000000000..cd52be863c7b
--- /dev/null
+++ b/news/aub/pkg-plist
@@ -0,0 +1,3 @@
+bin/aub
+man/man1/aub.1.gz
+share/doc/aub/BUG_FIXES