aboutsummaryrefslogtreecommitdiff
path: root/news/inn
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-03-30 12:52:38 +0000
committerClement Laforet <clement@FreeBSD.org>2004-03-30 12:52:38 +0000
commitd334590ce1e6fabc09728f2adfa38ee6b1b1fe62 (patch)
tree5f77c549302895c4f9a8cf5158195e9f68c14802 /news/inn
parent4aec323f51cfcf9cde597881da023cec7c792512 (diff)
downloadports-d334590ce1e6fabc09728f2adfa38ee6b1b1fe62.tar.gz
ports-d334590ce1e6fabc09728f2adfa38ee6b1b1fe62.zip
- Preserve config files permissions to reduce inncheck warnings.
Notes
Notes: svn path=/head/; revision=105693
Diffstat (limited to 'news/inn')
-rw-r--r--news/inn/pkg-install2
-rw-r--r--news/inn/pkg-plist52
2 files changed, 27 insertions, 27 deletions
diff --git a/news/inn/pkg-install b/news/inn/pkg-install
index d351162bd33d..f3345e3dccac 100644
--- a/news/inn/pkg-install
+++ b/news/inn/pkg-install
@@ -20,7 +20,7 @@ case $2 in
else
echo "[NO]"
echo " Installing ${f} to ${REALFILE}"
- cp ${f} ${REALFILE}
+ cp -p ${f} ${REALFILE}
fi
done
;;
diff --git a/news/inn/pkg-plist b/news/inn/pkg-plist
index 82b3b95bc39f..38345dc582f3 100644
--- a/news/inn/pkg-plist
+++ b/news/inn/pkg-plist
@@ -128,82 +128,82 @@ news/doc/hook-tcl
news/doc/sample-control
@unexec if cmp -s %D/%%ETCDIR%%/actsync.cfg %D/%%ETCDIR%%/actsync.cfg.dist; then rm -f %D/%%ETCDIR%%/actsync.cfg ; fi
%%ETCDIR%%/actsync.cfg.dist
-@exec [ -f %B/actsync.cfg ] || cp -f %B/%f %B/actsync.cfg
+@exec [ -f %B/actsync.cfg ] || cp -fp %B/%f %B/actsync.cfg
@unexec if cmp -s %D/%%ETCDIR%%/actsync.ign %D/%%ETCDIR%%/actsync.ign.dist; then rm -f %D/%%ETCDIR%%/actsync.ign ; fi
%%ETCDIR%%/actsync.ign.dist
-@exec [ -f %B/actsync.ign ] || cp -f %B/%f %B/actsync.ign
+@exec [ -f %B/actsync.ign ] || cp -fp %B/%f %B/actsync.ign
@unexec if cmp -s %D/%%ETCDIR%%/buffindexed.conf %D/%%ETCDIR%%/buffindexed.conf.dist; then rm -f %D/%%ETCDIR%%/buffindexed.conf ; fi
%%ETCDIR%%/buffindexed.conf.dist
-@exec [ -f %B/buffindexed.conf ] || cp -f %B%/%f %B/buffindexed.conf
+@exec [ -f %B/buffindexed.conf ] || cp -fp %B%/%f %B/buffindexed.conf
@unexec if cmp -s %D/%%ETCDIR%%/control.ctl %D/%%ETCDIR%%/control.ctl.dist; then rm -f %D/%%ETCDIR%%/control.ctl ; fi
%%ETCDIR%%/control.ctl.dist
-@exec [ -f %B/control.ctl ] || cp -f %B/%f %B/control.ctl
+@exec [ -f %B/control.ctl ] || cp -fp %B/%f %B/control.ctl
@unexec if cmp -s %D/%%ETCDIR%%/cycbuff.conf %D/%%ETCDIR%%/cycbuff.conf.dist; then rm -f %D/%%ETCDIR%%/cycbuff.conf ; fi
%%ETCDIR%%/cycbuff.conf.dist
-@exec [ -f %B/cycbuff.conf ] || cp -f %B/%f %B/cycbuff.conf
+@exec [ -f %B/cycbuff.conf ] || cp -fp %B/%f %B/cycbuff.conf
@unexec if cmp -s %D/%%ETCDIR%%/distrib.pats %D/%%ETCDIR%%/distrib.pats.dist; then rm -f %D/%%ETCDIR%%/distrib.pats ; fi
%%ETCDIR%%/distrib.pats.dist
-@exec [ -f %B/distrib.pats ] || cp -f %B/%f %B/distrib.pats
+@exec [ -f %B/distrib.pats ] || cp -fp %B/%f %B/distrib.pats
@unexec if cmp -s %D/%%ETCDIR%%/expire.ctl %D/%%ETCDIR%%/expire.ctl.dist; then rm -f %D/%%ETCDIR%%/expire.ctl ; fi
%%ETCDIR%%/expire.ctl.dist
-@exec [ -f %B/expire.ctl ] || cp -f %B/%f %B/expire.ctl
+@exec [ -f %B/expire.ctl ] || cp -fp %B/%f %B/expire.ctl
@unexec if cmp -s %D/%%ETCDIR%%/incoming.conf %D/%%ETCDIR%%/incoming.conf.dist; then rm -f %D/%%ETCDIR%%/incoming.conf ; fi
%%ETCDIR%%/incoming.conf.dist
-@exec [ -f %B/incoming ] || cp -f %B/%f %B/incoming.conf
+@exec [ -f %B/incoming ] || cp -fp %B/%f %B/incoming.conf
@unexec if cmp -s %D/%%ETCDIR%%/inn.conf %D/%%ETCDIR%%/inn.conf.dist; then rm -f %D/%%ETCDIR%%/inn.conf ; fi
%%ETCDIR%%/inn.conf.dist
-@exec [ -f %B/inn.conf ] || cp -f %B/%f %B/inn.conf
+@exec [ -f %B/inn.conf ] || cp -fp %B/%f %B/inn.conf
@unexec if cmp -s %D/%%ETCDIR%%/innfeed.conf %D/%%ETCDIR%%/innfeed.conf.dist; then rm -f %D/%%ETCDIR%%/innfeed.conf ; fi
%%ETCDIR%%/innfeed.conf.dist
-@exec [ -f %B/innfeed.conf.dist ] || cp -f %B/%f %B/innfeed.conf.dist
+@exec [ -f %B/innfeed.conf.dist ] || cp -fp %B/%f %B/innfeed.conf.dist
@unexec if cmp -s %D/%%ETCDIR%%/innreport.conf %D/%%ETCDIR%%/innreport.conf.dist; then rm -f %D/%%ETCDIR%%/innreport.conf ; fi
%%ETCDIR%%/innreport.conf.dist
-@exec [ -f %B/innreport.conf ] || cp -f %B/%f %B/innreport.conf
+@exec [ -f %B/innreport.conf ] || cp -fp %B/%f %B/innreport.conf
@unexec if cmp -s %D/%%ETCDIR%%/innwatch.ctl %D/%%ETCDIR%%/innwatch.ctl.dist; then rm -f %D/%%ETCDIR%%/innwatch.ctl ; fi
%%ETCDIR%%/innwatch.ctl.dist
-@exec [ -f %B/innwatch.ctl ] || cp -f %B/%f %B/innwatch.ctl
+@exec [ -f %B/innwatch.ctl ] || cp -fp %B/%f %B/innwatch.ctl
@unexec if cmp -s %D/%%ETCDIR%%/moderators %D/%%ETCDIR%%/moderators.dist; then rm -f %D/%%ETCDIR%%/moderators ; fi
%%ETCDIR%%/moderators.dist
-@exec [ -f %B/moderators ] || cp -f %B/%f %B/moderators
+@exec [ -f %B/moderators ] || cp -fp %B/%f %B/moderators
@unexec if cmp -s %D/%%ETCDIR%%/motd.news %D/%%ETCDIR%%/motd.news.dist; then rm -f %D/%%ETCDIR%%/motd.news ; fi
%%ETCDIR%%/motd.news.dist
-@exec [ -f %B/motd.news ] || cp -f %B/%f %B/motd.news
+@exec [ -f %B/motd.news ] || cp -fp %B/%f %B/motd.news
@unexec if cmp -s %D/%%ETCDIR%%/news2mail.cf %D/%%ETCDIR%%/news2mail.cf.dist; then rm -f %D/%%ETCDIR%%/news2mail.cf ; fi
%%ETCDIR%%/news2mail.cf.dist
-@exec [ -f %B/news2mail.cf ] || cp -f %B/%f %B/news2mail.cf
+@exec [ -f %B/news2mail.cf ] || cp -fp %B/%f %B/news2mail.cf
@unexec if cmp -s %D/%%ETCDIR%%/newsfeeds %D/%%ETCDIR%%/newsfeeds.dist; then rm -f %D/%%ETCDIR%%/newsfeeds ; fi
%%ETCDIR%%/newsfeeds.dist
-@exec [ -f %B/newsfeeds ] || cp -f %B/%f %B/newsfeeds
+@exec [ -f %B/newsfeeds ] || cp -fp %B/%f %B/newsfeeds
@unexec if cmp -s %D/%%ETCDIR%%/nnrpd.track %D/%%ETCDIR%%/nnrpd.track.dist; then rm -f %D/%%ETCDIR%%/nnrpd.track ; fi
%%ETCDIR%%/nnrpd.track.dist
-@exec [ -f %B/nnrpd.track ] || cp -f %B/%f %B/nnrpd.track
+@exec [ -f %B/nnrpd.track ] || cp -fp %B/%f %B/nnrpd.track
@unexec if cmp -s %D/%%ETCDIR%%/nntpsend.ctl %D/%%ETCDIR%%/nntpsend.ctl.dist; then rm -f %D/%%ETCDIR%%/nntpsend.ctl ; fi
%%ETCDIR%%/nntpsend.ctl.dist
-@exec [ -f %B/nntpsend.ctl ] || cp -f %B/%f %B/nntpsend.ctl
+@exec [ -f %B/nntpsend.ctl ] || cp -fp %B/%f %B/nntpsend.ctl
@unexec if cmp -s %D/%%ETCDIR%%/ovdb.conf %D/%%ETCDIR%%/ovdb.conf.dist; then rm -f %D/%%ETCDIR%%/ovdb.conf ; fi
%%ETCDIR%%/ovdb.conf.dist
-@exec [ -f %B/ovdb.conf ] || cp -f %B/%f %B/ovdb.conf
+@exec [ -f %B/ovdb.conf ] || cp -fp %B/%f %B/ovdb.conf
@unexec if cmp -s %D/%%ETCDIR%%/overview.fmt %D/%%ETCDIR%%/overview.fmt.dist; then rm -f %D/%%ETCDIR%%/overview.fmt ; fi
%%ETCDIR%%/overview.fmt.dist
-@exec [ -f %B/overview.fmt ] || cp -f %B/%f %B/overview.fmt
+@exec [ -f %B/overview.fmt ] || cp -fp %B/%f %B/overview.fmt
@unexec if cmp -s %D/%%ETCDIR%%/passwd.nntp %D/%%ETCDIR%%/passwd.nntp.dist; then rm -f %D/%%ETCDIR%%/passwd.nntp ; fi
%%ETCDIR%%/passwd.nntp.dist
-@exec [ -f %B/passwd.nntp ] || cp -f %B/%f %B/passwd.nntp
+@exec [ -f %B/passwd.nntp ] || cp -fp %B/%f %B/passwd.nntp
@unexec if cmp -s %D/%%ETCDIR%%/radius.conf %D/%%ETCDIR%%/radius.conf.dist; then rm -f %D/%%ETCDIR%%/radius.conf ; fi
%%ETCDIR%%/radius.conf.dist
-@exec [ -f %B/radius.conf ] || cp -f %B/%f %B/radius.conf
+@exec [ -f %B/radius.conf ] || cp -fp %B/%f %B/radius.conf
@unexec if cmp -s %D/%%ETCDIR%%/readers.conf %D/%%ETCDIR%%/readers.conf.dist; then rm -f %D/%%ETCDIR%%/readers.conf; fi
%%ETCDIR%%/readers.conf.dist
-@exec [ -f %B/readers.conf ] || cp -f %B/%f %B/readers.conf
+@exec [ -f %B/readers.conf ] || cp -fp %B/%f %B/readers.conf
@unexec if cmp -s %D/%%ETCDIR%%/sasl.conf %D/%%ETCDIR%%/sasl.conf.dist; then rm -f %D/%%ETCDIR%%/sasl.conf ; fi
%%ETCDIR%%/sasl.conf.dist
-@exec [ -f %B/sasl.conf ] || cp -f %B/%f %B/sasl.conf
+@exec [ -f %B/sasl.conf ] || cp -fp %B/%f %B/sasl.conf
@unexec if cmp -s %D/%%ETCDIR%%/storage.conf %D/%%ETCDIR%%/storage.conf.dist; then rm -f %D/%%ETCDIR%%/storage.conf ; fi
%%ETCDIR%%/storage.conf.dist
-@exec [ -f %B/storage.conf ] || cp -f %B/%f %B/storage.conf
+@exec [ -f %B/storage.conf ] || cp -fp %B/%f %B/storage.conf
@unexec if cmp -s %D/%%ETCDIR%%/subscriptions %D/%%ETCDIR%%/subscriptions.dist; then rm -f %D/%%ETCDIR%%/subscriptions ; fi
%%ETCDIR%%/subscriptions.dist
-@exec [ -f %B/subscriptions ] || cp -f %B/%f %B/subscriptions
+@exec [ -f %B/subscriptions ] || cp -fp %B/%f %B/subscriptions
news/include/clibrary.h
news/include/conffile.h
news/include/config.h