aboutsummaryrefslogtreecommitdiff
path: root/news/nn
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-06-19 06:54:39 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-06-19 06:54:39 +0000
commit5c10f3b56c364da216512a53bbd5ecfbd4f1b487 (patch)
tree96f3a5c7ab95912dddac59314840796377728d5d /news/nn
parenta5120cef6b8aaa8ad9675abc814398a26bad34d8 (diff)
downloadports-5c10f3b56c364da216512a53bbd5ecfbd4f1b487.tar.gz
ports-5c10f3b56c364da216512a53bbd5ecfbd4f1b487.zip
Create ${PREFIX}/news first as the mkdir's in the source's Makefile
don't have the -p flag. While I'm here, replace stuff with macros (${PREFIX}, ${ECHO}, etc.).
Notes
Notes: svn path=/head/; revision=7006
Diffstat (limited to 'news/nn')
-rw-r--r--news/nn/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/news/nn/Makefile b/news/nn/Makefile
index 01f2ef3003a9..5e43f3bdb907 100644
--- a/news/nn/Makefile
+++ b/news/nn/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 September 1994
# Whom: adam
#
-# $Id: Makefile,v 1.11 1996/12/07 00:01:26 ache Exp $
+# $Id: Makefile,v 1.12 1997/04/12 09:54:00 ache Exp $
#
DISTNAME= nn-6.5.0.b3
@@ -17,16 +17,17 @@ MAN1= nn.1 nncheck.1 nngoback.1 nngrab.1 nngrep.1 nnpost.1 \
MAN8= nnmaster.8 nnspew.8
pre-patch:
- @cp ${WRKSRC}/config.h-dist ${WRKSRC}/config.h
+ @${CP} ${WRKSRC}/config.h-dist ${WRKSRC}/config.h
pre-build:
- @cp ${.CURDIR}/files/s-freebsd.h ${WRKSRC}/conf
+ @${CP} ${FILESDIR}/s-freebsd.h ${WRKSRC}/conf
pre-install:
- [ -r /usr/local/news/lib/inews ] || ( cd ${WRKSRC}/inews; ${MAKE} all )
- [ -r /usr/local/news/lib/inews ] || ( cd ${WRKSRC}/inews; ${MAKE} install )
+ ${MKDIR} ${PREFIX}/news
+ [ -r ${PREFIX}/news/lib/inews ] || ( cd ${WRKSRC}/inews; ${MAKE} all )
+ [ -r ${PREFIX}/news/lib/inews ] || ( cd ${WRKSRC}/inews; ${MAKE} install )
post-install:
- @echo Put your NNTP host into ${PREFIX}/etc/nntpserver file
+ @${ECHO} Put your NNTP host into ${PREFIX}/etc/nntpserver file
.include <bsd.port.mk>