aboutsummaryrefslogtreecommitdiff
path: root/news/nn
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>2002-06-10 15:18:06 +0000
committerJacques Vidrine <nectar@FreeBSD.org>2002-06-10 15:18:06 +0000
commitbf87843cd9795bfd519304ed34b73fbcf7461614 (patch)
tree10cfc447e547d1e3794cd39f99ef24ec90549e10 /news/nn
parent56a60773a61cfc0b9a2717e1856032d62a47c6e1 (diff)
downloadports-bf87843cd9795bfd519304ed34b73fbcf7461614.tar.gz
ports-bf87843cd9795bfd519304ed34b73fbcf7461614.zip
Fix remotely exploitable format string vulnerability.
Notes
Notes: svn path=/head/; revision=61055
Diffstat (limited to 'news/nn')
-rw-r--r--news/nn/Makefile4
-rw-r--r--news/nn/files/patch-an11
2 files changed, 11 insertions, 4 deletions
diff --git a/news/nn/Makefile b/news/nn/Makefile
index cb6626e613f5..73cd398e7986 100644
--- a/news/nn/Makefile
+++ b/news/nn/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= nn
-PORTVERSION= 6.6.2
+PORTVERSION= 6.6.2_1
CATEGORIES= news
MASTER_SITES= ftp://ftp.nndev.org/pub/nn-6.6/
EXTRACT_SUFX= .tar.Z
MAINTAINER= jooji@nickelkid.com
-FORBIDDEN= "Remotely exploitable format string vulnerability."
-
MAN1= nn.1 nncheck.1 nngoback.1 nngrab.1 nngrep.1 nnpost.1 \
nntidy.1 nnview.1 nnacct.1m nnadmin.1m nnstats.1m nnusage.1m
MAN8= nnmaster.8 nnspew.8
diff --git a/news/nn/files/patch-an b/news/nn/files/patch-an
index 409d93cf7816..ebb161199ffa 100644
--- a/news/nn/files/patch-an
+++ b/news/nn/files/patch-an
@@ -1,5 +1,5 @@
--- nntp.c.orig Tue Oct 9 11:39:11 2001
-+++ nntp.c Fri Dec 7 07:10:29 2001
++++ nntp.c Mon Jun 10 10:15:02 2002
@@ -37,6 +37,7 @@
#include <errno.h>
#include <pwd.h>
@@ -66,6 +66,15 @@
* get_server_line: get a line from the server.
*
* Expects to be connected to the server.
+@@ -634,7 +679,7 @@
+ can_post = 0;
+ break;
+ default:
+- nn_exitmsg(1, line);
++ nn_exitmsg(1, "%s", line);
+ /* NOTREACHED */
+ }
+ }
@@ -1726,7 +1771,7 @@
* Phil Lapsley <phil@ucbvax.berkeley.edu>
*/