aboutsummaryrefslogtreecommitdiff
path: root/news/pan2/Makefile
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>1999-08-30 05:47:33 +0000
committerJim Mock <jim@FreeBSD.org>1999-08-30 05:47:33 +0000
commita4fccee966a71bd9bb41ecc59d46567fea7819b9 (patch)
tree752c675a5af70a7ae728c54f668ddb0d41cd61a1 /news/pan2/Makefile
parentd5c33331d604e77618741593ce518be993b29b89 (diff)
downloadports-a4fccee966a71bd9bb41ecc59d46567fea7819b9.tar.gz
ports-a4fccee966a71bd9bb41ecc59d46567fea7819b9.zip
Import of pan.
Pan is a threaded GNOME news reader based on Agent for Windows systems. PR: 13019 Submitted by: Chris D. Faulhaber <jedgar@fxp.org>
Notes
Notes: svn path=/head/; revision=21108
Diffstat (limited to 'news/pan2/Makefile')
-rw-r--r--news/pan2/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/news/pan2/Makefile b/news/pan2/Makefile
new file mode 100644
index 000000000000..672a88b8dd97
--- /dev/null
+++ b/news/pan2/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: pan
+# Version required: 0.4.3
+# Date created: 07 August 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= pan-0.4.3
+CATEGORIES= news gnome
+MASTER_SITES= ftp://source.rebelbase.com/pub/pan/
+
+MAINTAINER= jedgar@fxp.org
+
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm \
+ gnome.2:${PORTSDIR}/x11/gnomelibs
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-x
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 300000
+pre-fetch:
+ @${ECHO}
+ @${ECHO} "Must have FreeBSD-3.0 or greater due to"
+ @${ECHO} "the use of the thread library."
+ @${ECHO}
+.endif
+
+.include <bsd.port.mk>