aboutsummaryrefslogtreecommitdiff
path: root/news/tin
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-03-11 05:55:42 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-03-11 05:55:42 +0000
commit5dee439748f2e4188308acd5273d9f1949e40f33 (patch)
treed7b268b3953a9bb784892209d6c5fd5610a18028 /news/tin
parent979f3c18a95665db2668831eb146823d323463e5 (diff)
downloadports-5dee439748f2e4188308acd5273d9f1949e40f33.tar.gz
ports-5dee439748f2e4188308acd5273d9f1949e40f33.zip
Fix wrong configuration detection due to missing include
Notes
Notes: svn path=/head/; revision=39549
Diffstat (limited to 'news/tin')
-rw-r--r--news/tin/Makefile10
-rw-r--r--news/tin/files/pcre.h107
2 files changed, 114 insertions, 3 deletions
diff --git a/news/tin/Makefile b/news/tin/Makefile
index 63799702c811..c8285fcef79d 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -6,13 +6,14 @@
#
PORTNAME= tin
-PORTVERSION= 1.5.6
+PORTVERSION= 1.5.6
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/v1.5/ \
ftp://nuxi.ucdavis.edu/pub/tin/v1.5/ \
ftp://ftp.nuxi.com/pub/tin/v1.5/
-MAINTAINER= ache@FreeBSD.org
+MAINTAINER?= ache@FreeBSD.org
LIB_DEPENDS= uu.1:${PORTSDIR}/converters/uulib \
intl.1:${PORTSDIR}/devel/gettext
@@ -35,7 +36,7 @@ CONFIGURE_ARGS= --with-nntp-default-server=news \
--with-pgp=${PREFIX}/bin/pgp \
--with-ispell=${PREFIX}/bin/ispell \
--with-metamail=${PREFIX}/bin/metamail
-CONFIGURE_ENV= CFLAGS='${CFLAGS} -DNNTP_SERVER_FILE="\"${PREFIX}/etc/nntpserver\""' \
+CONFIGURE_ENV= CFLAGS='${CFLAGS} -DNNTP_SERVER_FILE="\"${PREFIX}/etc/nntpserver\""' \
CPPFLAGS='${CPPFLAGS} -I${LOCALBASE}/include' \
LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib'
MAKEFILE= makefile
@@ -53,6 +54,9 @@ post-patch:
-e 's:/usr/lib/news:${PREFIX}/news/lib:' \
<${WRKSRC}/doc/tin.1.dist >${WRKSRC}/doc/tin.1
+pre-configure:
+ ${CP} ${FILESDIR}/pcre.h ${WRKSRC}/pcre
+
post-install:
cd ${WRKSRC}/doc; ${INSTALL_DATA} tin.defaults ${PREFIX}/etc/tin.defaults.dist
if [ ! -f ${PREFIX}/etc/tin.defaults ] ; then \
diff --git a/news/tin/files/pcre.h b/news/tin/files/pcre.h
new file mode 100644
index 000000000000..82e696e0a676
--- /dev/null
+++ b/news/tin/files/pcre.h
@@ -0,0 +1,107 @@
+/*************************************************
+* Perl-Compatible Regular Expressions *
+*************************************************/
+
+/* Copyright (c) 1997-2000 University of Cambridge */
+
+#ifndef _PCRE_H
+#define _PCRE_H
+
+/* The file pcre.h is build by "configure". Do not edit it; instead
+make changes to pcre.in. */
+
+#define PCRE_MAJOR 3
+#define PCRE_MINOR 2
+#define PCRE_DATE 12-May-2000
+
+/* Win32 uses DLL by default */
+
+#ifdef _WIN32
+# ifdef STATIC
+# define PCRE_DL_IMPORT
+# else
+# define PCRE_DL_IMPORT __declspec(dllimport)
+# endif
+#else
+# define PCRE_DL_IMPORT
+#endif
+
+/* Have to include stdlib.h in order to ensure that size_t is defined;
+it is needed here for malloc. */
+
+#include <stdlib.h>
+
+/* Allow for C++ users */
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+/* Options */
+
+#define PCRE_CASELESS 0x0001
+#define PCRE_MULTILINE 0x0002
+#define PCRE_DOTALL 0x0004
+#define PCRE_EXTENDED 0x0008
+#define PCRE_ANCHORED 0x0010
+#define PCRE_DOLLAR_ENDONLY 0x0020
+#define PCRE_EXTRA 0x0040
+#define PCRE_NOTBOL 0x0080
+#define PCRE_NOTEOL 0x0100
+#define PCRE_UNGREEDY 0x0200
+#define PCRE_NOTEMPTY 0x0400
+
+/* Exec-time and get-time error codes */
+
+#define PCRE_ERROR_NOMATCH (-1)
+#define PCRE_ERROR_NULL (-2)
+#define PCRE_ERROR_BADOPTION (-3)
+#define PCRE_ERROR_BADMAGIC (-4)
+#define PCRE_ERROR_UNKNOWN_NODE (-5)
+#define PCRE_ERROR_NOMEMORY (-6)
+#define PCRE_ERROR_NOSUBSTRING (-7)
+
+/* Request types for pcre_fullinfo() */
+
+#define PCRE_INFO_OPTIONS 0
+#define PCRE_INFO_SIZE 1
+#define PCRE_INFO_CAPTURECOUNT 2
+#define PCRE_INFO_BACKREFMAX 3
+#define PCRE_INFO_FIRSTCHAR 4
+#define PCRE_INFO_FIRSTTABLE 5
+#define PCRE_INFO_LASTLITERAL 6
+
+/* Types */
+
+typedef void pcre;
+typedef void pcre_extra;
+
+/* Store get and free functions. These can be set to alternative malloc/free
+functions if required. Some magic is required for Win32 DLL; it is null on
+other OS. */
+
+PCRE_DL_IMPORT extern void *(*pcre_malloc)(size_t);
+PCRE_DL_IMPORT extern void (*pcre_free)(void *);
+
+#undef PCRE_DL_IMPORT
+
+/* Functions */
+
+extern pcre *pcre_compile(const char *, int, const char **, int *,
+ const unsigned char *);
+extern int pcre_copy_substring(const char *, int *, int, int, char *, int);
+extern int pcre_exec(const pcre *, const pcre_extra *, const char *,
+ int, int, int, int *, int);
+extern int pcre_get_substring(const char *, int *, int, int, const char **);
+extern int pcre_get_substring_list(const char *, int *, int, const char ***);
+extern int pcre_info(const pcre *, int *, int *);
+extern int pcre_fullinfo(const pcre *, const pcre_extra *, int, void *);
+extern unsigned const char *pcre_maketables(void);
+extern pcre_extra *pcre_study(const pcre *, int, const char **);
+extern const char *pcre_version(void);
+
+#ifdef __cplusplus
+} /* extern "C" */
+#endif
+
+#endif /* End of pcre.h */