aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-02 09:22:47 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-02 09:22:47 +0000
commitca11b0d6e9a1ec907ecd9af2960fc14b2d50a160 (patch)
tree57ff114ed6c22543eff6f68991fcfc5180976d04 /news
parentbd336fe2d26c73d05170cfe812e747f5cd8b4382 (diff)
downloadports-ca11b0d6e9a1ec907ecd9af2960fc14b2d50a160.tar.gz
ports-ca11b0d6e9a1ec907ecd9af2960fc14b2d50a160.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
Notes
Notes: svn path=/head/; revision=325955
Diffstat (limited to 'news')
-rw-r--r--news/c-nocem/Makefile2
-rw-r--r--news/cleanfeed/Makefile2
-rw-r--r--news/fidogate-ds/Makefile2
-rw-r--r--news/husky-hpt-devel/Makefile2
-rw-r--r--news/husky-hpt/Makefile2
-rw-r--r--news/newsgrab/Makefile2
-rw-r--r--news/p5-NNML/Makefile3
-rw-r--r--news/p5-NNTPClient/Makefile3
-rw-r--r--news/p5-News-Article-NoCeM/Makefile3
-rw-r--r--news/slrnconf/Makefile2
-rw-r--r--news/ubh/Makefile2
11 files changed, 14 insertions, 11 deletions
diff --git a/news/c-nocem/Makefile b/news/c-nocem/Makefile
index 74e2de54b904..a812041b30bb 100644
--- a/news/c-nocem/Makefile
+++ b/news/c-nocem/Makefile
@@ -22,7 +22,7 @@ CNEWS_PORT?= news/cnews
CNEWSWRK?= ${WRKDIRPREFIX}${.CURDIR}/../../${CNEWS_PORT}/work
NEWSBIN?= ${PREFIX}/libexec/cnews
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-cnews=${CNEWSWRK}
PLIST_SUB+= NEWSBIN=${NEWSBIN:S=${PREFIX}/==}
diff --git a/news/cleanfeed/Makefile b/news/cleanfeed/Makefile
index cfc092feb466..f83962c2d43e 100644
--- a/news/cleanfeed/Makefile
+++ b/news/cleanfeed/Makefile
@@ -16,7 +16,7 @@ COMMENT= Spam filter for Usenet news servers
RUN_DEPENDS= ${LOCALBASE}/news/bin/innd:${PORTSDIR}/news/inn
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
BINOWN= news
BINGRP= news
SHAREOWN= news
diff --git a/news/fidogate-ds/Makefile b/news/fidogate-ds/Makefile
index 9fb772c3fe1e..1ca6b3d2abb6 100644
--- a/news/fidogate-ds/Makefile
+++ b/news/fidogate-ds/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${LOCALBASE}/news/bin/innconfval:${PORTSDIR}/news/inn
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= perl5
MAKE_JOBS_UNSAFE= yes
SPOOLDIR?=/var/spool/fido/gate
diff --git a/news/husky-hpt-devel/Makefile b/news/husky-hpt-devel/Makefile
index 80ec7f0a24b2..28ce59a84fd1 100644
--- a/news/husky-hpt-devel/Makefile
+++ b/news/husky-hpt-devel/Makefile
@@ -15,7 +15,7 @@ CONFLICTS= husky-hpt-[0-9]*
.if !defined(WITHOUT_PERL)
MAKE_ARGS+= PERL=1
-USE_PERL5= yes
+USES= perl5
.else
MAKE_ARGS+= PERL=0
.endif
diff --git a/news/husky-hpt/Makefile b/news/husky-hpt/Makefile
index bb65a47508a8..ffb685181dfc 100644
--- a/news/husky-hpt/Makefile
+++ b/news/husky-hpt/Makefile
@@ -17,7 +17,7 @@ CONFLICTS= husky-hpt-devel-[0-9]*
.if !defined(WITHOUT_PERL)
MAKE_ARGS+= PERL=1
-USE_PERL5= yes
+USES= perl5
.else
MAKE_ARGS+= PERL=0
.endif
diff --git a/news/newsgrab/Makefile b/news/newsgrab/Makefile
index b009931efafc..f5876e95aec5 100644
--- a/news/newsgrab/Makefile
+++ b/news/newsgrab/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= p5-NNTPClient>=0:${PORTSDIR}/news/p5-NNTPClient \
p5-Time-modules>=0:${PORTSDIR}/devel/p5-Time-modules
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
post-patch:
@${REINPLACE_CMD} -e 's|^#!/usr/bin/perl|#!${PERL}|' ${WRKSRC}/newsgrab.pl
diff --git a/news/p5-NNML/Makefile b/news/p5-NNML/Makefile
index e7eab997e564..ebb2b6c97c1d 100644
--- a/news/p5-NNML/Makefile
+++ b/news/p5-NNML/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= A minimal NNTP server
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
RESTRICTED= License unknown
diff --git a/news/p5-NNTPClient/Makefile b/news/p5-NNTPClient/Makefile
index 185d0a53bacd..17f2168b3c0c 100644
--- a/news/p5-NNTPClient/Makefile
+++ b/news/p5-NNTPClient/Makefile
@@ -11,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gary@hayers.org
COMMENT= Client interface to NNTP (RFC977)
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= News::NNTPClient.3
diff --git a/news/p5-News-Article-NoCeM/Makefile b/news/p5-News-Article-NoCeM/Makefile
index 26d56ef7f82c..dbf6ed8d1b2c 100644
--- a/news/p5-News-Article-NoCeM/Makefile
+++ b/news/p5-News-Article-NoCeM/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-News-Article>=0:${PORTSDIR}/news/p5-News-Article \
p5-PGP-Sign>=0:${PORTSDIR}/security/p5-PGP-Sign
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= News::Article::NoCeM.3
diff --git a/news/slrnconf/Makefile b/news/slrnconf/Makefile
index fafa2455d026..118dbeefe2d6 100644
--- a/news/slrnconf/Makefile
+++ b/news/slrnconf/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
USE_BZIP2= yes
-USE_PERL5= yes
+USES= perl5
MAKE_ARGS+= PREFIX=${PREFIX}
do-install:
diff --git a/news/ubh/Makefile b/news/ubh/Makefile
index 704288741358..a6fc9a87e616 100644
--- a/news/ubh/Makefile
+++ b/news/ubh/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= \
p5-String-CRC32>=0:${PORTSDIR}/devel/p5-String-CRC32
NO_BUILD= YES
-USE_PERL5= YES
+USES= perl5
pre-patch:
@${MV} ${WRKSRC}/ubh ${WRKSRC}/ubh.old