aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /news
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'news')
-rw-r--r--news/p5-NNTPClient/Makefile1
-rw-r--r--news/p5-NNTPClient/pkg-plist4
-rw-r--r--news/p5-News-Article-NoCeM/Makefile1
-rw-r--r--news/p5-News-Article-NoCeM/pkg-plist4
-rw-r--r--news/p5-News-Article/Makefile2
-rw-r--r--news/p5-News-Article/pkg-plist4
-rw-r--r--news/p5-News-Newsrc/Makefile1
-rw-r--r--news/p5-News-Newsrc/pkg-plist4
-rw-r--r--news/p5-POE-Component-Client-NNTP/Makefile1
-rw-r--r--news/p5-POE-Component-Client-NNTP/pkg-plist9
-rw-r--r--news/p5-POE-Component-Server-NNTP/Makefile1
-rw-r--r--news/p5-POE-Component-Server-NNTP/pkg-plist9
12 files changed, 6 insertions, 35 deletions
diff --git a/news/p5-NNTPClient/Makefile b/news/p5-NNTPClient/Makefile
index 59b5c66ac9fc..e4a133d320d0 100644
--- a/news/p5-NNTPClient/Makefile
+++ b/news/p5-NNTPClient/Makefile
@@ -3,6 +3,7 @@
PORTNAME= NNTPClient
PORTVERSION= 0.37
+PORTREVISION= 1
CATEGORIES= news perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= News
diff --git a/news/p5-NNTPClient/pkg-plist b/news/p5-NNTPClient/pkg-plist
index 960ab6acb581..8bf85e845c8b 100644
--- a/news/p5-NNTPClient/pkg-plist
+++ b/news/p5-NNTPClient/pkg-plist
@@ -1,6 +1,2 @@
%%SITE_PERL%%/News/NNTPClient.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/News/NNTPClient/.packlist
%%PERL5_MAN3%%/News::NNTPClient.3.gz
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/News/NNTPClient
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/News
-@dirrmtry %%SITE_PERL%%/News
diff --git a/news/p5-News-Article-NoCeM/Makefile b/news/p5-News-Article-NoCeM/Makefile
index 47ef085169fe..6c108c113bcd 100644
--- a/news/p5-News-Article-NoCeM/Makefile
+++ b/news/p5-News-Article-NoCeM/Makefile
@@ -3,6 +3,7 @@
PORTNAME= News-Article-NoCeM
PORTVERSION= 0.08
+PORTREVISION= 1
CATEGORIES= news perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/news/p5-News-Article-NoCeM/pkg-plist b/news/p5-News-Article-NoCeM/pkg-plist
index 4c4b3fe36c1c..43b3a14ae4e1 100644
--- a/news/p5-News-Article-NoCeM/pkg-plist
+++ b/news/p5-News-Article-NoCeM/pkg-plist
@@ -1,6 +1,2 @@
%%SITE_PERL%%/News/Article/NoCeM.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/News/Article/NoCeM/.packlist
%%PERL5_MAN3%%/News::Article::NoCeM.3.gz
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/News/Article/NoCeM
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/News/Article
-@dirrmtry %%SITE_PERL%%/News/Article
diff --git a/news/p5-News-Article/Makefile b/news/p5-News-Article/Makefile
index 0d43053b6c39..1fdf442228c2 100644
--- a/news/p5-News-Article/Makefile
+++ b/news/p5-News-Article/Makefile
@@ -3,7 +3,7 @@
PORTNAME= News-Article
PORTVERSION= 1.27
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= news perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/news/p5-News-Article/pkg-plist b/news/p5-News-Article/pkg-plist
index 450e65aafbc8..3e65da2188d1 100644
--- a/news/p5-News-Article/pkg-plist
+++ b/news/p5-News-Article/pkg-plist
@@ -6,7 +6,3 @@
%%SITE_PERL%%/News/AutoReply.pm
%%SITE_PERL%%/News/FormArticle.pm
%%SITE_PERL%%/News/FormReply.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/News/Article/.packlist
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/News/Article
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/News
-@dirrmtry %%SITE_PERL%%/News
diff --git a/news/p5-News-Newsrc/Makefile b/news/p5-News-Newsrc/Makefile
index c04704a7d024..880e9cf9e6ea 100644
--- a/news/p5-News-Newsrc/Makefile
+++ b/news/p5-News-Newsrc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= News-Newsrc
PORTVERSION= 1.11
+PORTREVISION= 1
CATEGORIES= news perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/news/p5-News-Newsrc/pkg-plist b/news/p5-News-Newsrc/pkg-plist
index 320f8c3cc087..4d82dd5e2c77 100644
--- a/news/p5-News-Newsrc/pkg-plist
+++ b/news/p5-News-Newsrc/pkg-plist
@@ -1,6 +1,2 @@
%%SITE_PERL%%/News/Newsrc.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/News/Newsrc/.packlist
%%PERL5_MAN3%%/News::Newsrc.3.gz
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/News/Newsrc
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/News
-@dirrmtry %%SITE_PERL%%/News
diff --git a/news/p5-POE-Component-Client-NNTP/Makefile b/news/p5-POE-Component-Client-NNTP/Makefile
index 0adb5487569e..b95f1162dccc 100644
--- a/news/p5-POE-Component-Client-NNTP/Makefile
+++ b/news/p5-POE-Component-Client-NNTP/Makefile
@@ -3,6 +3,7 @@
PORTNAME= POE-Component-Client-NNTP
PORTVERSION= 2.22
+PORTREVISION= 1
CATEGORIES= news perl5 devel
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/news/p5-POE-Component-Client-NNTP/pkg-plist b/news/p5-POE-Component-Client-NNTP/pkg-plist
index 6b2712b18bd1..5e58d166af5e 100644
--- a/news/p5-POE-Component-Client-NNTP/pkg-plist
+++ b/news/p5-POE-Component-Client-NNTP/pkg-plist
@@ -1,13 +1,4 @@
%%SITE_PERL%%/POE/Component/Client/NNTP.pm
%%SITE_PERL%%/POE/Component/Client/NNTP/Constants.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/NNTP/.packlist
%%PERL5_MAN3%%/POE::Component::Client::NNTP.3.gz
%%PERL5_MAN3%%/POE::Component::Client::NNTP::Constants.3.gz
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/NNTP
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
-@dirrmtry %%SITE_PERL%%/POE/Component/Client/NNTP
-@dirrmtry %%SITE_PERL%%/POE/Component/Client
-@dirrmtry %%SITE_PERL%%/POE/Component
-@dirrmtry %%SITE_PERL%%/POE
diff --git a/news/p5-POE-Component-Server-NNTP/Makefile b/news/p5-POE-Component-Server-NNTP/Makefile
index bbc5c24e1b93..df1d15812133 100644
--- a/news/p5-POE-Component-Server-NNTP/Makefile
+++ b/news/p5-POE-Component-Server-NNTP/Makefile
@@ -3,6 +3,7 @@
PORTNAME= POE-Component-Server-NNTP
PORTVERSION= 1.04
+PORTREVISION= 1
CATEGORIES= news perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/news/p5-POE-Component-Server-NNTP/pkg-plist b/news/p5-POE-Component-Server-NNTP/pkg-plist
index 0bc44178c55c..e822fa236d69 100644
--- a/news/p5-POE-Component-Server-NNTP/pkg-plist
+++ b/news/p5-POE-Component-Server-NNTP/pkg-plist
@@ -1,13 +1,4 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/NNTP/.packlist
%%SITE_PERL%%/POE/Component/Server/NNTP.pm
%%SITE_PERL%%/POE/Component/Server/NNTP/Constants.pm
%%PERL5_MAN3%%/POE::Component::Server::NNTP.3.gz
%%PERL5_MAN3%%/POE::Component::Server::NNTP::Constants.3.gz
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/NNTP
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
-@dirrm %%SITE_PERL%%/POE/Component/Server/NNTP
-@dirrmtry %%SITE_PERL%%/POE/Component/Server
-@dirrmtry %%SITE_PERL%%/POE/Component
-@dirrmtry %%SITE_PERL%%/POE