aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-07-31 15:19:15 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-07-31 15:19:15 +0000
commit28e4715f45c319ef66b4c52b391877092dfb4363 (patch)
tree2e84e39375d7408a3799fc492d22755ae337249f /news
parent35b13183eeb1f6da51530e67fed08982eeb3073e (diff)
downloadports-28e4715f45c319ef66b4c52b391877092dfb4363.tar.gz
ports-28e4715f45c319ef66b4c52b391877092dfb4363.zip
Fix build with clang and getline(3)
The getline(3) failure was hidden by the fact the port was said to build with gcc from ports which occulted the getline(3) change because it bundles the system headers from when it was built (WTF???) Adding -Wno-return-type to cflags allows to build with clang
Notes
Notes: svn path=/head/; revision=419391
Diffstat (limited to 'news')
-rw-r--r--news/cnews/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index 0b365bdf7e1a..1cd006ccfe82 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cnews
PORTVERSION= cr.g
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= news
MASTER_SITES= ftp://ftp.cs.toronto.edu/pub/c-news/ \
ftp://ftp.funet.fi/pub/unix/news/cnews/ \
@@ -38,7 +38,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
MAKE_JOBS_UNSAFE= yes
USES= tar:Z
-USE_GCC= any
+CFLAGS+= -Wno-return-type
DIST_SUBDIR= ${DISTNAME}
NO_WRKSUBDIR= yes
@@ -94,6 +94,10 @@ pre-patch:
${DISTDIR}/${DIST_SUBDIR}/${PGPVERIFY} \
> ${WRKSRC}/${PGPVERIFY}
+post-patch:
+ @${REINPLACE_CMD} -e 's/getline/get_line/g' ${WRKSRC}/readnews/active.c \
+ ${WRKSRC}/readnews/newsrc.c
+
pre-configure:
.for i in conf/quiz.def conf/substitutions include/config.make
${REINPLACE_CMD} \