aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2003-04-07 15:56:21 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2003-04-07 15:56:21 +0000
commit047e6943fe2d777cc7aca123a4980efa8faf8497 (patch)
tree03b9f727886128cae78be6b34cbbd1c795114c94 /news
parenta14c4892781fae06aa8299e5e12005a7e140f4b0 (diff)
downloadports-047e6943fe2d777cc7aca123a4980efa8faf8497.tar.gz
ports-047e6943fe2d777cc7aca123a4980efa8faf8497.zip
Import straw 0.18.1:
Straw is a desktop news aggregator for the GNOME environment. Its aim is to be a faster, easier and more accessible way to read news and blogs than the traditional browser.
Notes
Notes: svn path=/head/; revision=78524
Diffstat (limited to 'news')
-rw-r--r--news/Makefile1
-rw-r--r--news/straw/Makefile35
-rw-r--r--news/straw/distinfo1
-rw-r--r--news/straw/files/patch-Makefile18
-rw-r--r--news/straw/files/patch-src::straw10
-rw-r--r--news/straw/pkg-descr14
-rw-r--r--news/straw/pkg-plist46
7 files changed, 125 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index e38f631c0e9f..96aec671c4c6 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -64,6 +64,7 @@
SUBDIR += slrn
SUBDIR += slrnface
SUBDIR += slurp
+ SUBDIR += straw
SUBDIR += suck
SUBDIR += suck-cnews
SUBDIR += t-gnus
diff --git a/news/straw/Makefile b/news/straw/Makefile
new file mode 100644
index 000000000000..bc1cc0143e2e
--- /dev/null
+++ b/news/straw/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: straw
+# Date created: 7 Apr 2003
+# Whom: sheldonh@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= straw
+PORTVERSION= 0.18.1
+CATEGORIES= news
+MASTER_SITES= http://savannah.nongnu.org/download/${PORTNAME}/${PORTNAME}.pkg/${PORTVERSION}/
+
+MAINTAINER= sheldonh@FreeBSD.org
+COMMENT= A desktop news aggregator for the GNOME 2 desktop
+
+BUILD_DEPENDS= ${LOCALBASE}/include/pyorbit-2/pyorbit.h:${PORTSDIR}/devel/py-orbit2 \
+ ${LOCALBASE}/bin/pygtk-codegen-2.0:${PORTSDIR}/x11-toolkits/py-gtk2 \
+ ${PYTHON_SITELIBDIR}/mx/DateTime/DateTime.py:${PORTSDIR}/lang/py-mx-base \
+ ${PYTHON_SITELIBDIR}/bsddb3/db.py:${PORTSDIR}/databases/py-bsddb3 \
+ ${PYTHON_SITELIBDIR}/_xmlplus/FtCore.py:${PORTSDIR}/textproc/py-xml \
+ ${PYTHON_SITELIBDIR}/ADNS.py:${PORTSDIR}/net/py-adns \
+ ${PYTHON_SITELIBDIR}/gtk-2.0/gnome/__init__.py:${PORTSDIR}/x11-toolkits/py-gnome2
+
+USE_X_PREFIX= yes
+USE_PYTHON= yes
+USE_REINPLACE= yes
+WITH_DB3= yes
+
+MAKE_ARGS+= PREFIX=${PREFIX}
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|g" \
+ ${WRKSRC}/src/straw
+
+.include <bsd.port.mk>
diff --git a/news/straw/distinfo b/news/straw/distinfo
new file mode 100644
index 000000000000..d8e68664e44f
--- /dev/null
+++ b/news/straw/distinfo
@@ -0,0 +1 @@
+MD5 (straw-0.18.1.tar.gz) = 3594de2ee2887e8f5ce661345c4dad73
diff --git a/news/straw/files/patch-Makefile b/news/straw/files/patch-Makefile
new file mode 100644
index 000000000000..8f1b0d83b3ba
--- /dev/null
+++ b/news/straw/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Mon Apr 7 16:54:49 2003
++++ Makefile Mon Apr 7 16:54:51 2003
+@@ -10,11 +10,11 @@
+ # autodetect GNOME prefix, change this if you want it elsewhere
+ PREFIX ?= `pkg-config libgnome-2.0 --variable=prefix || echo /usr/local`
+
+-LIBDIR = $(PREFIX)/lib/python2.2/site-packages/straw
++LIBDIR = $(PREFIX)/lib/straw
+ BINDIR = $(PREFIX)/bin
+-DATADIR = $(PREFIX)/share/straw
+-APPLICATIONSDIR = $(PREFIX)/share/applications
+-ICONDIR = $(PREFIX)/share/pixmaps
++DATADIR = $(LIBDIR)
++APPLICATIONSDIR = $(PREFIX)/share/gnome/applications
++ICONDIR = $(PREFIX)/share/gnome/pixmaps
+ LOCALEDIR = $(PREFIX)/share/locale
+
+ POFILES := $(shell echo po/*.po)
diff --git a/news/straw/files/patch-src::straw b/news/straw/files/patch-src::straw
new file mode 100644
index 000000000000..4e98d5b76ff3
--- /dev/null
+++ b/news/straw/files/patch-src::straw
@@ -0,0 +1,10 @@
+--- src/straw.orig Mon Apr 7 17:06:28 2003
++++ src/straw Mon Apr 7 17:07:14 2003
+@@ -26,6 +26,7 @@
+ raise "FileNotFoundError", "couldn't find straw library dir"
+
+ sys.path.insert(0, find_straw_lib())
++sys.path.insert(0, '%%PYTHON_SITELIBDIR%%')
+
+ import straw
+
diff --git a/news/straw/pkg-descr b/news/straw/pkg-descr
new file mode 100644
index 000000000000..55cfa4f6f1c3
--- /dev/null
+++ b/news/straw/pkg-descr
@@ -0,0 +1,14 @@
+Straw is a desktop news aggregator for the GNOME environment. Its aim is
+to be a faster, easier and more accessible way to read news and blogs
+than the traditional browser.
+
+News aggregators read news, weblog or other feeds over the web and
+aggregate them so the news items are readable from a single place,
+regardless of their source. The data format aggregators utilize
+to do their job is called RSS, standing either for Really Simple
+Syndication or RDF Site Summary, depending on who you ask. At the
+moment, there are two different, incompatible specifications, with
+different objectives: RSS 0.9x/RSS 2.0 and RSS 1.0. Straw supports both
+of them.
+
+WWW: http://www.nongnu.org/straw/
diff --git a/news/straw/pkg-plist b/news/straw/pkg-plist
new file mode 100644
index 000000000000..46600061f733
--- /dev/null
+++ b/news/straw/pkg-plist
@@ -0,0 +1,46 @@
+bin/straw
+lib/straw/Config.pyc
+lib/straw/Event.pyc
+lib/straw/ExportSubscriptionsDialog.pyc
+lib/straw/Feed.pyc
+lib/straw/FeedList.pyc
+lib/straw/FindDialog.pyc
+lib/straw/ImageCache.pyc
+lib/straw/ImportSubscriptionsDialog.pyc
+lib/straw/ItemStore.pyc
+lib/straw/LookupManager.pyc
+lib/straw/Main.pyc
+lib/straw/MainWindow.pyc
+lib/straw/NetworkConstants.pyc
+lib/straw/OPML.pyc
+lib/straw/OPMLExport.pyc
+lib/straw/OPMLImport.pyc
+lib/straw/ParsedSummary.pyc
+lib/straw/PollManager.pyc
+lib/straw/PreferencesDialog.pyc
+lib/straw/QueueDict.pyc
+lib/straw/StrawURLOpener.pyc
+lib/straw/SubscribeDialog.pyc
+lib/straw/SubscriptionsMergeDialog.pyc
+lib/straw/SummaryItem.pyc
+lib/straw/SummaryParser.pyc
+lib/straw/SummaryParserCommon.pyc
+lib/straw/SummaryParserMP.pyc
+lib/straw/URLFetch.pyc
+lib/straw/__init__.pyc
+lib/straw/default_subscriptions.opml
+lib/straw/error.pyc
+lib/straw/face-happy.png
+lib/straw/face-sad.png
+lib/straw/httplib_async.pyc
+lib/straw/image-broken.png
+lib/straw/image-waiting.png
+lib/straw/offline.png
+lib/straw/online.png
+lib/straw/rssfinder.pyc
+lib/straw/rssparser.pyc
+lib/straw/straw.glade
+lib/straw/straw.png
+share/gnome/applications/straw.desktop
+share/gnome/pixmaps/straw.png
+@dirrm share/straw