aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-12-25 12:21:17 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-12-25 12:21:17 +0000
commit8624262e8d5b841cda9743c8244bdc06becd21ab (patch)
tree822dba466ab577b5bf97ceaa7eb7c6697409371a /news
parentadd5fa1d464add5e9337ce60287ee20899db6d01 (diff)
downloadports-8624262e8d5b841cda9743c8244bdc06becd21ab.tar.gz
ports-8624262e8d5b841cda9743c8244bdc06becd21ab.zip
o fix build: catch false condition.
o portlint. PR: 33167(build error)
Notes
Notes: svn path=/head/; revision=52155
Diffstat (limited to 'news')
-rw-r--r--news/tin/Makefile12
-rw-r--r--news/tin/pkg-plist1
2 files changed, 7 insertions, 6 deletions
diff --git a/news/tin/Makefile b/news/tin/Makefile
index eb440916e408..9f104a9dfc0d 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -58,13 +58,15 @@ pre-configure:
${CP} ${FILESDIR}/pcre.h ${WRKSRC}/pcre
post-configure:
- (nm /usr/lib/libc.a | grep -q strcasestr) && \
- echo "#define HAVE_STRCASESTR 1" >> ${WRKSRC}/include/autoconf.h
- echo "#define HAVE_ICONV_H 1" >> ${WRKSRC}/include/autoconf.h
- echo "#define HAVE_ICONV 1" >> ${WRKSRC}/include/autoconf.h
+ if nm /usr/lib/libc.a | ${GREP} -q strcasestr; then \
+ ${ECHO} "#define HAVE_STRCASESTR 1" \
+ >> ${WRKSRC}/include/autoconf.h; \
+ fi
+ ${ECHO} "#define HAVE_ICONV_H 1" >> ${WRKSRC}/include/autoconf.h
+ ${ECHO} "#define HAVE_ICONV 1" >> ${WRKSRC}/include/autoconf.h
post-build:
- cd ${WRKSRC}/po; gmake
+ cd ${WRKSRC}/po; ${GMAKE}
post-install:
cd ${WRKSRC}/doc; ${INSTALL_DATA} tin.defaults ${PREFIX}/etc/tin.defaults.dist
diff --git a/news/tin/pkg-plist b/news/tin/pkg-plist
index 72ad1e19373b..00a5c2ede1fe 100644
--- a/news/tin/pkg-plist
+++ b/news/tin/pkg-plist
@@ -10,4 +10,3 @@ etc/tin.mime.types.dist
share/locale/de/LC_MESSAGES/tin.mo
share/locale/en_GB/LC_MESSAGES/tin.mo
share/locale/et/LC_MESSAGES/tin.mo
-