aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-29 11:48:57 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-29 11:48:57 +0000
commit897d06aa9731645e0a7fa7c315028dcdbfa3c798 (patch)
tree485cefa9621a788f5d27ac4dcab7fc6aa9843be6 /news
parentc982f5faf1c27ba011ef14e71aadc2182660d704 (diff)
downloadports-897d06aa9731645e0a7fa7c315028dcdbfa3c798.tar.gz
ports-897d06aa9731645e0a7fa7c315028dcdbfa3c798.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Notes
Notes: svn path=/head/; revision=53958
Diffstat (limited to 'news')
-rw-r--r--news/newsfetch/Makefile6
-rw-r--r--news/t-gnus-emacs20/Makefile2
-rw-r--r--news/t-gnus/Makefile2
-rw-r--r--news/tin/Makefile6
4 files changed, 8 insertions, 8 deletions
diff --git a/news/newsfetch/Makefile b/news/newsfetch/Makefile
index 5171279c821d..d201bbca1e8a 100644
--- a/news/newsfetch/Makefile
+++ b/news/newsfetch/Makefile
@@ -20,9 +20,9 @@ MANCOMPRESSED= maybe
do-configure:
cd ${WRKSRC} && ( \
- ${ECHO} "PROG= newsfetch"; \
- ${ECHO} "SRCS=" *.c; \
- ${ECHO} ".include <bsd.prog.mk>"; \
+ ${ECHO_CMD} "PROG= newsfetch"; \
+ ${ECHO_CMD} "SRCS=" *.c; \
+ ${ECHO_CMD} ".include <bsd.prog.mk>"; \
) > Makefile
.include <bsd.port.mk>
diff --git a/news/t-gnus-emacs20/Makefile b/news/t-gnus-emacs20/Makefile
index e3c5f8e174b8..9b2f1e80bd74 100644
--- a/news/t-gnus-emacs20/Makefile
+++ b/news/t-gnus-emacs20/Makefile
@@ -79,7 +79,7 @@ PLIST= ${PKGDIR}/pkg-plist.${EMACS_PORT_NAME}
.if (${EMACS_PORT_NAME} == "mule")
post-extract:
- ${ECHO} "${EMACS_CMD} -l apel-setupel.el \$$@" > ${WRKDIR}/mule-apel
+ ${ECHO_CMD} "${EMACS_CMD} -l apel-setupel.el \$$@" > ${WRKDIR}/mule-apel
${CHMOD} +x ${WRKDIR}/mule-apel
.endif
diff --git a/news/t-gnus/Makefile b/news/t-gnus/Makefile
index e3c5f8e174b8..9b2f1e80bd74 100644
--- a/news/t-gnus/Makefile
+++ b/news/t-gnus/Makefile
@@ -79,7 +79,7 @@ PLIST= ${PKGDIR}/pkg-plist.${EMACS_PORT_NAME}
.if (${EMACS_PORT_NAME} == "mule")
post-extract:
- ${ECHO} "${EMACS_CMD} -l apel-setupel.el \$$@" > ${WRKDIR}/mule-apel
+ ${ECHO_CMD} "${EMACS_CMD} -l apel-setupel.el \$$@" > ${WRKDIR}/mule-apel
${CHMOD} +x ${WRKDIR}/mule-apel
.endif
diff --git a/news/tin/Makefile b/news/tin/Makefile
index 9f104a9dfc0d..477d07eba199 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -59,11 +59,11 @@ pre-configure:
post-configure:
if nm /usr/lib/libc.a | ${GREP} -q strcasestr; then \
- ${ECHO} "#define HAVE_STRCASESTR 1" \
+ ${ECHO_CMD} "#define HAVE_STRCASESTR 1" \
>> ${WRKSRC}/include/autoconf.h; \
fi
- ${ECHO} "#define HAVE_ICONV_H 1" >> ${WRKSRC}/include/autoconf.h
- ${ECHO} "#define HAVE_ICONV 1" >> ${WRKSRC}/include/autoconf.h
+ ${ECHO_CMD} "#define HAVE_ICONV_H 1" >> ${WRKSRC}/include/autoconf.h
+ ${ECHO_CMD} "#define HAVE_ICONV 1" >> ${WRKSRC}/include/autoconf.h
post-build:
cd ${WRKSRC}/po; ${GMAKE}