aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-01-11 12:14:54 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-01-11 12:14:54 +0000
commitc2f735f15b3d157650e68df3f56d2676f3928021 (patch)
treec36a68c0751f15b948ff379a62d2b2aaf5c9d570 /news
parentc0f1f9895859e3350f2093a1c1b0fe3f65c3f10a (diff)
downloadports-c2f735f15b3d157650e68df3f56d2676f3928021.tar.gz
ports-c2f735f15b3d157650e68df3f56d2676f3928021.zip
correctly specify path to fidoconfig configuration file in man pages
Notes
Notes: svn path=/head/; revision=72897
Diffstat (limited to 'news')
-rw-r--r--news/husky-fidoconf/Makefile8
-rw-r--r--news/husky-fidoconf/files/patch-man::linkedto.111
-rw-r--r--news/husky-hpt/Makefile10
-rw-r--r--news/husky-htick-devel/Makefile6
-rw-r--r--news/husky-htick/Makefile6
-rw-r--r--news/husky-sqpack/Makefile6
6 files changed, 47 insertions, 0 deletions
diff --git a/news/husky-fidoconf/Makefile b/news/husky-fidoconf/Makefile
index 0fd155dd9dea..634baa39d2c5 100644
--- a/news/husky-fidoconf/Makefile
+++ b/news/husky-fidoconf/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= smapi.2:${PORTSDIR}/news/husky-smapi
INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
INSTALL_TARGET= install install-man
+USE_REINPLACE= yes
MAN1= dumpfcfg.1 fconf2.1 linkedto.1 tparser.1
MLINKS= fconf2.1 fconf2aquaed.1 \
@@ -27,6 +28,13 @@ MLINKS= fconf2.1 fconf2aquaed.1 \
fconf2.1 fconf2msged.1 \
fconf2.1 fconf2squish.1
+post-patch:
+ @${REINPLACE_CMD} -e 's^/fido/etc/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/dumpfcfg.1
+ @${REINPLACE_CMD} -e 's^/etc/fido/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/fconf2.1 \
+ ${WRKSRC}/man/tparser.1
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/news/husky-base/Makefile.inc"
.include <bsd.port.post.mk>
diff --git a/news/husky-fidoconf/files/patch-man::linkedto.1 b/news/husky-fidoconf/files/patch-man::linkedto.1
new file mode 100644
index 000000000000..6889e664cc9d
--- /dev/null
+++ b/news/husky-fidoconf/files/patch-man::linkedto.1
@@ -0,0 +1,11 @@
+--- man/linkedto.1.orig Sat Jan 11 17:52:57 2003
++++ man/linkedto.1 Sat Jan 11 17:53:14 2003
+@@ -19,8 +19,6 @@
+ .br
+ .nf
+ .\" set tabstop to longest possible filename, plus a wee bit
+-.ta \w'/etc/fido/config 'u
+-\fI/etc/fido/config\fR
+ .ta \w'/usr/local/etc/fido/config 'u
+ \fI/usr/local/etc/fido/config\fR Default Fidoconfig.
+ .SH NOTES
diff --git a/news/husky-hpt/Makefile b/news/husky-hpt/Makefile
index 430008b4881a..0149998c7fca 100644
--- a/news/husky-hpt/Makefile
+++ b/news/husky-hpt/Makefile
@@ -15,9 +15,19 @@ MAINTAINER= fjoe@FreeBSD.org
LIB_DEPENDS= fidoconfig.0:${PORTSDIR}/news/husky-fidoconf
+USE_REINPLACE= yes
+
MAN1= hpt.1 hptlink.1 hpttree.1 txt2pkt.1
MANCOMPRESSED= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's^/path/to/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/hptlink.1
+ @${REINPLACE_CMD} -e 's^/some/path/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/hpttree.1
+ @${REINPLACE_CMD} -e 's^/fido/etc/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/txt2pkt.1
+
post-build:
@cd ${WRKSRC}/doc && ${GMAKE}
diff --git a/news/husky-htick-devel/Makefile b/news/husky-htick-devel/Makefile
index 265a504bd8f2..5e1380822461 100644
--- a/news/husky-htick-devel/Makefile
+++ b/news/husky-htick-devel/Makefile
@@ -15,8 +15,14 @@ MAINTAINER= fjoe@FreeBSD.org
LIB_DEPENDS= fidoconfig.0:${PORTSDIR}/news/husky-fidoconf
+USE_REINPLACE= yes
+
MAN1= htick.1
+post-patch:
+ @${REINPLACE_CMD} -e 's^/fido/etc/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/htick.1
+
post-build:
@cd ${WRKSRC}/doc && ${GMAKE}
diff --git a/news/husky-htick/Makefile b/news/husky-htick/Makefile
index 265a504bd8f2..5e1380822461 100644
--- a/news/husky-htick/Makefile
+++ b/news/husky-htick/Makefile
@@ -15,8 +15,14 @@ MAINTAINER= fjoe@FreeBSD.org
LIB_DEPENDS= fidoconfig.0:${PORTSDIR}/news/husky-fidoconf
+USE_REINPLACE= yes
+
MAN1= htick.1
+post-patch:
+ @${REINPLACE_CMD} -e 's^/fido/etc/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/htick.1
+
post-build:
@cd ${WRKSRC}/doc && ${GMAKE}
diff --git a/news/husky-sqpack/Makefile b/news/husky-sqpack/Makefile
index b50530e971fc..0940767fec8f 100644
--- a/news/husky-sqpack/Makefile
+++ b/news/husky-sqpack/Makefile
@@ -15,9 +15,15 @@ MAINTAINER= fjoe@FreeBSD.org
LIB_DEPENDS= fidoconfig.0:${PORTSDIR}/news/husky-fidoconf
+USE_REINPLACE= yes
+
MAN1= sqpack.1
MANCOMPRESSED= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's^/etc/fido/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/sqpack.1
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/news/husky-base/Makefile.inc"
.include <bsd.port.post.mk>