aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-02-12 23:08:49 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-02-12 23:08:49 +0000
commit893fb68316815cc264847ed0f48bb23468f76236 (patch)
tree95876214da099d29222709403e6b195ea7454662 /news
parent22741ef2ea47afab0f8ab4d57ce8e2c139f30a32 (diff)
downloadports-893fb68316815cc264847ed0f48bb23468f76236.tar.gz
ports-893fb68316815cc264847ed0f48bb23468f76236.zip
64-bit and minor bug fixes.
Submitted by: Matthias Andree <matthias.andree@gmx.de>
Notes
Notes: svn path=/head/; revision=75402
Diffstat (limited to 'news')
-rw-r--r--news/leafnode/Makefile2
-rw-r--r--news/leafnode/files/patch-aa36
2 files changed, 37 insertions, 1 deletions
diff --git a/news/leafnode/Makefile b/news/leafnode/Makefile
index 9d073790a6b8..a8711e74b837 100644
--- a/news/leafnode/Makefile
+++ b/news/leafnode/Makefile
@@ -7,7 +7,7 @@
PORTNAME= leafnode
PORTVERSION= 1.9.33
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= news ipv6
MASTER_SITES= http://dl.sourceforge.net/sourceforge/leafnode/ \
http://www.dt.e-technik.uni-dortmund.de/~ma/${PORTNAME}/ \
diff --git a/news/leafnode/files/patch-aa b/news/leafnode/files/patch-aa
new file mode 100644
index 000000000000..c9b9890b32de
--- /dev/null
+++ b/news/leafnode/files/patch-aa
@@ -0,0 +1,36 @@
+
+$FreeBSD$
+
+--- fetchnews_check_date.c.orig Wed Feb 12 23:55:16 2003
++++ fetchnews_check_date.c Wed Feb 12 23:58:46 2003
+@@ -22,12 +22,20 @@
+ if (reply != 111) {
+ /* upstream does not support the DATE command, so ignore */
+ if (debugmode) {
+- syslog(LOG_DEBUG, "check_date: %s does not support DATE, "
++ syslog(LOG_DEBUG, "check_date: %s: does not support DATE, "
+ "reply %d, expected 111", servername, reply);
+ }
+ return;
+ }
+
++ if (lastline == NULL) {
++ if (debugmode) {
++ syslog(LOG_DEBUG, "check_date: %s: cannot parse lastline (NULL)",
++ servername);
++ }
++ return;
++ }
++
+ /* upstream supports the DATE command */
+ if (sscanf(lastline, "%*d %4d%2d%2d%2d%2d%2d",
+ &tm.tm_year, &tm.tm_mon, &tm.tm_mday,
+@@ -61,7 +69,7 @@
+ } else {
+ if (debugmode) {
+ syslog(LOG_DEBUG, "check_date: %s: server time %ld, our time %ld",
+- servername, t, to);
++ servername, (long)t, (long)to);
+ }
+ }
+ }