aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-02 12:09:22 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-02 12:09:22 +0000
commite0248212a2b811f6d0a123028246280315468328 (patch)
tree999f6c3eeb52ba567d93aae61277fcd9cff212b7 /news
parent85bb98973234cd04d15c35e28e75203e635bc3ce (diff)
downloadports-e0248212a2b811f6d0a123028246280315468328.tar.gz
ports-e0248212a2b811f6d0a123028246280315468328.zip
Add noffle 1.1.5, news server for low speed dial-up connections.
PR: 53889 Submitted by: Kirill Ponomarew <ponomarew@oberon.net>
Notes
Notes: svn path=/head/; revision=84039
Diffstat (limited to 'news')
-rw-r--r--news/Makefile1
-rw-r--r--news/noffle/Makefile73
-rw-r--r--news/noffle/distinfo1
-rw-r--r--news/noffle/pkg-descr8
-rw-r--r--news/noffle/pkg-message7
-rw-r--r--news/noffle/pkg-plist18
6 files changed, 108 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index df12796ad1a7..cdaf0deee6d4 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -50,6 +50,7 @@
SUBDIR += nntp
SUBDIR += nntpbtr
SUBDIR += nntpcache
+ SUBDIR += noffle
SUBDIR += p5-Gateway
SUBDIR += p5-NNTPClient
SUBDIR += p5-News-Article
diff --git a/news/noffle/Makefile b/news/noffle/Makefile
new file mode 100644
index 000000000000..533169ae0401
--- /dev/null
+++ b/news/noffle/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: noffle
+# Date created: 28.06.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= noffle
+PORTVERSION= 1.1.5
+CATEGORIES= news
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= News server for low speed dial-up connections
+
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_ARGS+=--with-configfile=${LOCALBASE}/etc/noffle.conf \
+ --with-usersfile=${LOCALBASE}/etc/noffle.users
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+SPOOL_DIR= /var/spool/noffle
+PLIST_SUB+= SPOOL_DIR=${SPOOL_DIR}
+
+MAN1= noffle.1
+MAN5= noffle.conf.5
+DOCS= ChangeLog docs/FAQ INSTALL docs/INTERNALS README \
+ docs/testing.txt docs/noffle.lsm
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|/etc/noffle.conf|${PREFIX}/etc/noffle.conf|g' \
+ ${WRKSRC}/docs/${PORTNAME}.1 \
+ ${WRKSRC}/docs/${PORTNAME}.conf.5
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} \
+ ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/docs/noffle.1 \
+ ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/docs/noffle.conf.5 \
+ ${PREFIX}/man/man5
+ ${INSTALL_DATA} ${WRKSRC}/noffle.conf.example \
+ ${PREFIX}/etc/noffle.conf.sample
+ @${ECHO} "
+ @${ECHO} "------------------------------------------------------------"
+ @${ECHO} "Sample of configuration file placed at"
+ @${ECHO} "${PREFIX}/etc/noffle.conf.sample"
+ @${ECHO} "------------------------------------------------------------
+ @${ECHO} "
+ @${MKDIR} ${SPOOL_DIR}
+ @${MKDIR} ${SPOOL_DIR}/data
+ @${MKDIR} ${SPOOL_DIR}/lock
+ @${MKDIR} ${SPOOL_DIR}/outgoing
+ @${MKDIR} ${SPOOL_DIR}/overview
+ @${MKDIR} ${SPOOL_DIR}/requested
+ @${CHOWN} -R news:news ${SPOOL_DIR}
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+post-install:
+ @${SED} -e "s:/usr/local:${PREFIX}:g" ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/news/noffle/distinfo b/news/noffle/distinfo
new file mode 100644
index 000000000000..3e50840f2fd2
--- /dev/null
+++ b/news/noffle/distinfo
@@ -0,0 +1 @@
+MD5 (noffle-1.1.5.tar.gz) = 43e0a2563b8dec6e4f36824ed4dc05d7
diff --git a/news/noffle/pkg-descr b/news/noffle/pkg-descr
new file mode 100644
index 000000000000..f4b6d73d3a69
--- /dev/null
+++ b/news/noffle/pkg-descr
@@ -0,0 +1,8 @@
+Noffle is a Usenet news server optimized for few users and low
+speed dial-up connections to the Internet. It acts as a server
+to news clients running on the local host, but gets its news
+feed by acting as a client to a remote server. Allows reading
+news offline with many news clients, even if they do not
+support offline reading by themselves.
+
+WWW: http://noffle.sourceforge.net
diff --git a/news/noffle/pkg-message b/news/noffle/pkg-message
new file mode 100644
index 000000000000..da487e076731
--- /dev/null
+++ b/news/noffle/pkg-message
@@ -0,0 +1,7 @@
+
+****************************************************************************
+To enable the noffle-daemon, add the following line to your /etc/inetd.conf:
+
+nntp stream tcp nowait news /usr/local/bin/noffle -r
+****************************************************************************
+
diff --git a/news/noffle/pkg-plist b/news/noffle/pkg-plist
new file mode 100644
index 000000000000..63ae3fa308eb
--- /dev/null
+++ b/news/noffle/pkg-plist
@@ -0,0 +1,18 @@
+bin/noffle
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/INTERNALS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/noffle.lsm
+%%PORTDOCS%%%%DOCSDIR%%/testing.txt
+etc/noffle.conf.sample
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@cwd /
+@exec mkdir -p %%SPOOL_DIR%%
+@exec mkdir -p %%SPOOL_DIR%%/data
+@exec mkdir -p %%SPOOL_DIR%%/lock
+@exec mkdir -p %%SPOOL_DIR%%/outgoing
+@exec mkdir -p %%SPOOL_DIR%%/overview
+@exec mkdir -p %%SPOOL_DIR%%/requested
+@unexec rm -rf %%SPOOL_DIR%%