aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-11-19 15:56:24 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-11-19 15:56:24 +0000
commita4d37b1b849ac9731ea6a375264eaaf030dceb79 (patch)
treee1eb7ef8f08c8f598b9d0189183178bc5b20c08a /news
parent790ffe327f18c9603f8459cd01ef1071282ac5ea (diff)
downloadports-a4d37b1b849ac9731ea6a375264eaaf030dceb79.tar.gz
ports-a4d37b1b849ac9731ea6a375264eaaf030dceb79.zip
- Fix gcc33 problems
Notes
Notes: svn path=/head/; revision=94387
Diffstat (limited to 'news')
-rw-r--r--news/fidogate/Makefile28
-rw-r--r--news/fidogate/files/patch-log.c12
-rw-r--r--news/fidogate/files/patch-prototypes.h11
3 files changed, 51 insertions, 0 deletions
diff --git a/news/fidogate/Makefile b/news/fidogate/Makefile
index 4367c4bbafe6..f3ca9f697ea9 100644
--- a/news/fidogate/Makefile
+++ b/news/fidogate/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fidogate
PORTVERSION= 4.4.9
+PORTREVISION= 1
CATEGORIES= news mail
MASTER_SITES= ftp://ftp.fidogate.org/pub/fidogate/ \
ftp://ftp.fu-berlin.de/unix/news/fidogate/ \
@@ -31,12 +32,39 @@ DOCLIST= fidogate.texi fidogate.txt gatebau94.txt kludge-rfc.doc \
template.html fido howto misc rfc gatebau/msgid.sgml \
gatebau/msgid.tex gatebau/msgid.txt
+FIXME= src/common/aliases.c src/common/binkley.c \
+ src/common/config.c src/common/crc32.c \
+ src/common/file.c src/common/flo.c \
+ src/common/fopen.c src/common/hosts.c \
+ src/common/lock.c src/common/log.c \
+ src/common/mail.c src/common/message.c \
+ src/common/outpkt.c src/common/packet.c \
+ src/common/routing.c src/common/sequencer.c \
+ src/common/tick.c src/charset/charset.c \
+ src/areafix/ftnaf.c src/areafix/areafix.c \
+ src/areafix/ftnafmail.c src/areafix/ftnafpkt.c \
+ src/areafix/ftnafutil.c src/ffx/ffx.c \
+ src/ffx/ffxqt.c src/gate/ftn2rfc.c \
+ src/gate/ftnin.c src/gate/rfc2ftn.c \
+ src/gate/ftnmail.c src/tick/ftnhatch.c \
+ src/tick/ftntick.c src/toss/ftn2ftn.c \
+ src/toss/ftnexpire.c src/toss/ftnpack.c \
+ src/toss/ftnroute.c src/toss/ftntoss.c \
+ src/toss/history.c src/util/ftnlog.c \
+ src/util/ftnflo.c
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 300000
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-perl
.endif
+post-patch:
+.for i in ${FIXME}
+ ${PERL5} -pi -e "s=([ ])log[(]=\\1log_fg(=" ${WRKSRC}/${i}
+ @grep "log_fg" ${WRKSRC}/${i}
+.endfor
+
pre-configure:
@${PERL5} -pi -e "s=.{PREFIX}=${PREFIX}=g" ${WRKSRC}/config.make
.if defined(FIDOGATE_RUNAS)
diff --git a/news/fidogate/files/patch-log.c b/news/fidogate/files/patch-log.c
new file mode 100644
index 000000000000..ad30c71429b0
--- /dev/null
+++ b/news/fidogate/files/patch-log.c
@@ -0,0 +1,12 @@
+--- src/common/log.c.orig Sun Feb 16 16:38:56 2003
++++ src/common/log.c Wed Nov 19 16:24:20 2003
+@@ -69,8 +69,8 @@
+ char *strerror(int errnum)
+ {
+ #ifndef OS2
+- extern int sys_nerr;
+ # ifndef __FreeBSD__
++ extern int sys_nerr;
+ extern char *sys_errlist[];
+ # endif
+ #endif
diff --git a/news/fidogate/files/patch-prototypes.h b/news/fidogate/files/patch-prototypes.h
new file mode 100644
index 000000000000..db83cb7f9195
--- /dev/null
+++ b/news/fidogate/files/patch-prototypes.h
@@ -0,0 +1,11 @@
+--- src/include/prototypes.h.orig Sun Feb 16 16:39:01 2003
++++ src/include/prototypes.h Wed Nov 19 16:12:12 2003
+@@ -270,7 +270,7 @@
+ extern int no_debug;
+
+ char *strerror (int);
+-void log (const char *, ...)
++void log_fg (const char *, ...)
+ __attribute__ ((format (printf, 1, 2)));
+ void debug (int, const char *, ...)
+ __attribute__ ((format (printf, 2, 3)));