aboutsummaryrefslogtreecommitdiff
path: root/palm/gnomepilot
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
commit19a718ac4c38750e766de7abf027f0491981495d (patch)
tree8fad9fa05facfd939ca92589f047e5224dffd236 /palm/gnomepilot
parent47c68887b223642a73baccd0fa69c8caf7845044 (diff)
downloadports-19a718ac4c38750e766de7abf027f0491981495d.tar.gz
ports-19a718ac4c38750e766de7abf027f0491981495d.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Notes
Notes: svn path=/head/; revision=62821
Diffstat (limited to 'palm/gnomepilot')
-rw-r--r--palm/gnomepilot/Makefile11
-rw-r--r--palm/gnomepilot/pkg-plist4
2 files changed, 5 insertions, 10 deletions
diff --git a/palm/gnomepilot/Makefile b/palm/gnomepilot/Makefile
index f571d0ac1661..573503503eeb 100644
--- a/palm/gnomepilot/Makefile
+++ b/palm/gnomepilot/Makefile
@@ -22,7 +22,9 @@ LIB_DEPENDS= pisock.4:${PORTSDIR}/palm/pilot-link
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs libglade gnomevfs libpanel \
+ libcapplet
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
@@ -31,11 +33,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gpilot-install-file.1
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/palm/gnomepilot/pkg-plist b/palm/gnomepilot/pkg-plist
index bfcec3dcf4d4..21f584b2ba1e 100644
--- a/palm/gnomepilot/pkg-plist
+++ b/palm/gnomepilot/pkg-plist
@@ -78,9 +78,5 @@ share/locale/tr/LC_MESSAGES/gnome-pilot.mo
share/locale/uk/LC_MESSAGES/gnome-pilot.mo
share/locale/zh_TW/LC_MESSAGES/gnome-pilot.mo
@dirrm share/gnome/gnome-pilot/glade
-@dirrm share/gnome/gnome-pilot/conduits
-@dirrm share/gnome/gnome-pilot
-@dirrm lib/gnome-pilot/conduits
-@dirrm lib/gnome-pilot
@dirrm include/libgpilotdCM
@dirrm include/gpilotd