aboutsummaryrefslogtreecommitdiff
path: root/palm/pilot_makedoc
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1997-05-30 20:07:46 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1997-05-30 20:07:46 +0000
commit3ee973c63bc80c07d7a21189640fc167ceb46856 (patch)
tree0e28e1f7b2aec664a31314e9650ee3103b1b88cc /palm/pilot_makedoc
parentbe30bbf9457b0dc7832c7c05700dbaa9ceb40d08 (diff)
downloadports-3ee973c63bc80c07d7a21189640fc167ceb46856.tar.gz
ports-3ee973c63bc80c07d7a21189640fc167ceb46856.zip
Import of a util to create PalPilot Doc format files from text files
Notes
Notes: svn path=/head/; revision=6646
Diffstat (limited to 'palm/pilot_makedoc')
-rw-r--r--palm/pilot_makedoc/Makefile26
-rw-r--r--palm/pilot_makedoc/distinfo1
-rw-r--r--palm/pilot_makedoc/files/Makefile12
-rw-r--r--palm/pilot_makedoc/files/patch-aa24
-rw-r--r--palm/pilot_makedoc/pkg-comment1
-rw-r--r--palm/pilot_makedoc/pkg-descr4
-rw-r--r--palm/pilot_makedoc/pkg-plist1
7 files changed, 69 insertions, 0 deletions
diff --git a/palm/pilot_makedoc/Makefile b/palm/pilot_makedoc/Makefile
new file mode 100644
index 000000000000..c8d9ea3af2f0
--- /dev/null
+++ b/palm/pilot_makedoc/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pilot_makedoc
+# Version required: 0.7
+# Date created: May 10th 1997
+# Whom: jfitz@FreeBSD.ORG
+#
+# $Id$
+#
+
+PKGNAME= pilot_makedoc-0.7
+CATEGORIES= textproc
+MASTER_SITES= http://www.concentric.net/~rbram/
+DISTFILES= makedoc7.cpp
+
+NO_WRKSUBDIR= YES
+
+ALL_TARGET= pilot_makedoc
+
+do-extract:
+ @${MKDIR} -p ${WRKDIR}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}
+ @${CP} ${FILESDIR}/Makefile ${WRKDIR}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKDIR}/pilot_makedoc ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/palm/pilot_makedoc/distinfo b/palm/pilot_makedoc/distinfo
new file mode 100644
index 000000000000..ce778114d9ca
--- /dev/null
+++ b/palm/pilot_makedoc/distinfo
@@ -0,0 +1 @@
+MD5 (makedoc7.cpp) = 88baf21e5d27b0493ee0e004ce4f520e
diff --git a/palm/pilot_makedoc/files/Makefile b/palm/pilot_makedoc/files/Makefile
new file mode 100644
index 000000000000..7d9285dfbe21
--- /dev/null
+++ b/palm/pilot_makedoc/files/Makefile
@@ -0,0 +1,12 @@
+#
+# $Id$
+#
+
+CC= g++
+CFLAGS= -O2
+
+pilot_makedoc: makedoc7.cpp
+ ${CC} -o pilot_makedoc makedoc7.cpp
+
+#
+# EOF
diff --git a/palm/pilot_makedoc/files/patch-aa b/palm/pilot_makedoc/files/patch-aa
new file mode 100644
index 000000000000..29dc5263848c
--- /dev/null
+++ b/palm/pilot_makedoc/files/patch-aa
@@ -0,0 +1,24 @@
+--- makedoc7.cpp.orig Sat May 10 20:05:27 1997
++++ makedoc7.cpp Sat May 10 20:05:53 1997
+@@ -31,11 +31,7 @@
+ // ver 0.7 change header and record0 to structs
+ // ver 0.7a minor mispellings and portability issues
+
+-#ifdef sparc
+-# ifndef UNIX
+-# define UNIX 1
+-# endif
+-#endif
++#define UNIX 1
+
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -588,7 +584,7 @@
+ printf("\n -n builds the .prc file without compression");
+ printf("\n -b option compresses/decompresses binary");
+ #if UNIX
+- printf("\n");
++ printf("\n\n");
+ #endif
+ exit(1);
+ }
diff --git a/palm/pilot_makedoc/pkg-comment b/palm/pilot_makedoc/pkg-comment
new file mode 100644
index 000000000000..59aeeb63b728
--- /dev/null
+++ b/palm/pilot_makedoc/pkg-comment
@@ -0,0 +1 @@
+converts text into the Doc format used by PalmPilots.
diff --git a/palm/pilot_makedoc/pkg-descr b/palm/pilot_makedoc/pkg-descr
new file mode 100644
index 000000000000..e15c150dbdb8
--- /dev/null
+++ b/palm/pilot_makedoc/pkg-descr
@@ -0,0 +1,4 @@
+makedoc is a utility for compressing and converting text files into the Doc
+standard. Doc is a program by Rick Bram (see
+http://www.concentric.net/~rbram/) to display text files on many popular
+PDAs, such as the USR PalmPilot.
diff --git a/palm/pilot_makedoc/pkg-plist b/palm/pilot_makedoc/pkg-plist
new file mode 100644
index 000000000000..e473bd8e6310
--- /dev/null
+++ b/palm/pilot_makedoc/pkg-plist
@@ -0,0 +1 @@
+bin/pilot_makedoc